Вход | Регистрация

1С:Предприятие ::

Метки: 

где ловится событие - выбор из справочника

Я
   lamme
 
29.08.18 - 13:09
1С УФ
на форме - поле (тип- справочник)
Открываю справочник  с отбором

&НаКлиенте
Процедура ПеревозичкНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    
    СтандартнаяОбработка = ложь;
    
    Форма = ОткрытьФорму("Справочник.Партнеры.ФормаВыбора")//Открываем форму

    
    ОтборВладелец =Форма.Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));//Добавлям отбор

    //

    ОтборВладелец.ВидСравнения = ВидСравненияКомпоновкиДанных.ВИерархии;//Как будем сравнивать

    ОтборВладелец.Использование = Истина;// Устанавливаем галку использованияНовый ПолеКомпоновкиДанных("Номенклатура")

    ОтборВладелец.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Ссылка");//По какому реквизиту будем делать отбор

    ОтборВладелец.ПравоеЗначение = ВернутьЗначениеОтбораГРуппы()//Объект.Контрагент; // И само значение отбора    

КонецПроцедуры



Открылось


Где поймать на форме документа  - что выбралось ?
Какое событие у какого объекта?
у формы ?
у поля ?
 
 
   Cyberhawk
 
1 - 29.08.18 - 13:09
ОбработкаВыбора
   lamme
 
2 - 29.08.18 - 13:20
ОбработкаВыбора - у формы ?
или
ПеревозичкОбработкаВыбора - ?
   lamme
 
3 - 29.08.18 - 13:20
ни там , ни там не ловиться
   Cyberhawk
 
4 - 29.08.18 - 13:20
1
   lamme
 
5 - 29.08.18 - 13:21
не ловиться
   Cyberhawk
 
6 - 29.08.18 - 13:24
А зачем ты после открытия формы к ней обращаешься?
   lamme
 
7 - 29.08.18 - 13:25
(6)
не понял ...
вроде бы - просто открываю форму
устанавливаю на ней отборы
   Cyberhawk
 
8 - 29.08.18 - 13:31
Так ты дзен не познаешь
https://its.1c.ru/db/pubv8devui#content:300:hdoc
   lamme
 
9 - 29.08.18 - 13:34
дзен без логин пароля не дзениться
   Mort
 
10 - 29.08.18 - 13:35
Ещё дзен не дзенится без этого:

http://infoogle.ru/tsya_i_tsya_v_glagolax_kak_pisat_pravilno.html
 
 Рекламное место пустует
   lamme
 
11 - 29.08.18 - 13:36
будьте добры, скиньте текст из
https://its.1c.ru/db/pubv8devui#content:300:hdoc
кому не сложно
   Cyberhawk
 
12 - 29.08.18 - 13:37
"без логин пароля" // Какие проблемы получить?
   spiller26
 
13 - 29.08.18 - 13:39
(0) Вот тут у тебя проблема.

 СтандартнаяОбработка = ложь;

ты выключаешь возврат
   spiller26
 
14 - 29.08.18 - 13:45
(0) Если ты выключаешь стандартную обработку, то нужно обозначить, что делать после.

Вот тебе простенький код, разобраться не трудно.


&НаКлиенте
Процедура КонтаргентНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    
    СтандартнаяОбработка = ложь;
    ОписаниеОповещения = Новый ОписаниеОповещения("ВыполнитьПослеЗакрытияВыбораКонтрагента", ЭтаФорма);
    Форма = ОткрытьФорму("Справочник.Контрагенты.ФормаВыбора", , ЭтаФорма,,,, ОписаниеОповещения);
    //тут можешь наваять отбор

    
КонецПроцедуры

&НаКлиенте
Процедура ВыполнитьПослеЗакрытияВыбораКонтрагента(ВыбранноеЗначение, ДополнительныеПараметры) Экспорт
    // Вставить содержимое обработчика.

КонецПроцедуры
   lamme
 
15 - 29.08.18 - 13:47
(14)
спасибо.


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует