Вход | Регистрация

1С:Предприятие ::

Метки: 

Булево в 1С

Я
   Trixietheflowskigod
 
28.08.18 - 09:43
Добрый день,
У меня возник вопрос как проверить значение Константы (тип булево) ?
По логике работы
Есть константа на которой пользователь устанавливает галочку что является истиной, далее есть регламентное задание в подсистеме в коде которого проводится проверка

Если Константы.Тех_ОтключениеПодсистемы = Истина 
Тогда Возврат;
КонецЕсли;

То есть если стоит галочка то Возврат Иначе он дальше будет выополнять процедуру.

Но на деле 1С игнорирует данный код и идет дальше, подправьте или подскажите пожалуйста в чем ошибка
 
 
   мистер игрек
 
1 - 28.08.18 - 09:44
Константы.Тех_ОтключениеПодсистемы.ПолучитьЗначение() = Истина
   Гипервизор
 
2 - 28.08.18 - 09:47
(1) Просто Получить()
   Trixietheflowskigod
 
3 - 28.08.18 - 09:53
Если Константы.Тех_ОтключениеПодсистемы.Получить()=Истина
    Тогда Возврат; 
    КонецЕсли;
   Trixietheflowskigod
 
4 - 28.08.18 - 09:53
Спасибо вылетело из головы эта получить
   Ненавижу 1С
 
5 - 28.08.18 - 10:09
и вообще так:

Если Константы.Тех_ОтключениеПодсистемы.Получить()
    Тогда Возврат; 
    КонецЕсли;
   Aleksey
 
6 - 28.08.18 - 10:10
(5) А если там неопределено?
   Ненавижу 1С
 
7 - 28.08.18 - 10:12
(6) в булевой константе?
   hhhh
 
8 - 28.08.18 - 10:31
(7) может быть. или null
   Ненавижу 1С
 
9 - 28.08.18 - 10:36
(8) не бреши
   dezss
 
10 - 28.08.18 - 10:37
(8) тогда он ругнется уже на Константы.Тех_ОтключениеПодсистемы, так как ее не существует)
 
 Рекламное место пустует
   Cyberhawk
 
11 - 28.08.18 - 10:53
(6) В параметре сеанса такое может быть. Но не в константе.


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует