Вход | Регистрация


1С:Предприятие ::

Метки: 

Ошибка работы в интернет Не могу установить соединение

Я
   pankrat00
 
24.08.18 - 14:14
Доброго времени суток друзья! Пишу выгрузку данных из 1с в телеграм.

Код:
ПроксиСервер        = "socks5://salutemsupplements-com.nh-serv.co.uk"; 
ПроксиПорт            = 3060;

 ИнтернетПрокси = Новый ИнтернетПрокси;
 ИнтернетПрокси.Установить("https", Объект.ПроксиСервер, Объект.ПроксиПорт, , );

 ЗащищенноеСоединение = Новый ЗащищенноеСоединениеOpenSSL();
 Ресурс = "bot" + Объект.Token + "/sendMessage?chat_id=" + СтрЗаменить(Формат(Объект.ID, "ЧДЦ=; ЧС=; ЧРГ=."), ".", "") + "&text= " + ТекстСообщения;
 Соединение  =  Новый HTTPСоединение("api.telegram.org",443,,,ИнтернетПрокси,,ЗащищенноеСоединение);
 Запрос = Новый HTTPЗапрос(Ресурс);
 Ответ = Соединение.Получить(Запрос);    

Проверил на локальной машине все ок, сообщения в телеграм приходят. При попытке выполнить тоже на удаленном сервере (там база клиент - сервер) выдает "Не могу установить соединение". Антивирус отключал, фаерволов ни каких нет, права у пользователя USR1Cv8 (агент сервера запущен под ним) есть. Что еще может блокировать? Друзья прошу помощи.

Платформа: 8.3.12.1469
Конфигурация: 1С:Фитнес клуб КОРП (УФ)
 
 
   Cyberhawk
 
1 - 24.08.18 - 14:16
Ищи причину на хосте или дальше
   Cyberhawk
 
2 - 24.08.18 - 14:17
"фаерволов ни каких нет" // Что-то ты явно брешешь
   dezss
 
3 - 24.08.18 - 14:18
(0) хм...а там своей прокси нет?
код выполняется на сервере или на клиенте?
   pankrat00
 
4 - 24.08.18 - 14:19
(2) Точно нет. Админ все проверил.
(3) Код на сервере. (пробовал и на клиенте результат тот же)
   Cyberhawk
 
5 - 24.08.18 - 14:20
Ну-ну
   dezss
 
6 - 24.08.18 - 14:22
(4) небось днс от гугла?
попробуй от яндекса...ну или наоборот)))
   dezss
 
7 - 24.08.18 - 14:24
(6) + в общем, косяк в сетке...
попробуй там попинговать, трасерты попускай...
   pankrat00
 
8 - 24.08.18 - 14:28
(7) Все пингуется.
   trdm
 
9 - 24.08.18 - 14:29
Протокол не поддерживается на сервере.
Было такое.
   dezss
 
10 - 24.08.18 - 14:30
(8) прокси тоже? О_о
 
 Рекламное место пустует
   dezss
 
11 - 24.08.18 - 14:30
кстати, а нафига прокси?
   pankrat00
 
12 - 24.08.18 - 14:32
Сделал так:

telnet salutemsupplements-com.nh-serv.co.uk 3060

Написал: Подключение к узлу утеряно.
   pankrat00
 
13 - 24.08.18 - 14:33
(11) А какие варианты еще к API телеграмма подключиться?
   pankrat00
 
14 - 24.08.18 - 14:35
(9) Как решили?
   dezss
 
15 - 24.08.18 - 15:59
(12) а на том компе, где все гут?
   dezss
 
16 - 24.08.18 - 15:59
(13) а без прокси что, не цепляется?
   dezss
 
17 - 24.08.18 - 16:00
у меня ping api.telegram.org проходит
   Вафель
 
18 - 24.08.18 - 16:08
разве 1с поддерживает socks5 проки?
   dezss
 
19 - 24.08.18 - 16:10
(18) ну если чувак не врет, то на одном компе точно работает
   pankrat00
 
20 - 24.08.18 - 16:12
Друзья, работает! Можете проверить код в сообщении (0) прокси живой.
   pankrat00
 
21 - 24.08.18 - 16:14
Могу ссылку дать на обработку для проверки, мне тож интересно взлетит на других машинах или нет.
   dezss
 
22 - 24.08.18 - 16:14
(20) что было не так, после чего заработало?
   dezss
 
23 - 24.08.18 - 16:16
(21) ссылку давай
   pankrat00
 
24 - 24.08.18 - 16:16
(22) Не заработало. Это я на сообщение (18) про socks5. Ответил.
   dezss
 
25 - 24.08.18 - 16:16
(23) + только нужен еще id чата
   dezss
 
26 - 24.08.18 - 16:17
(24) так телнет нормально подключается с того компа, на котором все работает?
   pankrat00
 
27 - 24.08.18 - 16:22
(23) Ссылка на обработку (УФ). https://yadi.sk/d/fx-mn1X53aXeYo
Бота создай своего.
   dezss
 
28 - 24.08.18 - 16:22
(27) ой не...вот еще я ботов в пятницу не создавал)))
   pankrat00
 
29 - 24.08.18 - 16:24
(26) Писал в (12)
telnet salutemsupplements-com.nh-serv.co.uk 3060

Подключение к узлу утеряно.
   arsik
 
30 - 24.08.18 - 16:29
Ой да разверните уже локально MTPROTO Proxy и цепляйтесь к нему.
   pankrat00
 
31 - 24.08.18 - 16:30
(28) Сделал тестового бота mistatest_bot, добавишь себе и ИД свой пропишешь.

https://yadi.sk/d/Kje3V22f3aXfS3
   Cyberhawk
 
32 - 24.08.18 - 16:31
Сообщение "Подключение к узлу утеряно" ничего не говорит о том, что коннект есть.
У меня, например, коннект успешно проходит, а такое сообщение всегда выдается при разрыве, инициированном с клиента.
   Вафель
 
33 - 24.08.18 - 16:31
(30) из 1с?
 
 
   dezss
 
34 - 24.08.18 - 16:35
(31) да я уже сделал себе...
имхо, с проксей что-то не так
   dezss
 
35 - 24.08.18 - 17:05
(31) через твой прокси не работает...через локально запущенный тор-прокси работает



Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует