Вход | Регистрация

1С:Предприятие ::

Метки: 

1С и .CSV формат ячейки

Я
   Сергей Роспатнюк
 
23.08.18 - 10:16
Вот что выходит а должно быть 40817810738050091838 все дело в том что при записи 1С пишет с форматом общий а нужно текст как это сделать не пойму в сп все методы пересмотрел можно добавить ' и тогда отображается как строка но как убрать ее потом тоже не знаю подскажите что можно сделать.

https://yadi.sk/i/R22B_SYJ3aUzUY

НаКлиенте
Процедура Выгрузить(Команда)
    Данные = ЗапросСервер();
    Начисления = Данные.ДанныеЗапросаНачислений;
    
    Если Данные.ДанныеЗапросаНачислений.Количество() = 0 Тогда
        Сообщить("Не выбран ни один сотрудник",СтатусСообщения.Информация); 
        Возврат;
    КонецЕсли;
    
    
    _НомерДоговора = Данные.ДанныеОрганизации.Найти("Номер договора СБ", "Вид");
    Если _НомерДоговора = Неопределено Тогда
        _НомерДоговора = "";
    Иначе
        _НомерДоговора = Строка(_НомерДоговора);
    КонецЕсли;    
    _ДатаДоговораСтр = Данные.ДанныеОрганизации.Найти("Дата договора СБ","Вид");
    Если _ДатаДоговораСтр = Неопределено Тогда
        _ДатаДоговораСтр = "";
    Иначе
        _ДатаДоговораСтр = _ДатаДоговораСтр.Представление;
    КонецЕсли;    
    _НомерБанковскогоСчетаПредприятия = Данные.ДанныеОрганизации.Найти("Расчетный счет СБ","Вид");
        
    ФайлЗаписи = Новый ТекстовыйДокумент();
    _Номер = 0; 
    _ИтогоСумма = 0;
    Для Каждого _Строка ИЗ Начисления Цикл
        _Лицо = _Строка.ФизЛицо;
        _Счет = _Строка.НомерЛицевогоСчета; 
        //

        _Фамилия  = СокрЛП(_Строка.Фамилия);
        _Имя         = СокрЛП(_Строка.Имя);
        _Отчество = СокрЛП(_Строка.Отчество);
        //

        _Номер = _Номер + 1; 
        //40817810738050091838;Скалыга;Евгений;Александрович;4015,88

        Стр = "'" + _Счет + ";" + _Фамилия + ";" + _Имя + ";" + _Отчество + ";" +  Формат(_Строка.Сумма,"ЧДЦ=2;ЧГ=0");
        ФайлЗаписи.ДобавитьСтроку(Стр);
        _Номер = _Номер + 1;
         _ИтогоСумма = _ИтогоСумма + _Строка.Сумма ;
    КонецЦикла; 
    ФайлЗаписи.Записать(Объект.Файл, "windows-1251");
     Сообщить("Выгрузка завершена!",СтатусСообщения.Информация);    
КонецПроцедуры
 
 
   ам794123
 
1 - 23.08.18 - 10:22
в xml выгружай
   Cool_Profi
 
2 - 23.08.18 - 10:29
В ЦСВ нет формата. Это просто текстовый файл. И каждый инструмент волен воспринимать его так, как ему надо
   Сергей Роспатнюк
 
3 - 23.08.18 - 10:29
(1) а можно формат файла оставить .csv и при этом сделать как надо?
   hhhh
 
4 - 23.08.18 - 10:31
(3) Стр = "'"  зачем такая странная кавычка?
   Остап Сулейманович
 
5 - 23.08.18 - 10:32
(3) Оно и так "как надо". В CSV оно так и есть.
   Сергей Роспатнюк
 
6 - 23.08.18 - 10:36
(4) она делает так https://yadi.sk/i/aqnNZj7e3aV3kR
   Kigo_Kigo
 
7 - 23.08.18 - 10:36
это просто так ексель его воспринимает, открой тесктом, там все нормально, если это файл для передачи в банк, то и банковская система его воспримет как надо
   ам794123
 
8 - 23.08.18 - 10:38
(3)
Можно, перепиши выгрузку на СКД. А результат напрямую записать в текстовый файл:
    Результат = Новый ТабличныйДокумент;
    СхемаКомпоновкиДанных = ЭтотОбъект.ПолучитьМакет("Макет");
    КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
    МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, СхемаКомпоновкиДанных.НастройкиПоУмолчанию);
    ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
    ПроцессорКомпоновки.Инициализировать(МакетКомпоновки, , , Истина);
    ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
    ПроцессорВывода.УстановитьДокумент(Результат);
    ПроцессорВывода.Вывести(ПроцессорКомпоновки);
    Результат.Записать(ИмяФайла, ТипФайлаТабличногоДокумента.TXT);
   Сергей Роспатнюк
 
9 - 23.08.18 - 10:46
(7) да это файл для передачи в банк так что думаю и менять походу не надо так как визуально просматривать и проверять в нем что то ни кто не будет.
   Михаил Козлов
 
10 - 23.08.18 - 10:47
(8) И чем это поможет? У него и так текстовый файл. Только расширение CSV.
 
 Рекламное место пустует
   XMMS
 
11 - 23.08.18 - 10:47
(0)Если вы откроете файл текстовым редактором, то скорее всего там будет всё корректно. Нет?
Обычно сам эксель так выводит числа.
А про csv правильно написали, там нет формата.
   Михаил Козлов
 
12 - 23.08.18 - 10:49
(9) Попробуйте в Экселе забить в ячейку только цифры, сохранить как CSV и открыть потом Экселем. Увидите такую-же хрень.
   Сергей Роспатнюк
 
13 - 23.08.18 - 10:50
(11) все верно текстовый отображает как надо
   Сергей Роспатнюк
 
14 - 23.08.18 - 10:51
(12) я понял это сам эксель преобразовывает в такой вид


Список тем форума
Рекламное место пустует Рекламное место пустует
Кaк может человек ожидaть, что его мольбaм о снисхождении ответит Тот, кто превыше, когдa сaм он откaзывaет в милосердии тем, кто ниже его? Петр Трубецкой
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует