Вход | Регистрация

1С:Предприятие ::

Метки: 

Запись значения в реквизит формы

Я
   Сергей Роспатнюк
 
22.08.18 - 14:47
Подскажите как можно записать значение пробовал РеквизитФормыВЗначение("Объект") не получилось 

&НаКлиенте
Процедура ФайлОткрытие(Элемент, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    Если Не ВыборФайла(Элемент) Тогда
        Возврат;
    КонецЕсли;
КонецПроцедуры

&НаКлиенте
Функция ВыборФайла(Элемент, ПроверятьСуществование = Ложь, Фильтр = "Файл данных (*.csv)|*.csv", 
    Расширение = "csv", Заголовок = "Выберите файл", ПолноеИмяПоУмолчанию = "") Экспорт
    Режим = РежимДиалогаВыбораФайла.Открытие;
    ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(Режим);
    ДиалогОткрытияФайла.ПроверятьСуществованиеФайла =    ПроверятьСуществование;
    ДиалогОткрытияФайла.Фильтр                      =    Фильтр;
    ДиалогОткрытияФайла.Заголовок                   =    Заголовок;
    ДиалогОткрытияФайла.ПредварительныйПросмотр     =    Ложь;
    ДиалогОткрытияФайла.Расширение                  =    Расширение;
    ДиалогОткрытияФайла.ИндексФильтра               =    0;
    Если ЗначениеЗаполнено(Элемент.ТекстРедактирования) Тогда
        ДиалогОткрытияФайла.ПолноеИмяФайла              =    Элемент.ТекстРедактирования;
    Иначе
        ДиалогОткрытияФайла.ПолноеИмяФайла              =    ПолноеИмяПоУмолчанию;
    КонецЕсли;
    Если ДиалогОткрытияФайла.Выбрать() Тогда
        Элемент.ТекстРедактирования = 
ДиалогОткрытияФайла.ПолноеИмяФайла;
        Возврат Истина;
    Иначе
        Возврат Ложь;
    КонецЕсли;
КонецФункции

ОШИБКА
{ВнешняяОбработка.ВыгрузкаВСберБанкOnLine.Форма.Форма.Форма(27)}: Поле объекта недоступно для записи (ТекстРедактирования)
        Элемент.ТекстРедактирования = ДиалогОткрытияФайла.ПолноеИмяФайла;
 
 
   Сергей Роспатнюк
 
1 - 22.08.18 - 14:48
(0) ну и то что использование только чтение я в курсе )))
   Fedor-1971
 
2 - 22.08.18 - 14:50
(0) ТекстРедактирования = ДиалогОткрытияФайла.ПолноеИмяФайла
Зачем что-то писать в Элемент формы? Пиши сразу в реквизит, он связан с Элементом через поле Данные.
   Сергей Роспатнюк
 
3 - 22.08.18 - 14:55
(2) {ВнешняяОбработка.ВыгрузкаВСберБанкOnLine.Форма.Форма.Форма(27)}: Значение не является значением объектного типа (Значение)
         Файл.Значение = ДиалогОткрытияФайла.ПолноеИмяФайла;
   Сергей Роспатнюк
 
4 - 22.08.18 - 14:58
(2) Забыл уточнить у меня Управляемые формы ЗУП3.1 и в зуп2.5 я могу найти поле данные у реквизита формы а вот в тройке есть ПутьКДанным и там стоит Объект.Файл
   Fedor-1971
 
5 - 22.08.18 - 15:02
(3) Объясни мне у реквизита Файл, есть свойство Значение?
Файл это структура или что?

Просто присвоить Файл = диалог ... уже совсем не катит?
   Timon1405
 
6 - 22.08.18 - 15:06
покажите скрин формы в конфигураторе с активной вкладкой "реквизиты"
   Сергей Роспатнюк
 
7 - 22.08.18 - 15:07
(5) Файл = диалог присвоил но на форму не вывелось
   Сергей Роспатнюк
 
8 - 22.08.18 - 15:12
   Fedor-1971
 
9 - 22.08.18 - 15:16
(8) и какой из 2 Файлов вынесен на форму?
Объект.Файл или реквизит Файл?
Что вынес, тому и присваивай.
   Сергей Роспатнюк
 
10 - 22.08.18 - 15:16
(5) Файл это строка в которой должно быть E:\1c_bases\ИмяПользователя\ЗУП 3.1\ИмяФайла.csv
 
 Рекламное место пустует
   Сергей Роспатнюк
 
11 - 22.08.18 - 15:19
все заработало благодарю за помощь тема закрыта.


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует