Вход | Регистрация

1С:Предприятие ::

Метки: 

отображение Состояние процесса выполнения на клиенте.

Я
   spiller26
 
21.08.18 - 09:19
Делаю разворачивание дерева значений. Пользователю нужно показывать что выполняется, а не "зависло".
Проблема в том, что дерево блокируется и выходит окно процесса, но они серые.

&НаКлиенте
Процедура РаскрытьВсеВетки(Команда)
    
    ПодключитьОбработчикОжидания("РазвернутьДерево", 1, Истина);

КонецПроцедуры

&НаКлиенте 
Процедура РазвернутьДерево()
    
    Состояние("Разворачивание дерева",,, БиблиотекаКартинок.ДлительнаяОперация48);
    //

    КоллекцияЭлементов = ДеревоОстатков.ПолучитьЭлементы();
    Для Каждого ЭлементКоллекции Из КоллекцияЭлементов Цикл
        Элементы.ДеревоОстатков.Развернуть(ЭлементКоллекции.ПолучитьИдентификатор(), Истина);
    КонецЦикла;
    
    ОтключитьОбработчикОжидания("РазвернутьДерево");
    
КонецПроцедуры
 
 
   Cyberhawk
 
1 - 21.08.18 - 09:20
Зачем же ты однократный обработчик целую секунду ждешь? Делай 0.1
   Cyberhawk
 
2 - 21.08.18 - 09:20
И нахера отключаешь его еще?
   spiller26
 
3 - 21.08.18 - 09:24
(2) После выполнения выключил.
   Cyberhawk
 
4 - 21.08.18 - 09:27
Не в коня корм
   spiller26
 
5 - 21.08.18 - 09:27
(2,3) убрал ОтключитьОбработчикОжидания

С отображением что?
   Cyberhawk
 
6 - 21.08.18 - 09:29
Каким отображением?
   spiller26
 
7 - 21.08.18 - 09:30
(6) состояние, т.е. "Кошака"
   spiller26
 
8 - 21.08.18 - 09:52
По ходу нужно ваять свою форму для отображения.
   spiller26
 
9 - 21.08.18 - 09:58
На файловой какой то глюк с отображением, на клиент-серверной  отображение прошло успешно.
С анимацией нужно отдельное окно писать.
   s03
 
10 - 21.08.18 - 10:02
(0) а если не обходить строки, а сразу всё дерево развернуть, быстрее не будет?

&НаКлиенте
Процедура РазвернутьВсеДерево(Команда)
   Элементы.ДеревоОстатков.Развернуть(0,Истина);    
КонецПроцедуры
 
 Рекламное место пустует


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует