Вход | Регистрация

1С:Предприятие ::

Метки: 

Помогите с: НачатьПомещениеФайла() в веб клиенте 1С 8.3.11

Я
   9451523
 
20.08.18 - 11:04
Привет Всем

Обновили платформу с 8.2 на 8.3 , есть справочник Модели в котором в которм добавляется и сохраняется файл картинки,

при работе в обыкновенном режиме все отрабатывает нормально, а вот при использовании веб клиента стало ругатся на модальные окна,

я переписал процедуру сейчас все открывает и показывает нормально но при записи не сохраяется рисунок в веб клиенте, опыта пока мало

подскажите где я ошибся?  вот код:



&НаКлиентеПроцедура Загрузить(Команда)

 

АдресВХранилище = "";

ВыбранноеИмяФайла = "";

#Если ВебКлиент Тогда            Оповещение = Новый ОписаниеОповещения("ОбработкаВыбораФайла",ЭтотОбъект);


НачатьПомещениеФайла(Оповещение, , ,Истина,УникальныйИдентификатор);

#Иначе                  ПоместитьФайл(АдресВХранилище, , ВыбранноеИмяФайла, , УникальныйИдентификатор);


Файл = Новый Файл(ВыбранноеИмяФайла);

ИмяФайлаКартинки = Файл.Имя;

СсылкаНаКартинку = АдресВХранилище;

Модифицированность = Истина;

#КонецЕсли       


 

КонецПроцедуры



&НаКлиенте


Процедура ОбработкаВыбораФайла(Результат, АдресВХранилище, ВыбранноеИмяФайла, ДополнительныеПараметры) Экспорт   

Если не Результат Тогда            Возврат;

КонецЕсли;

СсылкаНаКартинку = АдресВХранилище;         

 

КонецПроцедуры

 

&НаСервереПроцедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)

 

#Если ВебКлиент Тогда


Если ЭтоАдресВременногоХранилища(СсылкаНаКартинку) Тогда

ТекущийОбъект.ФайлКартинки = Новый ХранилищеЗначения(ПолучитьИзВременногоХранилища(СсылкаНаКартинку));

ТекущийОбъект.ИмяФайлаКартинки = ИмяФайлаКартинки;

КонецЕсли;

#Иначе                                                   


Если ЭтоАдресВременногоХранилища(СсылкаНаКартинку) ТогдаДвоичныеДанные = ПолучитьИзВременногоХранилища(СсылкаНаКартинку);

ТекущийОбъект.ФайлКартинки = Новый ХранилищеЗначения(ДвоичныеДанные, Новый СжатиеДанных(9));

ТекущийОбъект.ИмяФайлаКартинки = ИмяФайлаКартинки;КонецЕсли;

#КонецЕсли


 

КонецПроцедуры



С Уважением Дамир
 
 
   Вафель
 
1 - 20.08.18 - 11:12
делай всегда через НачатьПомещениеФайла
   9451523
 
2 - 20.08.18 - 11:17
ну я так и делаю он не сохранят файл в хранилище


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует