Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Странности отладчика

Странности отладчика
Я
   Tornadius
 
17.08.18 - 08:24
Доброго дня. Форумчане, может кто объяснить такое поведение отладчика: (УПП 1.3.108.1 на 8.2.9.130 обычные формы, толстый клиент) в процедуре ОМ.УправлениеЗапасами.ЗарегистрироватьДокументВПоследовательностяхПартионногоУчета(ДокументОбъект, Дата, Организация = Неопределено, Упр=Ложь, Бух = Ложь, Нал = Ложь, СпособВеденияПартионногоУчетаПоОрганизации=Неопределено) Экспорт
остановился по точке прерывания перед УправлениеЗапасамиПартионныйУчет.ЗарегистрироватьДокументВПоследовательностяхПартионногоУчетаНаСервере(ДокументОбъект.Ссылка, Дата, Организация, Упр, Бух, Нал, СпособВеденияПартионногоУчетаПоОрганизации, ТаблицаСтаройРегистрацииВПоследовательности);  нажимаю F11, чтобы войти в нее, а отладчик проскакивает далее просто выполняя код без входа в него. Хотя по F12 данная процедура раскрывается и в ней можно ставить точки прерывания, но отладчик на них не реагирует.
Как мне протрассировать выполнение кода в внутри партионной процедуры?
 
 
   Лодырь
 
1 - 17.08.18 - 08:26
Отладка на сервере отключена.
   dmpl
 
2 - 17.08.18 - 08:50
(0)
1. Создать копию базы на тестовом сервере.
2. Убедиться, что на тестовом сервере режим отладки включен.
3. Убедиться, что брандмауэр не режет входящие соединения.
4. Начать отладку.
   Tornadius
 
3 - 17.08.18 - 09:07
(1) отладка включена. как иначе вообще попал в отладку.
Какие еще могут быть варианты?
   мистер игрек
 
4 - 17.08.18 - 09:08
(3) Ты не понял. Есть еще отладка на сервере. Он включается в параметрах командной строки агента сервера. Находится в службах.
   Tornadius
 
5 - 17.08.18 - 09:13
Также не проваливается в процедуру: УправлениеЗапасамиПартионныйУчет.ДвижениеПартийТоваров(
        Ссылка, 
        Движения.СписанныеТовары.Выгрузить()
    );
   Tornadius
 
6 - 17.08.18 - 09:16
(4) У меня два агента:

C:\Program Files\1cv82\8.2.19.130\bin\ragent.exe" -srvc -agent -regport 1641 -port 1640 -range 1660:1691 -d "C:\Program Files\1cv82\srvinfo" -debug

C:\Program Files\1cv8\8.3.11.2899\bin\ragent.exe" -srvc -agent -regport 1541 -port 1540 -range 1560:1591 -d "C:\Program Files\1cv8\srvinfo" -debug

какой еще надо параметр?
   мистер игрек
 
7 - 17.08.18 - 09:18
(6) ну тогда незнаю
   dmpl
 
8 - 17.08.18 - 09:18
(6) В списке соединений для отладки надо подключить соединение клиента и соединение сервера.
   r_abdunazarov
 
9 - 17.08.18 - 09:20
(0) Мне помог перезапуск сервера
   Локи-13
 
10 - 17.08.18 - 09:22
перезапусти конфигуратор, отвалился серверный отладчик
 
 Рекламное место пустует
   bolder
 
11 - 17.08.18 - 09:28
(6) Покажи окно подключения объектов отладки.
   Tornadius
 
12 - 17.08.18 - 09:29
Перегрузить сервер смогу только в ночь, на выходных.
   Tornadius
 
13 - 17.08.18 - 09:52
Самое интересное, что не входит только в ОМ.УправлениеЗапасамиПартионныйУчет. почему только в него непонятно.
   dmpl
 
14 - 17.08.18 - 10:00
(13) Так может код до входа и не доходит. Запусти замер производительности и найди там вызов этой процедуры.
   Nikoss
 
15 - 17.08.18 - 10:00
(13) модуль серверный скорее всего, вот и не заходит (если отладка на сервере не работает)
   zippygrill
 
16 - 17.08.18 - 10:06
Кто вас учил ставить ключ -debug в конце?
Ставьте его по середине, например после диапазона портов и ключем -d
   r_abdunazarov
 
17 - 17.08.18 - 10:57
(16) У меня работает нормально, ключ дебаг в конце:
"C:\Program Files (x86)\1cv8\8.3.10.2252\bin\ragent.exe" -srvc -agent -regport 1541 -port 1540 -range 1560:1591 -d "C:\Program Files (x86)\1cv8\srvinfo" -debug
   Tornadius
 
18 - 17.08.18 - 11:54
Это что-то с сервером наверное. Служба агента 8.3 не запускается. Стартует и снова останавливается. даже принудительный старт не запускает. идет автоматическая остановка службы.
   мистер игрек
 
19 - 17.08.18 - 11:55
(18) Перезагрузку сервера пробовали?
   Tornadius
 
20 - 17.08.18 - 11:58
этот сервер запущен на одной физической машине с сервером 8.2. Так вот сервер 8.2. работает и бухи пока еще тоже. Как сможем выгнать всех сразу сделаем перезагрузку. Не понятно только как один работает а второй нет?
   Tornadius
 
21 - 24.08.18 - 08:50
Перезагрузили сервер. Проблемы остались. Сейчас захожу в базу на платформе 8.2 и с портами 1641 - ..., а отладчик теперь цепляется через порт 1541 и на точки прерывания никак не реагирует


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует