Вход | Регистрация

1С:Предприятие ::

Метки: 

Сброс всех пользователей для резервного копирования

Я
   prilforreal
 
16.08.18 - 14:32
Добренького денечка! Файловая 1С 8.3 пользователи через удаленный рабочий стол подключаются к базе, и конечно же сеансы свои не завершают, что можно сделать чтобы автоматически всех сбрасывать по ночам и производить копирование?
 
 
   zmaksimuz
 
1 - 16.08.18 - 14:37
(0) Написать батник-выгонялку и кинуть в планировщик виндовс.
   prilforreal
 
2 - 16.08.18 - 14:39
(1) Да, это лучший вариант, ребутить сервак каждую ночь жестко, а выгонять после часа бездействия может не помочь, мало ли кто решит заскочить..
   zmaksimuz
 
3 - 16.08.18 - 14:40
(1) + Либо настройках RDP можно указать время простоя сессии, после которого она сбрасывается.
   prilforreal
 
4 - 16.08.18 - 14:43
(3) Не получится так, например есть сессия "автомат", которая каждые 5 минут запускает обработку, значит останется висеть запущенной..
   zmaksimuz
 
5 - 16.08.18 - 14:46
(4) Для резервного копирования файловой 1С не обязательно пользователей выгонять. Просто нужно создать задание на копирования файла 1Cv8.1CD в необходимый каталог и все.
   ildary
 
6 - 16.08.18 - 14:46
(4) кому ночью сдался этот автомат?
   prilforreal
 
7 - 16.08.18 - 15:02
(5) Если есть активные процессы 1с, наличие файла exec.lck не даст нормально провести архивирование.
   Vet1310
 
8 - 20.08.18 - 08:35
(0) каким по архивы делаете?
   Serg_1960
 
9 - 20.08.18 - 09:01
(7) А зачем Вам весь каталог копировать? Достаточно только *.1cd
   prilforreal
 
10 - 22.08.18 - 10:02
(8) Для архивирования купили хранителя от гендальфа
 
 Рекламное место пустует
   prilforreal
 
11 - 22.08.18 - 10:04
Решил не париться с батниками, сегодня попробую ночью средствами 1С решить вопрос. При начале работы системы запускаю:

ПодключитьОбработчикОжидания("ЗавершениеСеанса",300);

И пишу процедурку ЗавершениеСеанса:
Процедура ЗавершениеСеанса() Экспорт
ТекДата=ТекущаяДата();
ВремяВыклНач=(НачалоДня(ТекДата))+9600;
ВремяВыклКон=(НачалоДня(ТекДата))+10800;
Если ВремяВыклНач<ТекДата тогда
    Если ТекДата<ВремяВыклКон тогда
ПрекратитьРаботуСистемы() 
КонецЕсли;
КонецЕсли;
КонецПроцедуры


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует