Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

ККТ печатает услуга вместо товар.

ККТ печатает услуга вместо товар.
Я
   Repey
 
16.08.18 - 09:06
Приветствую.

При формировании данных чека явным образом указываю КодПризнакаПредметаРасчета = 4
,а ККТ все равно печатает "ТОВАР".
Драйвер поставили девятый. Если формировать чек из драйвера, указать код = 4, печатает услугу.
Обработка обслуживания торгового оборудования в 1с - "АТОЛ: ККТ с передачей данных (версия 2,30)"
платформа - 8.3.9.2170
конфигурация - УПП, сильно переписанная.

Подскажите, пожалуйста - где и как искать причину такого поведения?

Благодарю.
 
 
   КонецЕсли
 
1 - 16.08.18 - 09:54
А в каком месте "явным образом указываю КодПризнакаПредметаРасчета = 4"?
   Repey
 
2 - 16.08.18 - 10:19
Перед фискализацией чека.
Делаю, считай, следующее:

ПараметрыЧека.ПозицииЧека[0].КодПризнакаПредметаРасчета = 4;
ОбъектДрайвера = Неопределено;
ОбработкаОбслуживания = Неопределено;
ПолучитьСерверТО().ПолучитьОбъектДрайвера(ФУ, ОбработкаОбслуживания, ОбъектДрайвера);
Результат = ОбработкаОбслуживания.ФискализироватьЧек(ОбъектДрайвера, ПараметрыЧека);
   FFIL0S0FF
 
3 - 16.08.18 - 10:34
Попробуй поменять дрова, была похожая проблема только с 8 атоловским драйвером. Если бы небыло доступа к конференции хрен бы узнали в чем проблема. Установили 9 драйвер и все отлично взлетело. Может в твоем случае наборот 8-ой драйвер нужен.
   КонецЕсли
 
4 - 16.08.18 - 10:36
А в ПараметрыЧека.ПозицииЧека разве прописывается КодПризнакаПредметаРасчета, а не ПризнакПредметаРасчета с типом Перечисления.ПризнакиПредметаРасчета?
   КонецЕсли
 
5 - 16.08.18 - 10:40
ОбработкаОбслуживания.ФискализироватьЧек вызывает ПодключаемоеОборудованиеУниверсальныйДрайверКлиент.ВыполнитьКоманду("ФискализацияЧека",....) 
Там вызываем МенеджерОборудованияВызовСервера.ПолучитьXMLПакетДляФискализацияЧека( ..) в которой анализируется "ПризнакПредметаРасчета" и только там получаем код и пишем его в xml.
   razlagator
 
6 - 16.08.18 - 10:42
(0) Откройте функцию ФискализацияЧека()
в ней найдите строку ДанныеЧека = МенеджерОборудованияВызовСервера.ПолучитьXMLПакетДляФискализацияЧека(ОбщиеПараметры, ВходныеПараметры, СуммаЧека, ШиринаСтроки, НовыйФормат, ВерсияФФД);
отладчиком посмотрите в переменную "ДанныеЧека", , это XML в нем проверьте какое значение у SignCalculationObject, Если 4 то должна печататься услуга, если 1 то товар.
   Repey
 
7 - 21.08.18 - 07:41
Прошу прощения. Забыл поблагодарить всех за ценные и правильные советы. После заполнения поля "признакапредметарасчета", признак напечатался как положено.

Благодарю!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует