Вход | Регистрация


Вопрос по обычным формам

[Волшебник, 15.08.18 - 15:45]
Вопрос по обычным формам
Я
   maptbln
 
15.08.18 - 15:43
День добрый,добавил в общий модуль функцию подсчёт выделенных ячеек

Функция СуммаПриВыделенииЯчеек (ПолеТабличногоДокумента) Экспорт
Сумма = 0;
Для Каждого Область Из ПолеТабличногоДокумента.ВыделенныеОбласти Цикл
   Если ТипЗнч(Область) = Тип("ОбластьЯчеекТабличногоДокумента") Тогда
      Для ИндексСтрока = Область.Верх По Область.Низ Цикл
         Для ИндексКолонка = Область.Лево По Область.Право Цикл
            Попытка
              Сумма = Сумма + Число(СтрЗаменить(ПолеТабличногоДокумента.Область("R" + Формат(ИндексСтрока, "ЧГ=0") + "C" + Формат(ИндексКолонка, "ЧГ=0")) .Текст, " ", ""));
           Исключение
           КонецПопытки;
          КонецЦикла;
      КонецЦикла;
   КонецЕсли;
КонецЦикла;
Возврат Сумма
КонецФункции


как теперь правильно из обычной формы обратиться к данной функции,пишу 

Процедура СуммаПриВыделении()  
      
      Сумма= ПЛ_Омега.СуммаПривыделенииЯчеек(ПолеТабличногоДокумента);
      СуммаВыдЯч = Сумма;

ругается на то ,что ПолеТабличногоДокумента не определено
как его правильно обозначить?
 
 
   Cool_Profi
 
1 - 15.08.18 - 15:44
ЭлементыФОрмы.* ?
   Малыш Джон
 
2 - 15.08.18 - 15:46
(0) функции ПолеТабличногоДокумента - это параметр функции,
а в процедуре эта переменная как определяется?
   Малыш Джон
 
3 - 15.08.18 - 15:46
+(2) *в функции, ПолеТабличногоДокумента - это параметр функции
   maptbln
 
4 - 15.08.18 - 15:48
(3) я привёл полный текст функции,если использовать его в качестве текста процедуры на форме,то работает
   Малыш Джон
 
5 - 15.08.18 - 15:49
(4) молодец. Но как это связано с тем, что написано в (2)?
   maptbln
 
6 - 15.08.18 - 15:50
(5)
так я и не знаю,как её правильно определить
   Малыш Джон
 
7 - 15.08.18 - 15:51
(4)
Функция СуммаПриВыделенииЯчеек (ПолеТабличногоДокумента)
здесь ПолеТабличногоДокумента - в параметрах функции есть, 1с понимает откуда его брать - из параметров функции

а вот здесь:

Процедура СуммаПриВыделении()  
      
      Сумма= ПЛ_Омега.СуммаПривыделенииЯчеек(ПолеТабличногоДокумента);

ПолеТабличногоДокумента - это что такое? это неизвестная переменная, о чем тебе и пишет
   Малыш Джон
 
8 - 15.08.18 - 15:52
(6) укажи, что такое ПолеТабличногоДокумента
   Малыш Джон
 
9 - 15.08.18 - 15:53
(6) если это элемент формы, значит и ищи его в коллекции элементов форм, как в (1) советуют
   maptbln
 
10 - 15.08.18 - 16:17
(9) понял , но не совсем ПолеТабличногоДокумента=ЭлементыФормы.Результат.ВыделенныеОбласти.Получить(0);

Результат - имя поля табличного документа
 
 Рекламное место пустует
   maptbln
 
11 - 15.08.18 - 17:13
ПолеТабличногоДокумента=ЭлементыФормы.Результат.ВыделенныеОбласти

не отрабатывает , подскажите как,я уже не знаю
   Михаил Козлов
 
12 - 15.08.18 - 17:17
А просто ЭлементыФормы.Результат не подходит?
   hhhh
 
13 - 15.08.18 - 17:19
(11) вот это вы тоже чего-то учудили
ПолеТабличногоДокумента.Область("R" + Формат(ИндексСтрока, "ЧГ=0") + "C" + Формат(ИндексКолонка, "ЧГ=0"))

пишите

ПолеТабличногоДокумента.Область(ИндексСтрока, ИндексКолонка)
   maptbln
 
14 - 15.08.18 - 17:22
(12) Результат не подходит , мне ведь нужны Выделенные ячейки
   maptbln
 
15 - 15.08.18 - 17:26
(14) да и тоже ошибку выдает

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует