Вход | Регистрация


ЗУП КОРП - Справочник Шаблоны произвольных кадровых приказов

ЗУП КОРП - Справочник Шаблоны произвольных кадровых приказов
Я
   pavlika
 
15.08.18 - 11:37
Кто с ним сталкивался? Нигде описания не найду - как цепляется шаблон печатной формы и по какому принципу формируется список "Создать на основании" в самом документе?
 
 
   Джуниор
 
1 - 27.08.18 - 07:16
Разобрался? Тоже не могу найти описание.
   2S
 
2 - 27.08.18 - 08:12
(0) ничего сложного. Там же в самом шаблоне можно макет привязать
   Джуниор
 
3 - 27.08.18 - 08:15
Макет должен быть оформлен определенным образом.
Пробовал подключить обработку внешней печатной формы - выдает ошибку: "Невозможно подключить дополнительную обработку из файла.
Возможно, она не подходит для этой версии программы."
   2S
 
4 - 27.08.18 - 08:18
(3) ну хз, у меня 7 групп по 3-4 шаблона в каждой, все работает. Точно не помню, но вроде пришлось править механизм выбора печатной формы из списка. По-умолчанию предлагает все макеты, а не конкретный под шаблон.
   2S
 
5 - 27.08.18 - 08:23
что-то вроде этого в присозданинасервере вместо типового механизма
    КомПечати = Документы.ПроизвольныйКадровыйПриказ.КомандыПечатиФормы(ЭтаФорма);
    Для Каждого КомандаПечати Из Команды Цикл
        ЕстьМ = 0;
        Для Каждого ОписаниеКомандыПечати Из КомПечати Цикл
            ЕстьМ = 1;
            Если СтрНайти(КомандаПечати.Имя, ОписаниеКомандыПечати.Идентификатор) > 0 Тогда
                Продолжить;
            КонецЕсли;    
            Если СтрНайти(КомандаПечати.Имя, "ПодменюПечатьОбычное") > 0 Тогда
                МассивУдаляемыхКоманд.Добавить(КомандаПечати);
            КонецЕсли;    
        КонецЦикла;
        Если ЕстьМ = 0 Тогда//не нашли команд печати

            Если СтрНайти(КомандаПечати.Имя, "ПодменюПечатьОбычное") > 0 Тогда
                МассивУдаляемыхКоманд.Добавить(КомандаПечати);
            КонецЕсли;
        КонецЕсли;
    КонецЦикла;
   Джуниор
 
6 - 27.08.18 - 08:32
Это все хорошо. Но если придумали такой механизм, то он должен работать без вмешательства в конфигурацию. Если найду описание - отпишусь.
   Джуниор
 
7 - 28.08.18 - 15:01
Добавил на инфостарт пример использования.
http://catalog.mista.ru/public/894061/
   pavlika
 
8 - 28.08.18 - 20:22
(2), (7) Спасибо, посмотрю - мысль понял.
   pavlika
 
9 - 28.08.18 - 20:26
Остался только вопрос с "Создать на основании" из произвольного кадрового приказа. Там то какой принцип?
   Джуниор
 
10 - 29.08.18 - 08:49
(9) Создается документ "Премия" или "Материальная помощь" с наполненными данными из произвольного кадрового приказа.
И еще, есть один нюанс: нельзя изменять реквизитный состав шаблона, если уже есть созданные произвольные приказы. Логично, но не удобно.
 
 Рекламное место пустует
   pavlika
 
11 - 29.08.18 - 09:23
(10) Спасибо - ожидал что можно расширить список документов, которые можно создать на основании произвольного кадрового приказа. Например, делаем шаблон для разовой премии и уже на основании него создаем разовое начисление.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует