Вход | Регистрация


1С:Предприятие ::

Метки: 

Печать через ВЕБ интерфейс УТ 3.1 для Украины (УТ 11).

Я
   Alex_Kh_ua
 
15.08.18 - 09:24
Добрый день дорогие форумчане! Есть проблема, возможно кому то она покажется до боли знакомой и сможет мне что то подсказать...
Задача состоит в подключении Торгового оборудования через ВЕБ клиент.
В список ТО входит Сканер ШК, Принтер этикеток, Принтер чеков (все для осуществления продаж через РМК). Проблемы, это то что много окон взаимодействия типо поиска ШК и прочее, являются модальными для типовой конфигурации, но этот момент я могу обойти путем проверки на ВЕБ клиент и переделывая модальные окна на не модальные. https://drive.google.com/open?id=1CvASpLJYDamRjH4lPsBvZxDsDCD6aeym

А вот дальше стоят проблемы другого характера:
В РМК при нажатии Пробить чек не происходит печать, так как печать идет не напрямую, а запрашивается как печать в браузере. При этом не сохраняется шаблон и размерность чека. Такая же ситуация и при печати этикеток и ценников.

Собственно вопрос, можно ли как то сделать автоматическую печать без браузера, и как выполнить настройку с сохранением шаблона и размерности чека?

Буду рад любому пинку в направлении решения проблемы...
 
 
   Остап Сулейманович
 
1 - 15.08.18 - 09:27
(0) Если нужны "шашечки" - ваше право. Если "ехать" - нужно отказываться от ВЕБ-клиента. Переходите на тонкого, РИБ или даже (не побоюсь этого слова) на РДП.
   Cyberhawk
 
2 - 15.08.18 - 09:28
Зачем через браузер? Делай через тонкий
   Alex_Kh_ua
 
3 - 15.08.18 - 09:35
(2) Я бы с радостью, но вот такая задача стоит и никуда не могу деться... увы...
   Cyberhawk
 
4 - 15.08.18 - 09:36
Как это никуда? Уволиться хотя бы...
   Остап Сулейманович
 
5 - 15.08.18 - 09:37
(3) Крепись... Отписывайся... Будем грустить вместе... )))
   hhhh
 
6 - 15.08.18 - 09:37
(0) а где там в ут 11 модальные окна? Их там нет в принципе. даже при пробитии чека, окно немодальное.
   Alex_Kh_ua
 
7 - 15.08.18 - 09:39
(6) Есть гадкая кнопочка Поиск по ШК
   hhhh
 
8 - 15.08.18 - 09:46
(7) ну вот открыл
    Оповещение = Новый ОписаниеОповещения("ПоискПоШтрихкодуЗавершение", ЭтотОбъект);
    ШтрихкодированиеНоменклатурыКлиент.ПоказатьВводШтрихкода(Оповещение);



и дальше

Процедура ПоказатьВводШтрихкода(ОповещениеУспешногоВвода, Количество = Неопределено, Заголовок = "") Экспорт 
    
    Если НЕ ЗначениеЗаполнено(Заголовок) Тогда
        Заголовок = НСтр("ru = 'Введите штрихкод'");
    КонецЕсли;
    
    ДополнительныеПараметры = Новый Структура(
        "ОповещениеУспешногоВвода, Количество",
        ОповещениеУспешногоВвода,
        Количество);
    Оповещение = Новый ОписаниеОповещения(
        "ПоказатьВводШтрихкодаЗавершение",
        ЭтотОбъект,
        ДополнительныеПараметры);
    ПоказатьВводЗначения(Оповещение, "", Заголовок);
    
КонецПроцедуры


то есть всё у них чики-пыки, никаких модальных форм, в вэб-клиенте всё работает.

Наверно, у вас не в модальных окнах дело.
   Alex_Kh_ua
 
9 - 15.08.18 - 09:51
(8) Типовая процедура в УТ 3.1 для Украины

Функция ВвестиШтрихкод(Штрихкод, Заголовок = "") Экспорт

    Результат = Ложь;

    Штрихкод = "";
    
    Если НЕ ЗначениеЗаполнено(Заголовок) Тогда
        Заголовок = НСтр("ru='Введите штрихкод';uk='Введіть штрихкод'");
    КонецЕсли;
    
    Если ВвестиЗначение(Штрихкод, Заголовок) Тогда
        Если Не ПустаяСтрока(Штрихкод) Тогда
            Результат = Истина;
        КонецЕсли;
    КонецЕсли;

    Возврат Результат;

КонецФункции

ВвестиЗначение модальное окно и такого чуда навалом по конфигурации
   Alex_Kh_ua
 
10 - 16.08.18 - 11:06
Расскажите пожалуйста начинающему, в чем по мимо модальности боль работы в ВЕБ клиенте с торговым оборудованием?
 
 Рекламное место пустует
   hhhh
 
11 - 16.08.18 - 11:07
(9) обновите тогда на более поздний релиз, это у вас релиз старый
   Alex_Kh_ua
 
12 - 16.08.18 - 11:17
(11) Увы, это актуальный релиз Украинской конфигурации, еще не дошли до нормальной реализации ВЕБ клиента
   Alex_Kh_ua
 
13 - 04.09.18 - 13:08
В общем, проблема состоит в том, что в момент вывода на печать этикетки, выводится она по кривому, и как это исправить не понятно... Здесь должен быть Штрих-код, но его нет.... http://prntscr.com/kqeoon хотя на печать выводится http://prntscr.com/kqepgu и стоит настройка Способ печати http://prntscr.com/kqepqo
   hhhh
 
14 - 04.09.18 - 13:22
(13) так вы &НаСервере выводите
   Alex_Kh_ua
 
15 - 04.09.18 - 14:07
(14) это типовой механизм... а как его обойти и где нужно печатать?
   Alex_Kh_ua
 
16 - 04.09.18 - 15:38
АП!
   hhhh
 
17 - 04.09.18 - 15:41
(15) ну открыть обработку эту, печать этикеток и ценников, скопипастить к себе, немножко подрихтовать напильником
   Alex_Kh_ua
 
18 - 05.09.18 - 14:00
Вопрос, возможно ли реализовать печать в Веб интерфейсе минуя стандартную обработку печати Google Chrome ? т.е. нажали кнопку печать, и данные сразу отправились на печать.
   Alex_Kh_ua
 
19 - 05.09.18 - 14:45
АП!
   Air777
 
20 - 05.09.18 - 15:20
ишь ты хитрый какой. Много хошь. Пиши в гугл и апай там. Это запрещено на уровне браузера. Есть вараинт написать свою программку которая будет печатать в обход браузера по TCPI/IP но это уже совсем другая история
   Alex_Kh_ua
 
21 - 05.09.18 - 16:29
(20) Инфа 100%?



Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует