Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Зуп 3.1.7.61 взаимодействие с сайтом hh.ru

Зуп 3.1.7.61   взаимодействие с сайтом hh.ru
Я
   Март_1c
 
14.08.18 - 18:31
При получении вакансий с сайта hh.ru по кнопке  "Загрузить с сайта hh.ru" выскакивает ошибка   {ОбщийМодуль.ИнтеграцияРекрутинговыхСайтовРедакция3.Модуль(85)}: Ошибка при вызове метода контекста (ПрочитатьJSON)
    Результат = ПрочитатьJSON(ЧтениеJSON, ПрочитатьВСоответствие);
по причине:
Недопустимое имя свойства: '90' для чтения JSON в объект Структура,

при нажатии кнопки "Найти кандидатов" выдает сообщение " Используемые рекрутинговые сайты не поддерживают поиск резюме в Интернете по решению компании. " .

У кого нибудь работает этот функционал с hh.ru ?

С SuperJob отрабатывает корректно.
 
 
   Март_1c
 
1 - 14.08.18 - 18:42
В процедуре :

Функция ИспользуемыеСайтыПриПоиске() Экспорт
    
    Сайты = Новый Массив;
    ИспользуемыеСайты = ИнтеграцияРекрутинговыхСайтов.ИспользуемыеСайты();
    
    Если ЗначениеЗаполнено(ИспользуемыеСайты) Тогда
        
        ПериодыОтключенияПоиска = ПериодыОтключенияПоискаПоРезюме();
        ДатаАктуальности = ТекущаяДатаСеанса();
        
        Для Каждого Сайт Из ИспользуемыеСайты Цикл
            
            СтрокаПериода = ПериодыОтключенияПоиска.Найти(Сайт, "Сайт");  //Март

            Если СтрокаПериода <> Неопределено Тогда
                Если (ДатаАктуальности >= СтрокаПериода.Начало)
                    И (ДатаАктуальности <= СтрокаПериода.Окончание 
                        ИЛИ Не ЗначениеЗаполнено(СтрокаПериода.Окончание)) Тогда
                    Продолжить;
                КонецЕсли;
            КонецЕсли;
            
            Сайты.Добавить(Сайт);
            
        КонецЦикла;
        
    КонецЕсли;
    
    Если ЗначениеЗаполнено(Сайты) Тогда
        Возврат Новый ФиксированныйМассив(Сайты);
    Иначе
        Возврат Неопределено;
    КонецЕсли;
    
КонецФункции

ЗначениеЗаполнено(СтрокаПериода.Окончание)  всегда Ложь так как :
Функция ПериодыОтключенияПоискаПоРезюме()
    
    ТаблицаПериодов = Новый ТаблицаЗначений;
    
    ТаблицаПериодов.Колонки.Добавить("Сайт", Новый ОписаниеТипов("СправочникСсылка.ИсточникиИнформацииОКандидатах"));
    ТаблицаПериодов.Колонки.Добавить("Начало", Новый ОписаниеТипов("Дата"));
    ТаблицаПериодов.Колонки.Добавить("Окончание", Новый ОписаниеТипов("Дата"));
    
    НоваяСтрока = ТаблицаПериодов.Добавить();
    НоваяСтрока.Сайт = ИнтеграцияРекрутинговыхСайтовКлиентСервер.HeadHunter();
    НоваяСтрока.Начало = Дата(2017, 9, 1);
    
    Возврат ТаблицаПериодов;
    
КонецФункции
   borodaty_pontorez
 
2 - 27.08.18 - 12:48
Что нибудь получилось в итоге?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует