Вход | Регистрация


1С:Предприятие ::

Метки: 

v7: Справочник - удалить наименование

Я
   Время
 
14.08.18 - 13:17
День добрый!
Вариант в справочнике удалить наименование (стандартный реквизит)?
Спасибо.
 
 
   АЛьФ
 
1 - 14.08.18 - 13:18
Сделать его длиной 0. А зачем?
   Время
 
2 - 14.08.18 - 13:22
(1) Спасибо.
Для ВТС нужен справочник ИСН - на фига там наименование?
   НЕА123
 
3 - 14.08.18 - 13:28
(3)
при обращении к Наименование - ошибку получишь.
не?
   catena
 
4 - 14.08.18 - 13:33
(3)Не. Насколько я помню, в 77 можно даже и наименование, и код делать нулевыми и даже одновременно. При одновременном, основным представлением становится первый реквизит.
   НЕА123
 
5 - 14.08.18 - 13:35
(4)
да. согласен.
но, какой-нибудь отчет на Спр.Наименование даст ошибку, кажись.
   Время
 
6 - 14.08.18 - 13:37
(3) Не переживай.
   Время
 
7 - 14.08.18 - 13:38
А как сделать отмену ввода?
То есть: код должен быть не менее 9 цифр (это есть), но вот после начала ввода - Esc не срабатывает. Проверку на 9 цифр сделала в ПриЗаписи.
   АЛьФ
 
8 - 14.08.18 - 13:40
2(5) Не выдаст. Вернет пустое значение. Как и с нулевым кодом.
   Время
 
9 - 14.08.18 - 13:42
(8) Лёша! А на (7) знаешь способ?
   vladko
 
10 - 14.08.18 - 13:50
(7) Наверное так:

Процедура ВводНового()
 Предупреждение("Это служебный справочник");
 СтатусВозврата(0);
 Возврат;
КонецПроцедуры
 
 Рекламное место пустует
   АЛьФ
 
11 - 14.08.18 - 13:54
2(9) Самое простое - сделать форму элемента.
   Время
 
12 - 14.08.18 - 13:56
(10) Не-а. Точно также себя ведет.
(11) Блин... Как не хотелось...
Спасибо.
   Карст
 
13 - 14.08.18 - 14:17
(12) при вводе поля проверять функцией  и выдавать сообщение или обнулять
ЗЫ а вообще это от лукавого , каким нить формексом смотреть
   Время
 
14 - 14.08.18 - 14:23
Прикольная фишка тут вылезла...
Форма справочника.
Одна процедура в модуле:
Процедура ПриЗаписи()
    
    Длина = СтрДлина(Наименование);
    
    Если (Длина < 9) Тогда
        Предупреждение("ИСН должен состоять из 9 цифр.");
        СтатусВозврата(0);
        Возврат;
    КонецЕсли;
    
КонецПроцедуры// ПриЗаписи


Так вот...
Все работает (по ESC отмена записи) пока не добавишь кнопку на форму, в которой прописано Форма.Закрыть(0) (это обработка ESC в справочнике).
   1Сергей
 
15 - 14.08.18 - 14:45
(14) ну, дык, нельзя так делать
   Время
 
16 - 14.08.18 - 14:45
(15) А почему?
   1Сергей
 
17 - 14.08.18 - 14:47
(16) Угадай
   Время
 
18 - 14.08.18 - 14:52
(17) Знаешь, что нельзя, но не знаешь почему - так и скажи.
Чего в угадайку играть.
   Peltik
 
19 - 14.08.18 - 15:01
может проще кнопку ОК блокировать пока правильно не ввидут ИСН?
типа как-то так:
    Если (СтрДлина(КодИСН) < 9) Тогда
        Форма.ОК.Доступность(0);
     Иначе
         Форма.ОК.Доступность(1);
    КонецЕсли;
   NSSerg
 
20 - 14.08.18 - 15:26
(14) Если добавить кнопку на форму с форма.Закрыть(0) - то закрывает без запроса о сохранении. Как и должно работать. А вам как надо чтоб отрабатывало?
   Время
 
21 - 14.08.18 - 15:32
(20) Мне надо:
- редактирование в списке.
- проверка ввода данных.
- при неправильном вводе - либо требуется правильный ввод (из поля нельзя выйти), либо отменить ввод (кнопка Esc).
Как "мне надо" работает без кнопки на форме с форма.Закрыть(0).
Если добавить кнопку (см. выше), то отменить ввод (см. выше) - не работает (не выходит никак из поля при неправильно введенных данных, выходит только после ввода (правильных) данных).
   NSSerg
 
22 - 14.08.18 - 15:51
(21) Повесить на кнопку процедуру с
Процедура Выйти() 
  WSHShell = СоздатьОбъект("WScript.Shell");
  WSHShell.SendKeys("{ESC}");    
КонецПроцедуры
   NSSerg
 
23 - 14.08.18 - 15:52
Или
Процедура Выйти() 
  WSHShell = СоздатьОбъект("WScript.Shell");
  WSHShell.SendKeys("{ESC}"); 
  форма.Закрыть(0);    
КонецПроцедуры
   NSSerg
 
24 - 14.08.18 - 15:57
А, понял, по кнопке сохраняет неверное значение?
   Время
 
25 - 14.08.18 - 16:00
(24) Если введено не верное значение - по ESC не выходит. Ни из строки, ни справочник не закрывает.
   Peltik
 
26 - 14.08.18 - 16:08
(25) фоукс из строки на кнопку, часом, не уходит? Если это последняя колонка в таблице, то после ее редактирования по Енткру или Табу, фокус уйдет на добавленнную кнопку, и тут начнется хрень
   NSSerg
 
27 - 14.08.18 - 16:10
(25) Код (23) Выходит.
   Время
 
28 - 14.08.18 - 16:23
(26) Вроде нет.
(27) Я пока кнопку убрала.
   Peltik
 
29 - 14.08.18 - 16:44
(28) зачем она вообще там?
   vicof
 
30 - 14.08.18 - 16:48

   vicof
 
31 - 14.08.18 - 16:49
Обработка проверки заполнения наше всё
   Peltik
 
32 - 14.08.18 - 16:53
(28) а попробуй, в свойствах кнопки поставить "Пропускать при вводе"
   Время
 
33 - 14.08.18 - 17:07
(29) По нажатию Esc закрывается справочник.
Не нужно давить на кнопку Закрыть или крест.
У меня во многих справочниках воткнута.
 
 
   Время
 
34 - 14.08.18 - 17:08
(32) Не-а. Фокус остается в строчке справочника.
   NSSerg
 
35 - 14.08.18 - 21:41
(33) А почему ESC? Неужели нельзя повесить на функциональную клавишу?
Я думал ты хочешь чтоб кнопка закрытия закрывала форму, если строка справочника в режиме редактирования.



Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует