Вход | Регистрация


КомпоновщикНастроекКомпоновкиДанных на сервере и клиенте

КомпоновщикНастроекКомпоновкиДанных на сервере и клиенте
Я
   kabv
 
14.08.18 - 10:40
Здравствуйте!
Внешняя обработка с реквизитом КомпоновщикНастроекКомпоновкиДанных.
На форме размещен отбор.

&НаСервере
Процедура ПриОткрытииНаСервере()
    ЭтотОбработкаОбъект = РеквизитФормыВЗначение("Объект");
    СхемаКомпоновкиДанных = ЭтотОбработкаОбъект.ПолучитьМакет("Макет");
    КомпоновщикНастроек = ЭтотОбработкаОбъект.КомпоновщикНастроек;
    КомпоновщикНастроек.Инициализировать(Новый ИсточникДоступныхНастроекКомпоновкиДанных(СхемаКомпоновкиДанных));
    КомпоновщикНастроек.ЗагрузитьНастройки(СхемаКомпоновкиДанных.НастройкиПоУмолчанию);
    КомпоновщикНастроек.Настройки.Отбор.Элементы.Очистить();
    ПолеСКД = КомпоновкаДанныхСервер.НайтиПолеСКДПоПолномуИмени(КомпоновщикНастроек.Настройки.Выбор.ДоступныеПоляВыбора.Элементы, "Номенклатура");
    Если ПолеСКД <> Неопределено Тогда
        //КомпоновщикНастроек.Настройки.Отбор.Элементы.Добавить(ПолеСКД.Поле);

    КонецЕсли;
    ЗначениеВРеквизитФормы(ЭтотОбработкаОбъект, "Объект");
//ТОЧКА 1

КонецПроцедуры


&НаКлиенте
Процедура ПриОткрытии(Отказ)
    ПриОткрытииНаСервере();
//ТОЧКА 2

КонецПроцедуры

В ТОЧКЕ 1 Объект.КомпоновщикНастроек.Настройки.Выбор.ДоступныеПоляВыбора.Элементы ЕСТЬ,
а в ТОЧКЕ 2 элементов уже нет. Почему не остаются заполненные настойки? Заранее благодарен!
 
 
   Cyberhawk
 
1 - 14.08.18 - 10:45
У формы есть события загрузки сохраненных настроек
   kabv
 
2 - 14.08.18 - 10:50
Чуть по-подродней можно? Зачем тут еще и события загрузки сохраненных настроек задействовать?

Список тем форума
Рекламное место пустует  Рекламное место пустует
Закон Брукера: Даже маленькая практика стоит большой теории.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует