Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Проблема с модальными окнами в 1С 8.3.11 в веб интерфейсе

Проблема с модальными окнами в 1С 8.3.11 в веб интерфейсе
Я
   9451523
 
13.08.18 - 10:23
Привет Всем
Прошу помощи, обновили конфигурацию с 8.2 на 8.3 все работает в обычном приложении, а вот через веб интерфейс при открытии документа ПоступлениеТоваровУслуг вышло сообщение "Использование модальных окон в данном режиме запрещено" вот процедура документа:

Процедура ПриОткрытии(Отказ)
    
    КурсРабочий=События_Каштан.ПолучитьТекущийРабочийКурс(КонецДня(Объект.Дата));
    Если не ЗначениеЗаполнено(Объект.КурсРабочий) Тогда   
        Объект.КурсРабочий=КурсРабочий; 
    ИначеЕсли Объект.КурсРабочий<>КурсРабочий Тогда
        Режим = РежимДиалогаВопрос.ДаНет;
        Ответ = Вопрос("Установлен неверный рабочий курс. Заменить?", Режим,,,"Текущий рабочий курс "+КурсРабочий);
        Если Ответ = КодВозвратаДиалога.Да Тогда
            Объект.КурсРабочий=КурсРабочий;
        КонецЕсли;
    КонецЕсли;

КонецПроцедуры

я пока обучаюсь опыта мало , подскажите как правильно переписать процедуру?
 
 
   Deon
 
1 - 13.08.18 - 10:25
Юзай ПоказатьВопрос()
   Вафель
 
2 - 13.08.18 - 10:25
вместо Вопрос нужно ПоказатьВопрос
   9451523
 
3 - 13.08.18 - 10:25
можно пример? если не сложно
   9451523
 
4 - 13.08.18 - 10:25
шас поробуем
   9451523
 
5 - 13.08.18 - 10:26
шас поробую
   Deon
 
6 - 13.08.18 - 10:26
(4) Пример в Синтакс-помощнике есть
   Deon
 
7 - 13.08.18 - 10:27
Получение рабочего курса лучше делать сразу в серверном методе типа ПриСозданииНаСервере(), чтобы лишний раз не бегать на сервер с клиента
   9451523
 
8 - 13.08.18 - 10:28
Обращение к процедуре как к функции (ПоказатьВопрос)
        Ответ = <<?>>ПоказатьВопрос("Установлен неверный рабочий курс. Заменить?", Режим,,,"Текущий рабочий курс "+КурсРабочий); (Проверка: Тонкий клиент)
   Вафель
 
9 - 13.08.18 - 10:31
(8) А потому что это не функция )))
   unbred
 
10 - 13.08.18 - 10:34
разрешить всплывающие окна в браузере? или пробовали?
 
 Рекламное место пустует
   Asmody
 
11 - 13.08.18 - 10:46
(9) У человека горе - СП украли.
   Fedor-1971
 
12 - 13.08.18 - 10:48
(8) вот пример из СП:

Режим = РежимДиалогаВопрос.ДаНет;
Оповещение = Новый ОписаниеОповещения ("ПослеЗакрытияВопроса", ЭтаФорма, Параметры);//Экспортная (!!!) процедура формы, где будешь обрабатывать ответ


ПоказатьВопрос(Оповещение,//куда идти после ответа на вопрос

"Волнующий тебя текст",//чего спросить то хотел

Режим,//режим вопрошения

0);//таймаут

//...


&НаКлиенте
Процедура ПослеЗакрытияВопроса(Результат, Параметры) Экспорт//(Обрати внимание!!! Экспорт, иначе не будет работать, т.к. вызов из вне формы)

    Если Результат = КодВозвратаДиалога.Нет Тогда// если ничего не ответии Результат = Непределено

        Возврат;
    КонецЕсли;

    //...



КонецПроцедуры

(10) не все браузеры будут работать корректно.
(11) не горе, просто есть несколько неочевидных моментов, сам путался, пока не привык
   Мыш
 
13 - 13.08.18 - 11:08
(12) Асинхронный режим штука такая, да. Требует переосмысления привычных подходов.
   Deon
 
14 - 13.08.18 - 11:11
(12) Волнующий текст )

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует