Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Поля из внешней таблицы У.О.

Поля из внешней таблицы У.О.
Я
   10kgcaxapa
 
13.08.18 - 04:52
Всем привет!Создал отчет на основе универсального.Передал внешнюю таблицу в источник данных.Все формирует,все работает...Вот только реквизитов полей нет в группировках и отборах.Это можно как-то исправить?
 
 
   10kgcaxapa
 
1 - 13.08.18 - 04:54
Тип у полей определен,справочники там,документы.Реквизитов нет
   10kgcaxapa
 
2 - 15.08.18 - 04:47
Ну же,неужели никто не знает?
   КонецЕсли
 
3 - 15.08.18 - 08:24
{ГДЕ
...
КакойтоДокумент.*,
КакойтоСправочник.*,
...
}

вот это .*  присутствует в тексте запроса для построителя в резделах {ГДЕ }  {Сгрппировать по }?
   10kgcaxapa
 
4 - 15.08.18 - 09:33
До этого не доходит.В процедуре установить начальные настройки у меня вызывается вот такая процедура
ТаблицаДанных = СформироватьТаблицуДанных();
ИсточникДанных=Новый ОписаниеИсточникаДанных(ТаблицаДанных);
ИсточникДанных.Колонки.Контрагент.Измерение=Истина;
        ИсточникДанных.Колонки.Склад.Измерение=Истина;
        ИсточникДанных.Колонки.Номенклатура.Измерение=Истина;
        ИсточникДанных.Колонки.ЗаказПокупателя.Измерение=Истина;
        
        ИсточникДанных.Колонки.МагазинЗаказал.Итог="СУММА(МагазинЗаказал)";
        ИсточникДанных.Колонки.СкладОтгрузил.Итог="СУММА(СкладОтгрузил)";
        ИсточникДанных.Колонки.МенеджерСогласовал.Итог="СУММА(МенеджерСогласовал)";
        ИсточникДанных.Колонки.Отклонение.Итог="СУММА(Отклонение)";
        ИсточникДанных.Колонки.ОтклонениеРуб.Итог="СУММА(ОтклонениеРуб)";



функция СформироватьТаблицуДанных()
        ВТ=новый ТаблицаЗначений;
        
        Массив = Новый Массив;
        Массив.Добавить(Тип("СправочникСсылка.Номенклатура"));
        ОписаниеТиповНоменклатура = Новый ОписаниеТипов(Массив);
        
        Массив = Новый Массив;
        Массив.Добавить(Тип("СправочникСсылка.Склады"));
        ОписаниеТиповСклады = Новый ОписаниеТипов(Массив);
        
        Массив = Новый Массив;
        Массив.Добавить(Тип("СправочникСсылка.Контрагенты"));
        ОписаниеТиповКонтрагенты = Новый ОписаниеТипов(Массив);
        
        Массив = Новый Массив;
        Массив.Добавить(Тип("ДокументСсылка.ЗаказПокупателя"));
        ОписаниеТиповЗаказ = Новый ОписаниеТипов(Массив);
        
        //Массив.Добавить(Тип("Число"));

        //КЧ = Новый КвалификаторыЧисла(10,0);

        //ОписаниеТиповЧисло = Новый ОписаниеТипов(Массив,,,КЧ);

        
        вт.Колонки.Добавить("Цена", Новый ОписаниеТипов("Число"));
        вт.Колонки.Добавить("МагазинЗаказал", Новый ОписаниеТипов("Число"));
        вт.Колонки.Добавить("МенеджерСогласовал",Новый ОписаниеТипов("Число"));
        вт.Колонки.Добавить("СкладОтгрузил", Новый ОписаниеТипов("Число"));
        вт.Колонки.Добавить("Отклонение", Новый ОписаниеТипов("Число"));
        вт.Колонки.Добавить("ОтклонениеРуб", Новый ОписаниеТипов("Число"));
        вт.Колонки.Добавить("Номенклатура", ОписаниеТиповНоменклатура);
        вт.Колонки.Добавить("Склад", ОписаниеТиповСклады);
        вт.Колонки.Добавить("Контрагент", ОписаниеТиповКонтрагенты);
        вт.Колонки.Добавить("ЗаказПокупателя",ОписаниеТиповЗаказ);
        
        
        
        
        возврат ВТ    
КонецФункции

Ну тоесть после открытия формы настроек я хочу выбрать реквизит,например,номенклатуры,а его нет :с (3)
   10kgcaxapa
 
5 - 15.08.18 - 09:34
Ой,не процедура,извиняюсь...Функция
   Cool_Profi
 
6 - 15.08.18 - 09:36
а запрос где формируется?
   10kgcaxapa
 
7 - 15.08.18 - 09:53
Процедура СформироватьОтчет(ТабличныйДокумент) Экспорт
        
        ТаблицаДанных.Очистить();
        ЗаполнитьТаблицуДанных();
        
        // Перед формирование отчета можно установить необходимые параметры универсального отчета.

        
        УниверсальныйОтчет.СформироватьОтчет(ТабличныйДокумент,,, ЭтотОбъект);
        
    КонецПроцедуры// СформироватьОтчет()


Тут заполняется Таблица значений,которая потом передается в источник данных отчета
   Cool_Profi
 
8 - 15.08.18 - 09:56
Насколько я помню построитель - расшифровка по внешнему источнику вроде не работает.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует