Вход | Регистрация


Событие динамической таблицы управляемой формы.

Событие динамической таблицы управляемой формы.
Я
   bplmeddy
 
11.08.18 - 15:46
Доброго времени суток.

Прошу помощи в решении следующего вопроса: есть форма обработки, на которой не размещается ТЧ.
ТЧ формируется программно и заполняется результатом запроса.

Вот пример кода:

ТЗ_рез = Запрос.Выполнить().Выгрузить();
    
    МассивРеквизитов.Очистить();
    Для Каждого Колонка ИЗ ТЗ_рез.Колонки Цикл
        НоваяКолонка = Новый РеквизитФормы(Колонка.Имя, Новый ОписаниеТипов(Колонка.ТипЗначения), "ТЗ");
        МассивРеквизитов.Добавить(НоваяКолонка);
    КонецЦикла;      
    ИзменитьРеквизиты(МассивРеквизитов);  
    ЗначениеВРеквизитФормы(ТЗ_рез, "ТЗ");
    
    ЭлементТЗ = Элементы.ТЗ;
    Для Каждого Колонка ИЗ ТЗ_рез.Колонки Цикл
        НовыйЭлементФормы = Элементы.Добавить("ТЗ"+Колонка.Имя, Тип("ПолеФормы"), ЭлементТЗ);
        НовыйЭлементФормы.Вид = ВидПоляФормы.ПолеВвода;
        НовыйЭлементФормы.ПутьКДанным = "ТЗ." + Колонка.Имя;
        НовыйЭлементФормы.Де
    КонецЦикла;



Как в сформированой таблице на форме можно перехватить события "ПриИзменении" ? Буду очень благодарен за помощь.
 
 
   Tonik992
 
1 - 11.08.18 - 15:52
Есть метод УстановитьДействие(), он тебе поможет в этом.
   bplmeddy
 
2 - 11.08.18 - 15:56
(1) А к чему его привязать. Не могу понять как зацепить данный метод за форму.
   bplmeddy
 
3 - 11.08.18 - 16:36
Люди, помогите, никак не могу сам разобраться.
   rphosts
 
4 - 11.08.18 - 16:44
Продам СП, дорого.

бесплатный фрагмент в рамках рекламной компании:

ТаблицаФормы (FormTable)
УстановитьДействие (SetAction)
Синтаксис:
УстановитьДействие(<ИмяСобытия>, <Действие>)
Параметры:
<ИмяСобытия> (обязательный)
Тип: Строка.
Имя события, для которого устанавливается новое действие.
<Действие> (обязательный)
Тип: Строка.
Указывается имя обработчика.
Описание:
Устанавливает обработчик события.
Доступность:
Сервер, мобильное приложение(сервер).

методические указания: http://www.1centerprise.com/devlinks?C="id=00040O01603M04002;lan=ru"#!id=00040O01603M04002
   bplmeddy
 
5 - 11.08.18 - 16:52
(4) &НаСервере
Процедура Тест()
    ЭтаФорма.ТЗ.Колонки.Цена.УстановитьДействие("ПриИзменении", "ПриИзменении");
КонецПроцедуры

&НаСервере
Процедура ПриИзменении(Элемент)
    Сообщить("моя обработка");
КонецПроцедуры
.

Что я делаю не так ?
   bplmeddy
 
6 - 11.08.18 - 16:56
Вот скриншот самой формы в конфигураторе.

http://i.piccy.info/i9/a9f763774c1d797985e85c8a0fc2d06d/1533995782/84945/1248074/Tabl.jpg
   runoff_runoff
 
7 - 11.08.18 - 19:49
нужно &НаКлиенте

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует