Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Заполнить таб часть документа

Заполнить таб часть документа
Я
   AnisaL
 
10.08.18 - 12:26
Добрый день, подскажите, пожалуйста, как заполнить таб часть документа Перемещение из таб части другого документа (ОтчетОРозничныхПродажах).

СсылкаНаОтчет = ОтчетОРозничныхПродажах.Ссылка;
ДокПеремещение = Документы.ПеремещениеТоваров.СоздатьДокумент();
ДокПеремещение.Товары.Загрузить(СсылкаНаОтчет.Товары);

Так выдает ошибку, неверные параметры
 
 
   Mankubus
 
1 - 10.08.18 - 12:31
(0) СсылкаНаОтчет.Товары.Выгрузить()
но лучше запросом
   AnisaL
 
2 - 10.08.18 - 12:33
(1) сейчас попробую
   AnisaL
 
3 - 10.08.18 - 12:49
(1) спасибо, все получилось!
   Михаил Козлов
 
4 - 10.08.18 - 12:53
Если ОФ, то делал 2 примитивные внешние обработки заполнения ТЧ: ВБуфер и ИзБуфера.
В первой (ВБуфер):
Процедура Инициализировать(Объект, ИмяТабличнойЧасти, ТабличноеПолеОбъекта) ЭКСПОРТ
  тч = Объект[ИмяТабличнойЧасти];
  СохранитьЗначение("БуферТаблиц_ИмениКозлова", тч.Выгрузить());
КонецПроцедуры
Во второй (ИзБуфера):
Процедура Инициализировать(Объект, ИмяТабличнойЧасти, ТабличноеПолеОбъекта) ЭКСПОРТ
  табл = ВосстановитьЗначение("БуферТаблиц_ИмениКозлова"); 
  Если ТипЗнч(табл)=Тип("ТаблицаЗначений") И табл.Количество()>0 Тогда
    тч = Объект[ИмяТабличнойЧасти];
    ДЛЯ каждого стр ИЗ табл Цикл
      нов = тч.Добавить();
      ЗаполнитьЗначенияСвойств(нов, стр);
    КонецЦикла;            
  КонецЕсли;        
КонецПроцедуры

Подключал в приложении к разным типам документов.
   AnisaL
 
5 - 10.08.18 - 13:04
(4) а что за функция СохранитьЗначение?
   Михаил Козлов
 
6 - 10.08.18 - 13:07
(5) Платформенная.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует