Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Как вывести основного менеджера в список документов актсверкивзаиморасчетов

Как вывести основного менеджера в список документов актсверкивзаиморасчетов
Я
   sidalexsandr
 
10.08.18 - 12:04
Надо в список документов АктСверкиВзаиморасчетов вывести ОсновногоМенеджера. Пробовал в форме списка документов создать колонку, но в данных не указать Контрагент.ОсновнойМенеджерПокупателя.Ссылка.
 
 
   Deon
 
1 - 10.08.18 - 12:05
Управляемые формы?
   sidalexsandr
 
2 - 10.08.18 - 12:08
Добавил реквизит ОсновнойМенеджер. Сделал в процедуре ПослеЗаписи сохранение в реквизит = Контрагент.ОсновнойМенеджерПокупателя.Ссылка.
   Deon
 
3 - 10.08.18 - 12:10
(2) Не делай так. Это избыточная информация в БД. И, к тому же, почему в ПослеЗаписи?
   Deon
 
4 - 10.08.18 - 12:12
И как вообще форма списка с Послезаписи() связана?..
   sidalexsandr
 
5 - 10.08.18 - 12:31
(4) В форме списка отображается ревизит которому присваивается значение в процедуре ПослеЗаписи
   sidalexsandr
 
6 - 10.08.18 - 12:31
Как запустить групповое проведение документов определённого типа в УТ 10?
   Lexey_
 
7 - 10.08.18 - 12:35
(2) если основной менеджер поменяется информация в твоем реквизите станет неактуальной
   sidalexsandr
 
8 - 10.08.18 - 13:44
(7) Спасибо
   sidalexsandr
 
9 - 10.08.18 - 13:47
Написал обработку перезаписи документа и при её выполнении не срабатывает процедура ПослеЗаписи, вот текст обработки:
Выборка = Документы.АктСверкиВзаиморасчетов.Выбрать();
    Пока Выборка.Следующий() Цикл
        
        ТекДок = Выборка.ПолучитьОбъект();
        ТекДок.Записать(РежимЗаписиДокумента.Запись);
        Сообщить("Записан = " + Выборка.Ссылка);
        
    КонецЦикла;
    
    Сообщить("Все документы АктСверкиВзаиморасчетов перезаписаны.");

Вопрос: как сделать чтобы срабатывала в обработке процедуура ПослеЗаписи?

При интерактивной записи документа процедура ПослеЗаписи срабатывает.
   ColonelAp4u
 
10 - 10.08.18 - 13:47
(0) Добавь колонку в форму списка, а модуле формы списка в ПриПолученииДанных обработай что нужно и подставь в эту колонку
 
 Рекламное место пустует
   ColonelAp4u
 
11 - 10.08.18 - 13:48
реквизит = бред, в модуле документа при записи = бред
   ColonelAp4u
 
12 - 10.08.18 - 13:50
МассивДокументов = новый Массив;
    Если ЭлементыФормы.Список.Колонки._Вес.Видимость = Истина ИЛИ ЭлементыФормы.Список.Колонки._Объем.Видимость = Истина Тогда
        МассивДокументов.Очистить();
        Соответствие = новый Соответствие;
        Для каждого Строка из ОформленияСтрок цикл
            МассивДокументов.Добавить(Строка.ДанныеСтроки.Ссылка);
            Соответствие.Вставить(Строка.ДанныеСтроки.Ссылка, Строка);
        КонецЦикла;
        Запрос2 = Новый Запрос;
        Запрос2.Текст = "ВЫБРАТЬ РАЗРЕШЕННЫЕ
        |    ВнутреннийЗаказТовары.Ссылка КАК Заказ,
        |    СУММА(ВнутреннийЗаказТовары.Количество * ВнутреннийЗаказТовары.Номенклатура.ЕдиницаХраненияОстатков.Вес) КАК Вес,
        |    СУММА(ВнутреннийЗаказТовары.Количество * ВнутреннийЗаказТовары.Номенклатура.ЕдиницаХраненияОстатков.Объем) КАК Объем
        |ИЗ
        |    Документ.ВнутреннийЗаказ.Товары КАК ВнутреннийЗаказТовары
        |ГДЕ
        |    ВнутреннийЗаказТовары.Ссылка В(&Заказ)
        |
        |СГРУППИРОВАТЬ ПО
        |    ВнутреннийЗаказТовары.Ссылка";
        Запрос2.УстановитьПараметр("Заказ",МассивДокументов);
        Результат2 = Запрос2.Выполнить().Выбрать();
        Пока Результат2.Следующий() Цикл
            Соответствие.Получить(Результат2.Заказ).Ячейки._Вес.УстановитьТекст(Результат2.Вес);
            Соответствие.Получить(Результат2.Заказ).Ячейки._Вес.ОтображатьТекст =Истина;
            Соответствие.Получить(Результат2.Заказ).Ячейки._Объем.УстановитьТекст(Результат2.Объем);
            Соответствие.Получить(Результат2.Заказ).Ячейки._Объем.ОтображатьТекст =Истина;
        КонецЦикла;
        
    КонецЕсли;


Вот как у меня выводятся вес и объем из заказа покупателя
   ColonelAp4u
 
13 - 10.08.18 - 13:51
(12) ой из внутреннего заказа, хотя в заказе покупателя такая же шняга только выборка из заказа. Подставь свои данные и вуаля счастье
   sidalexsandr
 
14 - 10.08.18 - 14:13
(13) Спасибо
   sidalexsandr
 
15 - 10.08.18 - 14:55
Написал
Выборка = Документы.АктСверкиВзаиморасчетов.Выбрать();
    Пока Выборка.Следующий() Цикл
        
        ТекДок = Выборка.ПолучитьОбъект();
        ТекДок.ОсновнойМенеджер = ТекДок.Контрагент.ОсновнойМенеджерПокупателя.Ссылка;
        ТекДок.Записать(РежимЗаписиДокумента.Запись);
        Сообщить("Записан = " + Выборка.Ссылка);
        
    КонецЦикла;
    
    Сообщить("Все документы АктСверкиВзаиморасчетов перезаписаны.");


Все равно основной менеджер пустой
   sidalexsandr
 
16 - 10.08.18 - 14:57
Консоль запросов показывает, что  ОсновнойМенеджер заполнен, а в журнале ОсновнойМенеджер не выводится

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует