Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Отчет СКД на УФ. Как получить значение верхней группировки для передачи в другой отчет?

Отчет СКД на УФ. Как получить значение верхней группировки для передачи в другой отчет?
Я
   Birmingem
 
09.08.18 - 11:30
Есть простой отчет на СКД в упр.формах. Обычная оборотка (остатки и обороты) по нескольким счетам (задаются программно) и их субконто. Первая группировка - счета, вторая - субконто, третья - валюта.
Задача получить расшифровку. А конкретно:
Пользователь щелкает например на строчке группировки субконто. Значение субконто в этой строке я получил.
А как получить значение вышестоящей группировки - счета?
 
 
   olegves
 
1 - 09.08.18 - 12:00
(0) Расшифровку юзай
   olegves
 
2 - 09.08.18 - 12:02
+(1) через рекурсию.
   Birmingem
 
3 - 09.08.18 - 12:16
(1)ее и юзаю
(2)можно пример или ссылку где почитать?
Вообще про нестандартную расшифровку очень мало информации. Все примеры что нашел, совсем примитивные и прямолинейные, шаг в сторону и все, тупик.
   olegves
 
4 - 09.08.18 - 12:36
(3)
&НаСервере
Процедура ПолучитьПоляРасшифровки(Расшифровка, Парам, ДанРасш)
    Родители = ДанРасш.Элементы[Расшифровка].ПолучитьРодителей();
    Для каждого эл из Родители Цикл
        Если ТипЗнч(эл) = Тип("ЭлементРасшифровкиКомпоновкиДанныхПоля") Тогда
            Поля = эл.ПолучитьПоля();
            Для каждого тПоле из Поля Цикл
                Парам.Вставить(тПоле.Поле, тПоле.Значение);
            КонецЦикла;
        ИначеЕсли ТипЗнч(эл) = Тип("ЭлементРасшифровкиКомпоновкиДанныхГруппировка") Тогда
            ПолучитьПоляРасшифровки(эл.Идентификатор, Парам, ДанРасш);
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует