Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

обновить управляемую формы табличную часть

обновить управляемую формы табличную часть
Я
   nAPACEHAK
 
09.08.18 - 08:49
Доброго.

На форме есть таблица сотрудники.
как правильно обновить таблицу после програмного изменения поля?
там где галка в колонке "обработать" - обновляется а как обновить колонку "физЛицо"?

Спасибо

&НаСервере
Процедура ОбработатьСотрудниковНаСервере()
    Для каждого Сотрудник Из Объект.Сотрудники Цикл
        Если НЕ Сотрудник.Обработать Тогда Продолжить; КонецЕсли; 
        //итд

        ФЛ = Справочники.ФизическиеЛица.СоздатьЭлемент();
        ФЛ.Наименование = ФИО;
        ФЛ.Записать();
        
        Сотрудник.ФизЛицо = ФЛ;
        Сотрудник.Обработать = Ложь;
    КонецЦикла;     
КонецПроцедуры

&НаКлиенте
Процедура ОбработатьСотрудников(Команда)
    ОбработатьСотрудниковНаСервере();
    Элементы.Сотрудники.Обновить();
КонецПроцедуры
 
 
   Cyberhawk
 
1 - 09.08.18 - 09:01
ОбновитьОтображениеДанных
   nAPACEHAK
 
2 - 09.08.18 - 09:12
блин. извиняюсь сам протупил
   nAPACEHAK
 
3 - 09.08.18 - 09:14
вместо ссылки объект присваивал (((

Список тем форума
Рекламное место пустует  Рекламное место пустует
Глупец, лишенный способности посмеяться над собой вместе с другими, не сможет долго выносить программирование.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует