Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Выход из состояния 8: "открытый документ", Штрих-М

v7: Выход из состояния 8: "открытый документ", Штрих-М
Я
   san4ez1008
 
09.08.18 - 05:26
Доброго времени суток! Бывают у всех ситуации, когда кончилась кассовая лента, лень подключиться на ТТ,решил добавить кнопочку, по которой печать будет продолжаться. Столкнулся с неизведанным.. Почему-то при продолжении печати документ останавливается при печати и впадает в состояние 8: открытый документ, *вид_документа*, подрежим 0 : бумага присутствует. Собственно, почему так? Решение-то конечно я нашел,административная отмена чека, но как-то по-другому можно? Код для примера:
Функция ПродолжитьПечать(Объект, Пароль)
    Рез = 0;
    Если ПустоеЗначение(Объект) = 1 Тогда
        ОписаниеРезультата = "устройство не подключено";
    ИначеЕсли ПодключитьсяКФР(Объект, Пароль) = 1 Тогда
        // переключение в режим снятия отчета (нужен пароль администратора)

        Объект.Password = Пароль;
        Объект.Connect();
        Подрежим=Объект.ECRAdvancedMode;
        Если Подрежим=3 тогда
            Объект.ContinuePrint();
            Объект.CheckConnection();
            Подрежим=Объект.ECRAdvancedMode;
            Пока Подрежим<>0 цикл
                Подрежим=Объект.ECRAdvancedMode;
                Объект.CheckConnection();
            КонецЦикла;
            
            Если (Объект.ECRMode=8) и (Подрежим=0) тогда
                Объект.SysAdminCancelCheck();
            КонецЕсли;
        иначе
            Сообщить("В продолжении печати не нуждается!");
            Рез=-1;
        КонецЕсли;
    КонецЕсли;
    
    Возврат Рез;
КонецФункции
 
 
   Галахад
 
1 - 09.08.18 - 06:20
(0) Подрежим 0 означает, ККМ считает что сделала все свои дела, и ей просто-напросто нечего печатать. По идее нужно подать команду печать следующей строки.
   san4ez1008
 
2 - 09.08.18 - 07:17
(1) но ККМ не до конца свои дела доделала,чек может и допечатала,но не закрыла
   Галахад
 
3 - 09.08.18 - 07:32
(2) Ну, наверное, где-то что-то не правильно напрограммировано....
   san4ez1008
 
4 - 09.08.18 - 07:42
так я через тест драйвера продолжаю печать,нажимаю закрыть чек-он по бороде,только отмена чека администратором действует
   Галахад
 
5 - 09.08.18 - 07:49
(4) Еще раз, ККМ считает что сделала все свои дела. Наверное, где-то что-то не правильно напрограммировано при печати чека.
   Масянька
 
6 - 09.08.18 - 08:15
(0) Заходишь в драйвер:
02. Регистрация -> вкладка "Регистрация" -> кнопка "Продолжить печать" или кнопка "Адм. отмена чека".
Затем драйвером проверь состояние (короткий или длинный запрос).
   Масянька
 
7 - 09.08.18 - 08:19
+ (6) "Продолжить печать" работает не всегда (так сказали в ЦТО).
У меня (лично) ни разу не работала. Ни из драйвера, ни программно.
ИМХО - "Я его слепила из того, что было" (С)
   san4ez1008
 
8 - 09.08.18 - 10:07
(6) да это все я знаю. у меня вопрос,почему после того,как кончилась лента,при вставке новой ленты через ДРАЙВЕР нажимаю "продолжить печать" и ккм впадает в режим 8, подрежим 0,т.е. ккм не закрывает чек, хотя по идее должна и перейти в режим 2. Хрен бы с ним, я это все сделал и обошел. Только из 20ти раз ккм нормально допечатала чек до конца с закрытием..в чем бл причина
   1snik_d
 
9 - 09.08.18 - 10:12
(8) Зависит от того, в какой момент кончилась бумага в ККМ.
Если чек не успел закрыться, то продолжить печать не поможет, нужно аннулировать чек. У Атол в этом плане умнее сделано, там сам аппарат все правильно делает, если бумага кончилась.
   Масянька
 
10 - 09.08.18 - 10:12
(8) Потому что "слепили из того, что было".
А вы теперь - подпрыгивайте.
 
 Рекламное место пустует
   1snik_d
 
11 - 09.08.18 - 10:15
(8) У нас очень часто бумага кончается, когда печатают слипы сбербанка. Вот там продолжить печать помогает всегда, потому что идет обычная печать строки. В чеках чаще всего приходится аннулировать чек и пробивать заново.

Список тем форума
Рекламное место пустует  Рекламное место пустует
Требовать и эффективности, и гибкости от одной и той же программы — все равно, что искать очаровательную и скромную жену... по-видимому, нам следует остановиться на чем-то одном из двух.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует