Вход | Регистрация


Конвертация данных (интерактивное окно)

Конвертация данных (интерактивное окно)
Я
   myr4ik07
 
08.08.18 - 13:38
Привет.
Задача, переносить документы, только те, в которых дата источник.дата больше чем приемник.датаЗапретаРедактированияДокументов

в обработчике КД ПослеЗагрузки 


ОбщаяДатаЗапретаРедактирования = ПараметрыСеанса.ГраницыЗапретаИзмененияДанных.Получить().Получить("ОбщаяДатаЗапретаРедактирования");
Если Объект.Дата <= ОбщаяДатаЗапретаРедактирования Тогда
    Сообщить("Документ №"+Объект.Номер+" пропущен, так как дата документа меньше даты запрета редактирования");
    Отказ = Истина;
КонецЕсли;


а есть ли возможность при загрузке в приемнике интерактивное окно открывать типа Если Вопрос("Все ровно загрузить?") = Да Тогда
Загружаем

?
 
 
   myr4ik07
 
1 - 08.08.18 - 13:40
если нет, то как выйти с данной ситуации, нужно пользователя справшивать, да нет, и обрабатывать ответ
   myr4ik07
 
2 - 08.08.18 - 13:44
или Вопрос() = КодВозврата.Да работает в КД?
   myr4ik07
 
3 - 08.08.18 - 13:52
работает http://prntscr.com/kg52b5
   myr4ik07
 
4 - 08.08.18 - 13:57
ОбщаяДатаЗапретаРедактирования = ПараметрыСеанса.ГраницыЗапретаИзмененияДанных.Получить().Получить("ОбщаяДатаЗапретаРедактирования");
Если Объект.Дата <= ОбщаяДатаЗапретаРедактирования Тогда
    
    Если Вопрос("Дата документа №"+Объект.Номер+"  меньше даты запрета редактирования. Всеровно загрузить?", РежимДиалогаВопрос.ДаНет) = КодВозвратаДиалога.Нет Тогда 
        Отказ = Истина;
    КонецЕсли;
    
КонецЕсли;
   Михаил Козлов
 
5 - 08.08.18 - 14:18
Не забудьте #Если Клиент, а то регламентное задание отвалится.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует