Вход | Регистрация

1С:Предприятие ::

Метки: 

Обновить Отображение Данных УФ

Я
   noffkj
 
08.08.18 - 11:38
Доброе утро.
Есть форма. УФ.
На форме таблица значений (реквизит формы).

ТЗ.Ссылка
ТЗ.Количество

Заполняется ссылками на документ.
Есть кнопка

&НаСервере
Процедура ИзменитьКолвоНаСервере()
    Для каждого СтрТаб Из Реквизит1 Цикл
        Док = СтрТаб.ссылка.ПолучитьОбъект();
        Док.Количество = 1;
        Док.Записать();
    КонецЦикла; 
    //Элементы.Реквизит1.Обновить();

КонецПроцедуры

&НаКлиенте
Процедура ИзменитьКолво(Команда)
    ИзменитьКолвоНаСервере();
    //ОбновитьОтображениеДанных(Элементы.Реквизит1);

КонецПроцедуры

После выполнения отображается предыдущее значение реквизита документа (Количество). Подскажите как перечитать или обновить форму чтобы количество отображалось измененное?
 
  Рекламное место пустует
   DrShad
 
1 - 08.08.18 - 11:45
использовать демонический список с произвольным запросом
или перезаполнять ТЗ
   DrWatson
 
2 - 08.08.18 - 12:01
А что если на форме отображать не ТЗ.Количество, а ТЗ.Ссылка.Количество ?
   DrShad
 
3 - 08.08.18 - 12:03
(2) пофигу, ибо ТЗ не обновится
   Buster007
 
4 - 08.08.18 - 12:20
Обновить только те строки, которые были изменены в процедуре на новые данные самостоятельно
   noffkj
 
5 - 08.08.18 - 12:20
ТЗ = РеквизитФормыВЗначение("Реквизит1");
    Реквизит1.Очистить();
    
    Для каждого СтрТЗ Из ТЗ Цикл
        СтрРеквизит1 = Реквизит1.Добавить();                
        СтрРеквизит1.Ссылка = ТЗ[0].Ссылка;
    КонецЦикла;

Не помогло. Забавно.
   Cyberhawk
 
6 - 08.08.18 - 12:23
Прочитать()
   Cyberhawk
 
7 - 08.08.18 - 12:24
Хотя была какая-то замута с этим методом, что он читает из объектного кэша (т.е. вызов этого метода не вызывает повторное чтение из БД, пока кэш не протух, и не обновляет этот кэш, что весьма странно)
   noffkj
 
8 - 08.08.18 - 12:44
&НаКлиенте
Процедура ИзменитьКолво(Команда)
    ИзменитьКолвоНаСервере();
    ОповеститьОбИзменении(Реквизит1[0].Ссылка);

    //ОбновитьОтображениеДанных(Элементы.Реквизит1);

КонецПроцедуры



Если грубо тто вот так оказывается.
ОповеститьОбИзменении(Реквизит1[0].Ссылка);


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует