Вход | Регистрация


Расширение Кладра для ЕРП 2.4

Расширение Кладра для ЕРП 2.4
Я
   Обфускация
 
08.08.18 - 08:51
Есть ЕРП 2.4, там есть КЛАДР. Когда нажимаешь на "..." возле адреса, открывается форма. Там дом,корпус,квартира... Как еще значения добавить которые там отображаются и сохраняются?
 
 
   yzimin
 
1 - 08.08.18 - 08:53
Там же есть произвольный комментарий к адресу, не хватает?
   Обфускация
 
2 - 08.08.18 - 08:55
не хватает
   Фрэнки
 
3 - 08.08.18 - 08:56
Работа с адресами и контактной инфой в ЕРП заимствована из общего для всех типовых БСП. Так что вопрос поставлен немного не корректно.
   Фрэнки
 
4 - 08.08.18 - 08:58
А зачем именно в кладр запихивать чего-то лишнее?
Объекты, к которым он вяжется - физлица и контрагенты. Это справочники и можно назначить допреквизиты для них.
   Обфускация
 
5 - 08.08.18 - 09:01
Всякие отчеты на кладр завязаны. Поэтому лучше его модифицировать.
   Фрэнки
 
6 - 08.08.18 - 09:02
Тип этого объекта метаданных уже посмотрел?
   Обфускация
 
7 - 08.08.18 - 09:04
(6)
Там очень хитро. Выпадающий список строится из реквизита на форме. Но в реквизите не видно никакого списка.

&НаКлиенте
Процедура ДобавитьОбъект(Команда)
    Варианты = НеиспользованныеЭлементыДополнительнойТаблицы(ДополнительныеЗдания, Элементы.ТипСтроения, 1);
    Для Каждого ЭлементОбъект Из НеиспользованныеЭлементыДополнительнойТаблицы(ДополнительныеПомещения, Элементы.ТипПомещения, 2) Цикл
        ЗаполнитьЗначенияСвойств(Варианты.Добавить(), ЭлементОбъект);
    КонецЦикла;
    
    КоличествоВариантов = Варианты.Количество();
    Если КоличествоВариантов>0 Тогда
        ДополнительныеПараметры = Новый Структура("КоличествоВариантов", КоличествоВариантов);
        Оповещение = Новый ОписаниеОповещения("ДобавитьОбъектЗавершение", ЭтотОбъект, ДополнительныеПараметры);
        ПоказатьВыборИзМеню(Оповещение, Варианты, Элементы.ДобавитьОбъект);
    КонецЕсли;
КонецПроцедуры
   Обфускация
 
8 - 08.08.18 - 09:05
Элементы.ТипСтроения - это источник списка значений
   Фрэнки
 
9 - 08.08.18 - 09:21
только это не в ту сторону тебя занесет
   Cyberhawk
 
10 - 08.08.18 - 09:22
xml-строка там со структурой полей
 
 Рекламное место пустует
   Обфускация
 
11 - 08.08.18 - 11:52
Может кто конкретней знает, что и где по этой части лежит?
   Обфускация
 
12 - 08.08.18 - 13:18
Вот это тут добавлялось в общем модуле, если вдруг кому тоже понадобится
Функция ТипыОбъектовАдресацииАдресаРФ() Экспорт
    
    Результат = Новый Массив;
    
    // Код, Наименование, Тип, Порядок, КодФИАС

    // Тип: 1 - владение, 2 - здание, 3 - помещение.

    
    Результат.Добавить(СтрокаОбъектаАдресации("1010", НСтр("ru = 'Дом'"),          1, 1, 2));
    Результат.Добавить(СтрокаОбъектаАдресации("1020", НСтр("ru = 'Владение'"),     1, 2, 1));
    Результат.Добавить(СтрокаОбъектаАдресации("1030", НСтр("ru = 'Домовладение'"), 1, 3, 3));
    
    Результат.Добавить(СтрокаОбъектаАдресации("1050", НСтр("ru = 'Корпус'"),     2, 1));
    Результат.Добавить(СтрокаОбъектаАдресации("1060", НСтр("ru = 'Строение'"),   2, 2, 1));
    Результат.Добавить(СтрокаОбъектаАдресации("1080", НСтр("ru = 'Литера'"),     2, 3, 3));
    Результат.Добавить(СтрокаОбъектаАдресации("1070", НСтр("ru = 'Сооружение'"), 2, 4, 2));
    Результат.Добавить(СтрокаОбъектаАдресации("1040", НСтр("ru = 'Участок'"),    2, 5));
    
    Результат.Добавить(СтрокаОбъектаАдресации("2010", НСтр("ru = 'Квартира'"),  3, 1));
    Результат.Добавить(СтрокаОбъектаАдресации("2030", НСтр("ru = 'Офис'"),      3, 2));
    Результат.Добавить(СтрокаОбъектаАдресации("2040", НСтр("ru = 'Бокс'"),      3, 3));
    Результат.Добавить(СтрокаОбъектаАдресации("2020", НСтр("ru = 'Помещение'"), 3, 4));
    Результат.Добавить(СтрокаОбъектаАдресации("2050", НСтр("ru = 'Комната'"),   3, 5));
    Результат.Добавить(СтрокаОбъектаАдресации("2060", НСтр("ru = 'Этаж'"),   3, 6));
    Результат.Добавить(СтрокаОбъектаАдресации("2070", НСтр("ru = 'Примечание'"),   3, 7));

    //  Наши сокращения для поддержки обратной совместимости при парсинге.

    Результат.Добавить(СтрокаОбъектаАдресации("2010", НСтр("ru = 'кв.'"),       3, 6));
    Результат.Добавить(СтрокаОбъектаАдресации("2030", НСтр("ru = 'оф.'"),       3, 7));
    
    // Уточняющие объекты

    Результат.Добавить(СтрокаОбъектаАдресации("10100000", НСтр("ru = 'Почтовый индекс'")));
    Результат.Добавить(СтрокаОбъектаАдресации("10200000", НСтр("ru = 'Адресная точка'")));
    Результат.Добавить(СтрокаОбъектаАдресации("10300000", НСтр("ru = 'Садовое товарищество'")));
    Результат.Добавить(СтрокаОбъектаАдресации("10400000", НСтр("ru = 'Элемент улично-дорожной сети, планировочной структуры дополнительного адресного элемента'")));
    Результат.Добавить(СтрокаОбъектаАдресации("10500000", НСтр("ru = 'Промышленная зона'")));
    Результат.Добавить(СтрокаОбъектаАдресации("10600000", НСтр("ru = 'Гаражно-строительный кооператив'")));
    Результат.Добавить(СтрокаОбъектаАдресации("10700000", НСтр("ru = 'Территория'")));
    
    Возврат Результат;
КонецФункции

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует