Вход | Регистрация

1С:Предприятие ::

Метки: 

Получить номер текущего документа в обработке заполнения

Я
   prilforreal
 
07.08.18 - 16:10
Добрый день! Пишу обработку заполнения с формированием кода изделия, частью кода будет номер документа, смотрю отладчиком, номер все время нулевой, как решить вопрос?

Функция ПолучитьКод(Код="") Экспорт
    Номер=ЭтотОбъект.Номер;
    Если НЕ ЗначениеЗаполнено(Дилер) тогда
        Предупреждение("Заполните Дилера.",15); 
        возврат "";
    иначе    
        если ДляКода=9 Тогда
            Предупреждение("Исчерпан набор кодов для документа.",15); 
            возврат "";
        иначеесли не значениезаполнено(Код) тогда
            ДляКода=ДляКода+1;
            
            Код1=Строка(Число(""+Константы.ОбщийПрефикс.Получить()+Константы.ПрефиксUV.Получить()));
            длинаКод=СтрДлина(""+Число(Дилер.Код))+1;
            Для ии=длинакод По 4 Цикл
                Код1=Код1+"0";    
            КонецЦикла;
            код1=код1+Формат(Число(Дилер.Код),"ЧГ=0");
            длинаКод=СтрДлина(Формат(Число(Номер),"ЧГ=0"))+1;
            
            код1=код1+СокрЛП(Формат(Число(Номер),"ЧГ=0"))+ДляКода;
            
            
            возврат код1;
        иначе
            Код1=Строка(Число(""+Константы.ОбщийПрефикс.Получить()+Константы.ПрефиксПотолка.Получить()));
            длинаКод=СтрДлина(""+Число(Дилер.Код))+1;
            Для ии=длинакод По 4 Цикл
                Код1=Код1+"0";    
            КонецЦикла;
            код1=код1+Формат(Число(Дилер.Код),"ЧГ=0");
            длинаКод=СтрДлина(Формат(Число(Номер),"ЧГ=0"))+1;
            Для ии=длинакод По 5 Цикл
                Код1=Код1+"0";    
            КонецЦикла;
            код1=код1+СокрЛП(Формат(Число(Номер),"ЧГ=0"))+Прав(Код,1);
            
            
            возврат код1;
        конецесли; 
    конецесли;
конецфункции
 
  Рекламное место пустует
   Amra
 
1 - 07.08.18 - 16:12
Документ не записан, а присваивание номера идет в момент записи. От этого и пляши
   prilforreal
 
2 - 07.08.18 - 16:16
(1) Спасибо! Тогда возьму код документа основания =)
   Serg_1960
 
3 - 07.08.18 - 16:22
Детский сад, штаны на лямках :)
   Serg_1960
 
4 - 07.08.18 - 16:26
Бессмысленное занятие наделять каки-то левым смыслом номера документов и коды справочников. Тем более бессмысленно, если Вы не собираетесь далее их поддерживать в алгоритмах.


Список тем форума
Рекламное место пустует  
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует