Вход | Регистрация

1С:Предприятие ::

Метки: 

Метод объекта не обнаружен (Добавить)

↓ [Волшебник, 06.08.18 - 16:41]
Я
   Ranty
 
06.08.18 - 16:37
Всем привет! Дали задание собрать все справочники и документы в табличную часть - все получилось. Позже, сказали сделать теперь это в Дерево значений, и тут меня настигла неприятная ошибка.
Может кто знает что делать?

{ВнешняяОбработка.ВнешняяОбработка.Форма.Форма.Форма(12)}: Метод объекта не обнаружен (Добавить)
    НоваяСтрока = ДокСпр.Добавить();


&НаСервере
Процедура СформироватьНаСервере()
    
    Для каждого Справочник из Метаданные.Справочники Цикл 
    
    НоваяСтрока = ДокСпр.Добавить();
    
    НоваяСтрока.Имя = Справочник.Имя;
    НоваяСтрока.Синоним = Справочник.Синоним;
           
    КонецЦикла; 

    Для каждого Документ из Метаданные.Документы Цикл 
        
    НоваяСтрока = ДокСпр.Добавить();
        
    НоваяСтрока.Имя     = Документ.Имя; 
    НоваяСтрока.Синоним = Документ.Синоним;  
        
    КонецЦикла;        
КонецПроцедуры
 
  Рекламное место пустует
   YaFedor
 
1 - 06.08.18 - 16:41
все логично - отладчик поможет
   Волшебник
 
2 - 06.08.18 - 16:41
НоваяСтрока = дерево.Строки.Добавить();
   Ranty
 
3 - 06.08.18 - 16:46
{ВнешняяОбработка.ВнешняяОбработка.Форма.Форма.Форма(13)}: Поле объекта не обнаружено (Строки)
    НоваяСтрока = ДокСпр.Строки.Добавить();
   Волшебник
 
4 - 06.08.18 - 16:50
(3) Печалька...
   segn
 
5 - 06.08.18 - 16:50
(3) Значит ДокСпр не является деревом значений
   Ranty
 
6 - 06.08.18 - 16:59
>Свойство - ДокСпр 
>Значение - ДанныеФормыДерево
>Тип      - ДанныеФормыДерево

Разве не является?
А что может являться в этом случае?
   Necessitudo
 
7 - 06.08.18 - 17:11
Объект.ДокСпр?
   RomaH
 
8 - 06.08.18 - 22:38
РеквизитФормыВЗначение
или ка его там
надо получить тип ДеревоЗначений
   Ranty
 
9 - 07.08.18 - 11:04
Да, спасибо! 
НовыйДокСпр = РеквизитФормыВЗначение("ДокСпр");
ЗначениеВРеквизитФормы(НовыйДокСпр,"ДокСпр");

Это помогло


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует