Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Проблема с компонентой штрихкода

Проблема с компонентой штрихкода
Я
   satoru
 
05.08.18 - 16:39
Пытаюсь настроить печать этикеток на управляемом приложении. База серверная: 1С сервер на Debian 9 (x64), а клиент на WIndows 7 (x32). Компонента "КомпонентаПечатиШтрихкодовLinux64" не подключается. Подскажите как установить данную компоненту на Debian.
1С:Предприятие 8.3 (8.3.10.2772).
На всякий случай код:
Функция ПодключитьВнешнююКомпонентуПечатиШтрихкода()
    
    // В зависимости от типа платформы подключим соответствующую внешнюю компоненту

    СистемнаяИнформация = Новый СистемнаяИнформация;             

    Если СистемнаяИнформация.ТипПлатформы = ТипПлатформы.Windows_x86 Тогда
        ПодключениеВыполнено = ПодключитьВнешнююКомпоненту("Обработка.ИНАГРО_РабочиеСтолы_Управляемая.Макет.КомпонентаПечатиШтрихкодовWindows32", "КартинкаШтрихкода", ТипВнешнейКомпоненты.Native);
        
    ИначеЕсли СистемнаяИнформация.ТипПлатформы = ТипПлатформы.Windows_x86_64 Тогда
        ПодключениеВыполнено = ПодключитьВнешнююКомпоненту("Обработка.ИНАГРО_РабочиеСтолы_Управляемая.Макет.КомпонентаПечатиШтрихкодовWindows64", "КартинкаШтрихкода", ТипВнешнейКомпоненты.Native);
        
    ИначеЕсли СистемнаяИнформация.ТипПлатформы = ТипПлатформы.Linux_x86 Тогда
        ПодключениеВыполнено = ПодключитьВнешнююКомпоненту("Обработка.ИНАГРО_РабочиеСтолы_Управляемая.Макет.КомпонентаПечатиШтрихкодовLinux32", "КартинкаШтрихкода", ТипВнешнейКомпоненты.Native);
        
    Иначе
        ПодключениеВыполнено = ПодключитьВнешнююКомпоненту("Обработка.ИНАГРО_РабочиеСтолы_Управляемая.Макет.КомпонентаПечатиШтрихкодовLinux64", "КартинкаШтрихкода", ТипВнешнейКомпоненты.Native);
        
    КонецЕсли;    
    
    // Создадим объект внешней компоненты

    Если ПодключениеВыполнено Тогда
        ВнешняяКомпонента = Новый("AddIn.КартинкаШтрихкода.Barcode");
    Иначе
        Возврат Неопределено;
    КонецЕсли;
    
    // Если нет возможности рисовать

    Если НЕ ВнешняяКомпонента.ГрафикаУстановлена Тогда
        // То картинку сформировать не сможем

        Возврат Неопределено;
    Иначе
        
        // Установим основные параметры компоненты

        
        // Если в системе установлен шрифт Tahoma

        Если ВнешняяКомпонента.НайтиШрифт("Tahoma") = Истина Тогда
            // Выбираем его как шрифт для формирования картинки

            ВнешняяКомпонента.Шрифт = "Tahoma";
        Иначе
            
            // Шрифт Tahoma в системе отсутствует

            // Обойдем все доступные компоненте шрифты

            Для Сч = 0 По ВнешняяКомпонента.КоличествоШрифтов -1 Цикл
                // Получим очередной шрифт, доступный компоненте

                ТекущийШрифт = ВнешняяКомпонента.ШрифтПоИндексу(Сч);
                // Если шрифт доступен

                Если ТекущийШрифт <> Неопределено Тогда
                    // Они и будет шрифтом для формирования штри-кода

                    //ВнешняяКомпонента.Шрифт = ТекущийШрифт;

                    Прервать;
                КонецЕсли;
            КонецЦикла;
        КонецЕсли;
        
        // Утановим размер шрифта

        ВнешняяКомпонента.РазмерШрифта = 10;
        
        Возврат ВнешняяКомпонента;
        
    КонецЕсли;
    
КонецФункции
 
 
   tesseract
 
1 - 05.08.18 - 17:34
(0)ИНАГРО Это франч?  Надо у них спросить зависимости. Обычно это imagemagick.
   satoru
 
2 - 05.08.18 - 21:23
(1) Конфигурация от ИНАГРО, но разве компонента это их разработка?
   Garykom
 
3 - 05.08.18 - 21:33
Ты компоненту пытаешься на клиенте или на сервере ставить и юзать?
   satoru
 
4 - 06.08.18 - 10:02
(3) На сервере.
   satoru
 
5 - 06.08.18 - 14:04
up
   Сияющий в темноте
 
6 - 06.08.18 - 14:21
а компонента 64 бита умеет?про линукс можно спросить потом.
   PloAl
 
7 - 06.08.18 - 14:51
(4) Зачем?

На сервере не бывает внешнего события.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует