Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Событие по флажку. 1С 7.7

v7: Событие по флажку. 1С 7.7
Я
   Лиза777
 
03.08.18 - 13:37
Мне нужно когда включаю флажок на форме, чтобы поле ввода стало неактивным. Не могу понять какое событие отлавливает, что флажок поставили?
 
 
   trad
 
1 - 03.08.18 - 13:39
в формуле свойств флажка пропиши вызов процедуры
в процедуре напиши Форма.ПолеВвода.Доступность(флаг)
   trad
 
2 - 03.08.18 - 13:40
или
Форма.ПолеВвода.Доступность(1-флаг)
   Лиза777
 
3 - 03.08.18 - 13:54
(1) пробовала в поле "формула" писать процедуру. Но отладчиком проверяю не заходит в процедуру эту
   trad
 
4 - 03.08.18 - 14:01
чудес не бывает
либо отладчик запущен не с теми параметрами запуска, что предприятие
либо отлаживаешь не тот модуль
либо точка останова не в той процедуре
   Масянька
 
5 - 03.08.18 - 14:43
(3) Процедура ПриУстановкеКорректировки()

    
    Если (Корректировка = 1) Тогда
        ТекстВопроса = "Рекомендуется использовать только в исключительных случаях." + РазделительСтрок + "Включить?";
        
        Ответ = Вопрос(ТекстВопроса ,"Да+Нет", 60);
        
        Если Ответ = "Нет" Тогда
            Корректировка = 0;
            СтатусВозврата(0);
            Возврат;
        КонецЕсли;
    КонецЕсли;
    
    Если (Корректировка = 1) Тогда

        РасшФормы.УстановитьФорму(Форма);
        
        Для Счетчик = 0 По (РасшФормы.КоличествоАтрибутов() - 1) Цикл
            РасшФормы.ПолучитьАтрибут(Счетчик).Доступность = 1;
        КонецЦикла;

        Форма.кнЗаполнить.Доступность(0);
        Форма.кнОК.          Доступность(0);
        Форма.кнОБГ.      Доступность(0);
        
        ЗапрещенныеПоля();
    КонецЕсли;
    
КонецПроцедуры // ПриУстановкеКорректировки

https://pastenow.ru/78b8af5348ab6c56e1b640cb5d0bb2f7

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует