Вход | Регистрация


Выпадающий список из ячейки тч документа

Выпадающий список из ячейки тч документа
Я
   Обфускация
 
02.08.18 - 13:07
Есть заполненная ТЗ, есть ТЧ документа. Как сделать, чтобы в ТЧ документа появился выпадающий список из определенной колонки ТЗ?
 
 
   МимохожийОднако
 
1 - 02.08.18 - 13:09
(0) Не понятная фигня
   Обфускация
 
2 - 02.08.18 - 13:10
Более умные есть?
   Kondarat
 
3 - 02.08.18 - 13:10
Колонку выгрузить в массив, массив загрузить в список значений, список значений использовать в ВыбратьИзМеню()
   rudnitskij
 
4 - 02.08.18 - 13:11
В поле ввода есть событие ПриНачалеВыбора, в нем формируйте список выбора с нужными вам значениями
   Обфускация
 
5 - 02.08.18 - 13:43
можно конкретней, с примером?
   Обфускация
 
6 - 02.08.18 - 14:00
Вот смотрите, я на ячейку наложила такой код. В итоге поле выпадает, но после клика в ячейке остается пусто. Что у меня не так?

&НаКлиенте
Процедура ПричиныНедопускаМероприятиеЗаявителяИзТУНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    Список = Новый СписокЗначений;
Список.Добавить("тест 666");

ДанныеВыбора = Список;


КонецПроцедуры
   Kondarat
 
7 - 02.08.18 - 14:04
&НаКлиенте
Процедура ТоварыНоменклатураНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;
    
    МассивТоваров = ПолучитьМассивТоваров();
    СписокТоваров = Новый СписокЗначений();
    СписокТоваров.ЗагрузитьЗначения(МассивТоваров);
    
    Оповещение = Новый ОписаниеОповещения("ПослеВыбораИзСписка",ЭтаФорма);
    
    ЭтаФорма.ПоказатьВыборИзСписка(Оповещение,СписокТоваров,Элемент);
    
КонецПроцедуры

&НаКлиенте
Процедура ПослеВыбораИзСписка(ВыбранныйЭлемент, ДопПарметры) Экспорт

    Если ВыбранныйЭлемент = Неопределено Тогда
        Возврат;
    КонецЕсли;    
    
    ТекущиеДанные = Элементы.Товары.ТекущиеДанные;
    ТекущиеДанные.Номенклатура = ВыбранныйЭлемент.Значение;

КонецПроцедуры// ПослеВыбораИзСписка()


&НаСервере
Функция ПолучитьМассивТоваров()
    
    Запрос = Новый Запрос("ВЫБРАТЬ ПЕРВЫЕ 10
                          |    Номенклатура.Ссылка КАК Ссылка
                          |ИЗ
                          |    Справочник.Номенклатура КАК Номенклатура");
    
    
    Возврат Запрос.Выполнить().Выгрузить().ВыгрузитьКолонку("Ссылка");
    

КонецФункции// ПолучитьМассивТоваров()
   s03
 
8 - 02.08.18 - 14:05
(6) В списке выбора, который задаешь и в данном поле (куда список выбора цепляешь должны совпадать типы значений
   Обфускация
 
9 - 02.08.18 - 14:07
(8)
у меня везде строка
   Обфускация
 
10 - 02.08.18 - 14:10
(7)
Процедура ПослеВыбораИзСписка - у меня нет такой процедуры справа от выбранной ячейки
 
 Рекламное место пустует
   Kondarat
 
11 - 02.08.18 - 14:11
ОФ, УФ?
   Обфускация
 
12 - 02.08.18 - 14:12
УФ
   s03
 
13 - 02.08.18 - 14:12
(9) СтандартнаяОбработка = Ложь
Эта установка разве не отменяет стандартные действия при выборе? вот результат у тебя и отсутствует.
Если список выбора всегда постоянен (условно), то можно задать его при открытии формы и никаких обработчиков выбора больше не нужно будет
   Kondarat
 
14 - 02.08.18 - 14:14
(12) тогда, что тебя смущает в (10). Это обработчик оповещения.
   Обфускация
 
15 - 02.08.18 - 14:31
(14)
Да, (7) правильно работает, спасибо, сама ошиблась в копипасте
   Обфускация
 
16 - 03.08.18 - 08:09
(14)
Тут только один нюанс возник. Значение отображается после начала заведения новой строки, после клика не отображается в ячейке сразу. Чего еще не хватает?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует