Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Передать параметр в форму в виде владельца объекта

Передать параметр в форму в виде владельца объекта
Я
   Eastert
 
02.08.18 - 10:35
Добрый день, нужно из одного справочника - "стеллаж" открыть форму другого справочника - деталь". У детали стандартное поле владелец имеет тип Справочник.Стеллаж, также у детали на форме есть соответствующее поле формы владелец, и нужно туда передать стеллаж, из которого открывается эта форма детали.

Я делаю так:
в форме Стеллажа:

    &НаКлиенте
    Процедура ДетальСоздание(Элемент, СтандартнаяОбработка)
        СтандартнаяОбработка = Ложь;
            
        ПараметрыДетали = Новый Структура;
        ПараметрыДетали.Вставить("Основание", ПолучитьЭтотОбъект());
        ОткрытьФорму("Справочник.Деталь.ФормаОбъекта", ПараметрыДетали);
        
    КонецПроцедуры
    
    &НаСервере
    Функция ПолучитьЭтотОбъект()
    
        РеквизитФормыВЗначение("Объект");
        
    КонецФункции

В форме детали:

    &НаСервере
    Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
        
        ЗначениеВРеквизитФормы(Параметры.Основание, "Владелец");// вот тут рукается

        
    КонецПроцедуры

Ошибка:
Ошибка при вызове метода контекста (ЗначениеВРеквизитФормы) ЗначениеВРеквизитФормы(Параметры.Основание, "Владелец");
по причине:
Недопустимое значение параметра (параметр номер '2')

Как при в СозданииНаСервере присвоить полю формы объект который есть в параметрах этой формы?
 
 
   BobCat
 
1 - 02.08.18 - 10:40
Объект.Ссылка передай
   Eastert
 
2 - 02.08.18 - 10:41
(1) та же ошибка
   YaFedor
 
3 - 02.08.18 - 10:44
А какие реквизиты есть у формы? Дай скрин посмотреть
   palsergeich
 
4 - 02.08.18 - 10:44
Один из параметров метода ОткрытьФрому - владелец. Засуньте туда ЭтаФорма.
   BobCat
 
5 - 02.08.18 - 10:45
Зачем вообще значение в реквизит формы переводишь ? Тебе в отбор списка надо ссылку подставить
   YaFedor
 
6 - 02.08.18 - 10:45
(4) это же просто владелец формы, а не владелец нового, создаваемого объекта
   palsergeich
 
7 - 02.08.18 - 10:46
Из формы можно вытащить что угодно.
ну или да, отбор.
   Eastert
 
8 - 02.08.18 - 10:46
   Eastert
 
9 - 02.08.18 - 10:47
параметр формы основание заполнен нужным стеллажном, здесь все хорошо, нужно просто этот параметр присвоить полю формы
при открытии либо при созданиинасервре
   palsergeich
 
10 - 02.08.18 - 10:47
Есть еще такая штука как заполнять из данных заполнения. Если нужно просто владельца засунуть, то православнее востпользоваться ей
 
 Рекламное место пустует
   Eastert
 
11 - 02.08.18 - 10:47
(9) в поел формы владелец
   YaFedor
 
12 - 02.08.18 - 10:47
(8) У формы всего один реквизит "Объект"

Тогда уж:

Объект.Владелец = Параметры.Основание
   palsergeich
 
13 - 02.08.18 - 10:48
   palsergeich
 
14 - 02.08.18 - 10:50
Почитай и пойми что там написано. Для твоей задачи это именно то что нужно

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует