Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Мобильная платформа. Сделать и сохранить фото на карту памяти

Мобильная платформа. Сделать и сохранить фото на карту памяти
Я
   bard666
 
01.08.18 - 11:02
Здравствуйте!

Возник вопрос как в мобильной версии сделать и сохранить фото на карту памяти? На первый вопрос ответил, а вот как сохранить фотку? Может кто поможет разобраться? Версия мобильной платформы 8.3.10.51.
Код:

&НаКлиенте
Процедура Фотка(Команда)
    
    #Если МобильноеПриложениеКлиент Тогда

        
        Если СредстваМультимедиа.ПоддерживаетсяФотоснимок(ТипКамерыУстройства.Задняя) Тогда
            Данные = СредстваМультимедиа.СделатьФотоснимок();
            Если Данные = Неопределено Тогда
                Сообщение = Новый СообщениеПользователю;
                Сообщение.Текст = "Фотоснимок не сделан";
                Сообщение.Сообщить();
            Иначе
                ДанныеДД = Данные.ПолучитьДвоичныеДанные();
                РасширениеФайла = Данные.РасширениеФайла;
                //Отражение картинки в форме.

                АдресХР  = ПоместитьВоВременноеХранилище(ДанныеДД, Новый УникальныйИдентификатор);
                СсылкаНаКартинку = АдресХР;

                
                ПоместитьФотоНаСервере(ДанныеДД, РасширениеФайла);
                
            КонецЕсли;    
        Иначе
            Сообщение = Новый СообщениеПользователю;
            Сообщение.Текст = "Фотоснимок не поддерживается";
            Сообщение.Сообщить();
        КонецЕсли;    
        
    #КонецЕсли    

        
КонецПроцедуры

&НаСервере
Процедура ПоместитьФотоНаСервере(ДанныеДД, РасширениеФайла)
    
    
    ИмяФайла = "//storage/extSdCard/DCIM/Camera/" + Формат(ТекущаяДата(),"ДФ=yyyyMMdd_HHmmss");

    НФ = Новый Файл("//storage/extSdCard/DCIM/Camera/");

    Если НФ.Существует() Тогда
        
        Если НФ.ЭтоКаталог() Тогда
            
            ДанныеДД.Записать(ИмяФайла + "." + РасширениеФайла);
            
        КонецЕсли;
        
    Иначе
        
        Сообщить("Нет каталога");
        
    КонецЕсли;    
    
КонецПроцедуры
 
 
   Широкий
 
1 - 01.08.18 - 13:01
Путь к карте памяти может быть разным.
Я бы сделал где настройку. Юзер один раз выбирает каталог в которым сохраняются фото. В дальнейшем все фотки туда льются

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует