Вход | Регистрация


Текст в подвале табличной части

Текст в подвале табличной части
Я
   ac13
 
30.07.18 - 17:35
Есть Таблица

Н = 0;

Для каждого СтрокаТаблицы из Таблица Цикл
     Н = Н * 3;
     СтрокаТаблицы.Количество = Н;
КонецЦикла;

ЭлементыФормы.Таблица.Колонки.Количество.ТекстПодвала = ДругаяТаблица.Итог("Количество"));


Если не писать заполнение значений строк таблицы, ок. Если писать, то текст подвала очищается. Мне нужно и строки значениями заполнить и текст подвала свой написать. Как это возможно? Тип поля у колонки - строка.
 
 
   Cyberhawk
 
1 - 30.07.18 - 17:37
Там 0 пади, а не "очищается"
   Tatitutu
 
2 - 30.07.18 - 17:37
Н = 0;

Н = Н * 3;

у тебя всегда равно нулю
   ac13
 
3 - 30.07.18 - 17:38
"Н" конечно не ноль, это я так для примера. Колонка заполняется разными строковыми значениями
   ac13
 
4 - 30.07.18 - 17:39
Пусть так будет

Н = 10;

Для каждого СтрокаТаблицы из Таблица Цикл
     Н = Н * 3 + " ннннн";
     СтрокаТаблицы.Количество = Н;
КонецЦикла;

ЭлементыФормы.Таблица.Колонки.Количество.ТекстПодвала = ДругаяТаблица.Итог("Количество"));

Результат тот же
   Tatitutu
 
5 - 30.07.18 - 17:39
(3) ты вообще оригинален
ЭлементыФормы.Таблица.Колонки.Количество.ТекстПодвала = ДругаяТаблица.Итог("Количество"));

может

ЭлементыФормы.Таблица.Колонки.Количество.ТекстПодвала = Таблица.Итог("Количество"));
   ac13
 
6 - 30.07.18 - 17:40
(5) нет, мне нужно так:
ЭлементыФормы.Таблица.Колонки.Количество.ТекстПодвала = ДругаяТаблица.Итог("Количество"));
   ac13
 
7 - 30.07.18 - 17:40
Вот интересуюсь возможно ли?
   Tatitutu
 
8 - 30.07.18 - 17:41
Н = 10;

Для каждого СтрокаТаблицы из Таблица Цикл
     Н = Н * 3 + " ннннн";
     СтрокаТаблицы.Количество = Н;
КонецЦикла;

бинго !!!!
количество тип Число 
а ты туда строку пихаешь , зачем ?


и
что такое ДРУГАЯТАБЛИЦА ?
   Tatitutu
 
9 - 30.07.18 - 17:41
Это вообще сильно !
Н = 10;

Н = Н * 3 + " ннннн";
   ac13
 
10 - 30.07.18 - 17:43
(9) Так я это для примера, какая разница что там за значения
(8) ДРУГАЯТАБЛИЦА - это другая таблица, которая не "Таблица"
 
 Рекламное место пустует
   ac13
 
11 - 30.07.18 - 17:44
(8) так я ж написал, у меня колонка "Количество" с типом "Строка"
   hhhh
 
12 - 30.07.18 - 17:49
(11) ну у нее стоит галка типа итоги в подвале?
   ac13
 
13 - 30.07.18 - 17:49
(12) у ячейки с типом строка нельзя поставить такую галку
   ac13
 
14 - 30.07.18 - 17:51
(12) а вы оказались правы. оказывается я поставил галку отображения итогов, когда у ячейки был тип "число", потом поменял на строку. сейчас убрал и всё получилось
благодарю за помощь)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует