Вход | Регистрация


СКД Отображение на форме настроек отбора установленного в конфигураторе

СКД Отображение на форме  настроек отбора установленного в конфигураторе
Я
   Dunstan
 
30.07.18 - 16:05
День всем добрый!
Такая тема: Есть отчет в отборе у которого стоит пользователь из справочника пользователи.
При открытии делаю такую процедуру:

&НаСервере
Процедура ПриОткрытииНаСервере()
    Настройки = Отчет.КомпоновщикНастроек.ПолучитьНастройки();
    Для Каждого Поле из Настройки.Отбор.Элементы Цикл 
        Если Строка(Поле.ЛевоеЗначение) = "АналитикаУчетаПоПартнерам.Партнер.ОсновнойМенеджер" Тогда 
          Поле.ПравоеЗначение   = ПолучитьТекущегоПользователя();
        КонецЕсли;
    КонецЦикла;
    Отчет.КомпоновщикНастроек.ЗагрузитьНастройки(Настройки);
КонецПроцедуры

Значение отбора устанавливается и при формировании отчета отбор осуществляется по текущему пользователю , однако на форме не отображается. А на форме стоит сохраненное с прошлого раза.

Вопрос: Как можно побороть?
 
 
   aleks_default
 
1 - 30.07.18 - 17:02
Изменять пользовательские настройки

ЭлементыОтбора = Отчет.КомпоновщикНастроек.ПользовательскиеНастройки.Элементы;
    
    Для Каждого ТекЭлементОтбора Из ЭлементыОтбора Цикл 
        
        Если ТипЗнч(ТекЭлементОтбора) = Тип("ОтборКомпоновкиДанных") Тогда 
            ОтборКомпоновкиДанных = ТекЭлементОтбора;
            Прервать;
        Иначе 
            ОтборКомпоновкиДанных = Неопределено;
        КонецЕсли;
        
    КонецЦикла;
    
    ЭлементыОтбораКомпоновкиДанных = ОтборКомпоновкиДанных.Элементы;
   Cyberhawk
 
2 - 30.07.18 - 17:09
"на форме стоит сохраненное с прошлого раза" // Не сохранять
   Dunstan
 
3 - 30.07.18 - 17:26
Отбор "АналитикаУчетаПоПартнерам.Партнер.ОсновнойМенеджер" устанавливается в СКД в конфигураторе. Он, как бы, предопределенный.

Список тем форума
Рекламное место пустует  Рекламное место пустует
Оптимист верит, что мы живем в лучшем из миров. Пессимист боится, что так оно и есть.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует