Вход | Регистрация
 

С каких пор серверные методы модуля формы доступны извне без директивы Экспорт?

С каких пор серверные методы модуля формы доступны извне без директивы Экспорт?
Я
   DTX 4th
 
25.07.18 - 16:32
[1c]&НаКлиенте
Функция тест1()
    Возврат 1;    
КонецФункции

&НаСервере
Функция Тест2()
    Возврат 2;    
КонецФункции

&НаСервереБезКонтекста
Функция Тест3()
    Возврат 3;    
КонецФункции
[/1c]

В другой форме:
[1c]Форма = ПолучитьФорму("ВнешняяОбработка.Обр.Форма.МояФома");
Форма.Тест1(); // Метод не найден
Форма.Тест2(); // Возвращает 2
Форма.Тест3(); // Возвращает 3
[/1c]

8.3.11.3034
 
 
   МихаилМ
 
1 - 25.07.18 - 16:35
в поиск. уже было
   DTX 4th
 
2 - 25.07.18 - 16:40
(1) Действительно.
С каких пор стало можно вызывать не экспортные процедуры модуля формы?

Баг это или фича до сих пор неясно.

Спасибо
   H A D G E H O G s
 
3 - 25.07.18 - 16:42
Бага.
Обещали уьрать

Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует