Вход | Регистрация


ПоказатьВводСтроки() ПриОткрытии()

ПоказатьВводСтроки() ПриОткрытии()
Я
   Сметанин
 
25.07.18 - 12:41
Всем доброго дня.

Такая задача. Внешнюю обработку нужно защитить паролем при запуске.

В модуле формы пишу такой код:

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    Строка = "";
    ОписаниеОповещения = Новый ОписаниеОповещения("ПроверкаКода", ЭтаФорма);
    ПоказатьВводСтроки(ОписаниеОповещения, Строка, "Введите код");
    Если ВведенныйКод <> "123" Тогда 
        Отказ = Истина;
    КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура ПроверкаКода(ПолученноеЗначение, ПереданныеПараметры) Экспорт
    ВведенныйКод = ПолученноеЗначение;
КонецПроцедуры

ВведенныйКод  - это реквизит формы.
Процедура не отрабатывает так как нужно, то есть ВведенныйКод  при проверке остается пустое. Как правильно написать?
 
 
   Сметанин
 
1 - 25.07.18 - 12:42
Через ВвестиСтроку работает, но ругается, что использование модальных окон запрещено
   Малыш Джон
 
2 - 25.07.18 - 12:44
"при проверке  остается пустое": проверка - это условие в процедуре ПриОткрытии()?
   Сметанин
 
3 - 25.07.18 - 12:44
да
   spectre1978
 
4 - 25.07.18 - 12:45
(0) наверно, придется поменять логику. По умолчанию форма должна открываться. Но - неработоспособной (например, все поля и кнопки неактивные). И только при наличии верного пароля все должно ожить.
   Сметанин
 
5 - 25.07.18 - 12:53
(4) В этом случае все равно придется писать условие ПриОткрытии, а там введенный пароль не получается проверить
   Сметанин
 
6 - 25.07.18 - 13:04
(4) Хотя можно делать проверку при нажатии на кнопку выполнения. За идею спасибо
   hhhh
 
7 - 25.07.18 - 13:06
(5) ну так

&НаКлиенте
Процедура ПроверкаКода(ПолученноеЗначение, ПереданныеПараметры) Экспорт
    ВведенныйКод = ПолученноеЗначение;
    Если ВведенныйКод <> "123" Тогда 
        Отказ = Истина;
    КонецЕсли;
КонецПроцедуры
   Малыш Джон
 
8 - 25.07.18 - 13:07
(3) потому что это немодальные окна

Ты ПоказатьВВодСтроки() запустил, оповещение сделал, но ПриОткрытии() от этого не затормозилось, а как продолжало выполняться - так и выполняется
   Малыш Джон
 
9 - 25.07.18 - 13:08
(7) а на что этот Отказ будет влиять?
   Сметанин
 
10 - 25.07.18 - 13:09
(7) Так не работает. Форма всегда открывается
 
 Рекламное место пустует
   hhhh
 
11 - 25.07.18 - 13:10
(9) ну так тогда


&НаКлиенте
Процедура ПроверкаКода(ПолученноеЗначение, ПереданныеПараметры) Экспорт
    ВведенныйКод = ПолученноеЗначение;
    Если ВведенныйКод <> "123" Тогда 
        Закрыть();
    КонецЕсли;
КонецПроцедуры
   D_E_S_131
 
12 - 25.07.18 - 13:11
(10) Вместо "отказа" поставь "Закрыть()"
   Малыш Джон
 
13 - 25.07.18 - 13:11
(10) ставь форму только на просмотр при открытии

а в оповещении - если прошел проверку - разблокируешь, нет - закрываешь форму
   Сметанин
 
14 - 25.07.18 - 13:17
(11) (12) Спасибо! работает

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует