Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Конвертация данных,обращение к параметрам табличной части После загрузки

Конвертация данных,обращение к параметрам табличной части После загрузки
Я
   bacamba49
 
24.07.18 - 12:40
Помогите плиз.КД2,После загрузки пытаюсь обратиться к табличной части документа

//Если ПараметрыОбъекта <> Неопределено тогда

ТаблицаПараметровТовары = ПараметрыОбъекта["ТоварыТабличнаяЧасть"];
//    
//Если ЗначениеЗаполнено(ТаблицаПараметровТовары) тогда
    
НомерСтроки = 0;

Для Каждого СтрокаПараметров Из ТаблицаПараметровТовары Цикл

    СтрокаТЧ = Объект.Товары.Получить(НомерСтроки);
    
    ЗначениеПараметра = СтрокаПараметров.Комиссия;
    
    Если ЗначениеПараметра = Истина Тогда
        
        //Сообщить(СтрокаТЧ.Номенклатура);
        
        //СтрокаТЧ = Объект.Товары.Получить(НомерСтроки);
        СтрокаТЧ.СчетУчета    = ПланыСчетов.Хозрасчетный.ТоварыПереданныеНаКомиссию;
    //    СтрокаТЧ.СчетУчетаНУ  = ПланыСчетов.Налоговый.ТоварыПереданныеНаКомиссию;
    
        Если СтрокаТЧ.СчетДоходов.ВидыСубконто.Количество() > 0 Тогда
            
            СтрокаТЧ.Субконто = Новый(СтрокаТЧ.СчетДоходов.ВидыСубконто[0].ВидСубконто.ТипЗначения.Типы()[0]);
            
            Если ТипЗнч(СтрокаТЧ.Субконто) = Тип("СправочникСсылка.НоменклатурныеГруппы") Тогда
                СтрокаТЧ.Субконто = СтрокаТЧ.Номенклатура.НоменклатурнаяГруппа;
            КонецЕсли;
            
        Иначе
            
            СтрокаТЧ.Субконто = Неопределено;
            
        КонецЕсли;
        
    ИначеЕсли СтрокаТЧ.СчетУчета = ПланыСчетов.Хозрасчетный.ТоварыПереданныеНаКомиссию Тогда
        
         СтрокаТЧ.СчетУчета                 = Неопределено;
         СтрокаТЧ.СчетДоходов                 = Неопределено;
         СтрокаТЧ.СчетРасходов                 = Неопределено;
         СтрокаТЧ.СчетУчетаНДСПоРеализации     = Неопределено;
        
         //СтрокаТЧ.Субконто     = Неопределено;
                            
    КонецЕсли;
    
    НомерСтроки = НомерСтроки + 1;

КонецЦикла;
 
 
   bacamba49
 
1 - 24.07.18 - 12:41
выдает ошибку

ОписаниеОшибки         =  Итератор для значения не определен
ПозицияМодуля          =  (47)
   bacamba49
 
2 - 24.07.18 - 12:44
(1) позиция 47 - как раз на начало цикла..как табличную часть Товары перебрать?
   bacamba49
 
3 - 24.07.18 - 13:33
ну подскажите где не так?
   Новый1сник2
 
4 - 24.07.18 - 13:49
Для Каждого Строка Из Объект.Товары Цикл

КонецЦикла;

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует