Вход | Регистрация


Дерево значений.

Дерево значений.
Я
   antihacker
 
20.07.18 - 07:52
Всем привет! Есть дерево значений. Как можно выбрать все строки по отбору
СтруктурныйОбзорДЗ_РФЗ = РеквизитФормыВЗначение("СтруктурныйОбзорДЗ"); 

    ОтборВыбранные = Новый Структура;
    ОтборВыбранные.Вставить("Выбрать",Истина);

Одним махом ? Мне сейчас придется опускаться на уровень и там применить этот отбор еще раз. И так далее.
 
 
   1Сергей
 
1 - 20.07.18 - 08:02
Что с ними делать потом?

так, рекурсией можно
   antihacker
 
2 - 20.07.18 - 08:11
Да рекурсией можно

Процедура ОбходДереваДетально(ПереданноеДер)
    
    
    Для Каждого СтрПолученногоДерева Из ПереданноеДер.Строки Цикл
        
        Если  СтрПолученногоДерева.Выбрать Тогда
              Сообщить(СтрПолученногоДерева.Организация);
        КонецЕсли;
      Если СтрПолученногоДерева.Строки.Количество()>0 Тогда
          
          Если  СтрПолученногоДерева.Выбрать Тогда
              Сообщить(СтрПолученногоДерева.Организация);
        КонецЕсли;

         ОбходДереваДетально(СтрПолученногоДерева);
         
     КонецЕсли;
     
  КонецЦикла;
  
КонецПроцедуры

Но рекурсия не нравиться тем, что надо обходить все строки. А мне хочется на текущем уровне выбрать только по условиям отбора.
   Lexey_
 
3 - 20.07.18 - 08:12
(2) сейчас как ищешь?
   antihacker
 
4 - 20.07.18 - 08:13
И еще вторая проблема. Если текущая строки не удовлетворяет условию. то не означает что у нее есть подстрока которая удовлетворяет условию. Можно прозевать эти подстроки.

Сейчас пока рекурсия.
   antihacker
 
5 - 20.07.18 - 08:14
Ой. " то не означает что у нее НЕТ подстрока которая удовлетворяет"
   Lexey_
 
6 - 20.07.18 - 08:14
(4) НайтиСтроки() чем не устраивает?
   antihacker
 
7 - 20.07.18 - 08:15
Lexey_, чуть выше ответил. Можно прозевать подстроки, которые  удовлетворяют отбор
   Lexey_
 
8 - 20.07.18 - 08:17
(7) не прозеваешь
   Dvoe4nik
 
9 - 20.07.18 - 08:17
(7)  выгрузить дерево В ТЗ взапрос и потом обратно в дерево..
   Dvoe4nik
 
10 - 20.07.18 - 08:18
+ (9)  муторно правда
 
 Рекламное место пустует
   antihacker
 
11 - 20.07.18 - 08:32
Lexey_. как не прозеваешь ? У строка1 есть подстроки, которые   удовлетворяют условию. Вот их будем прозевать так как родитель выпал из отбора
   Ненавижу 1С
 
12 - 20.07.18 - 08:35
(11) НайтиСтроки смотри второй параметр
   antihacker
 
13 - 20.07.18 - 08:44
Ога вот это новость. Работает. Спасибо !

Список тем форума
Рекламное место пустует  Рекламное место пустует
Оптимист верит, что мы живем в лучшем из миров. Пессимист боится, что так оно и есть.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует