Вход | Регистрация

1С:Предприятие ::

Метки: 

УПП 1.3 начисление не должно попадать в зарплату за 1 половину месяца

Я
   dchumak
 
20.07.18 - 07:16
Добрый день.

Есть основное начисление фиксированной суммой, которое должно выплачиваться в зп за 2 половину месяца.

Сейчас оно попадает в расчет зп за первую половину месяца (аванс).

Как сделать, чтобы не попадало в аванс, а попадало в расчет за 2 половину месяца?

УПП 1.3 последняя версия.
 
  Рекламное место пустует
   dchumak
 
1 - 20.07.18 - 07:53
Раньше с таким не сталкивались, т.к. выдавали плановый аванс. Сейчас же сделали зп за 1 и 2 половину месяца, и это начисление стало попадать в 1 часть, а должно в окончательный расчет.
   Alexandr_U1982
 
2 - 20.07.18 - 11:51
Никак. Только в ЗУП 3 можно указать признак включения/исключения начисления при расчете зарплаты за первую половину месяца.
   dka80
 
3 - 20.07.18 - 13:13
Дописать код, который будет проходить табличную часть и удалять лишнее начисление. Только потом НДФЛ и удержания не забудьте пересчитать
   dchumak
 
4 - 23.07.18 - 05:19
(2) спасибо, полезная информация.
   dchumak
 
5 - 23.07.18 - 05:21
(3) думаю проще будет запретить проводить документ, если стоит признак "Зарплата за 1 половину месяца" и в ТЧ есть начисление "Аренда..." Это можно сделать через подписку на событие, не правя документ. А с цифрами уже пусть расчетчик разбирается.
   Фрэнки
 
6 - 23.07.18 - 08:25
Надо было сразу начинать вопросы об ошибках с инфы, что это начисление Аренда и оно вот как-то кривенько создано.

В расчет за первую половину не всякие виды расчетов попадают - это зависит от установленных признаков в самом расчете. Конкретней трудно угадать. Не исключено, что какие-то мелкие глюки не совпадают в УПП 1.3 с ЗУП 2.5 по этой части.
   Фрэнки
 
7 - 23.07.18 - 08:40
Я бы глянул на вкладку "Время" у введенного вида расчета Аренда
   dchumak
 
8 - 23.07.18 - 10:08
(7) на вкладке "Время" установлен вид времени как "Дополнительное начисление за уже отработанное время". Остальные виды привязаны к отработанному времени, если поставить их, то, скорее всего, это начисление будет дробиться в пределах отработанного времени или нормы времени.
   Alexandr_U1982
 
9 - 23.07.18 - 10:44
(6) В плане видов расчета "ОсновныеНачисленияОрганизаций" есть реквизит "НачисляетсяВЦеломЗаМесяц". Возможно, виды расчета, в которых реквизит "НачисляетсяВЦеломЗаМесяц" имеет значение "Истина" и могут не попадать в расчет за первую половину месяца. Сам не проверял, просто предположение.
   dchumak
 
10 - 23.07.18 - 10:57
(9) реквизит в ИСТИНА у нужных нам начислений.
Функция УстановитьФлагНачисляетсяВЦеломЗаМесяц(ПроизвольнаяФормулаРасчета, Показатели, СпособРасчета = Неопределено, БазовыйПериодПрошлыйМесяц = Ложь) Экспорт
    
    НачисляетсяВЦеломЗаМесяц = Истина;
    
    Если ПроизвольнаяФормулаРасчета Тогда
        
        СписокПоказателей = Новый Массив;
        СписокПоказателей.Добавить(Справочники.ПоказателиСхемМотивации.ВремяВДнях);
        СписокПоказателей.Добавить(Справочники.ПоказателиСхемМотивации.ВремяВКалендарныхДнях);
        СписокПоказателей.Добавить(Справочники.ПоказателиСхемМотивации.ВремяВЧасах);
        СписокПоказателей.Добавить(Справочники.ПоказателиСхемМотивации.ОтработаноВремениВДнях);
        СписокПоказателей.Добавить(Справочники.ПоказателиСхемМотивации.ОтработаноВремениВЧасах);
        СписокПоказателей.Добавить(Справочники.ПоказателиСхемМотивации.РасчетнаяБаза);
        СписокПоказателей.Добавить(Справочники.ПоказателиСхемМотивации.СдельнаяВыработка);
        
        ПоказателиСхемМотивацииПереопределяемый.ДополнитьПоказателиНачисляетсяВЦеломЗаМесяц(СписокПоказателей);
        
        Для Каждого СтрПоказателя Из Показатели Цикл
            Если СписокПоказателей.Найти(СтрПоказателя.Показатель) <> Неопределено Тогда
                НачисляетсяВЦеломЗаМесяц = Ложь;
                Прервать;
            КонецЕсли;
        КонецЦикла;
        
    Иначе
        
        НачисляетсяВЦеломЗаМесяц = СпособРасчета = Перечисления.СпособыРасчетаОплатыТруда.ФиксированнойСуммой ИЛИ БазовыйПериодПрошлыйМесяц;
        
    КонецЕсли;
    
    Возврат НачисляетсяВЦеломЗаМесяц;
    
КонецФункции

У нас фиксированная сумма => реквизит в истина
 
 
   Alexandr_U1982
 
11 - 23.07.18 - 11:01
(10)Я себе в ПВР "ОсновныеНачисленияОрганизаций" дописал флаг "РассчитываетсяЗаПервуюПоловинуМесяца". И при заполнении документа "НачислениеЗарплатыРаботникамОрганизации" отфильтровываю не нужные начисления.
   РБ
 
12 - 23.07.18 - 11:11
(11) так сделано в ERP, по-крайней, мере.
наверное, и в ЗУП 3


Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует