Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: как получить список вариантов select из под 1с 7.7 ?

v7: как получить список вариантов select  из под 1с 7.7 ?
Я
   DES
 
19.07.18 - 20:19
<div class="col-lg-2">
select name="c2l00$ContentPlaceHolder1$DropDownList3" tabindex="2" class="form-control" id="ContentPlaceHolder1_DropDownList3" style="color:Blue;font-size:Medium;" onchange="javascript:setTimeout('__doPostBack(\'ctl00$ContentPlaceHold\',\'\')', 0)">
    <option selected="selected" value="-1">--------</option>
    <option value="0">вариант0</option>
    <option value="1">вариант1(с.)</option>
    <option value="2">вариант2(с.)</option>
    <option value="3">вариант3(с.)</option>

</select>
</div>
 
 
   Злопчинский
 
1 - 19.07.18 - 20:27
а в чем проблема? распарсить иксемель не знаешь как?
   Злопчинский
 
2 - 19.07.18 - 20:30
Иксемель = СоздатьОбъект("Microsoft.XMLDOM");
    Иксемель.Load(ФайлДанных);
    Корень = Иксемель.DocumentElement;
    
    ОбработатьУзел(Корень, 0);//тест чтения
   Злопчинский
 
3 - 19.07.18 - 20:31
//**************************************************************************************

//
Процедура ОбработатьУзел(Узел, Уровень=0)
    Состояние(Уровень);
    
    //Если СЗузлы.НайтиЗначение(Врег(Узел.tagName)) = 0 Тогда

    //    Стр = Формат("","С"+Уровень*8);

    //    Сообщить(Стр + "<--- узел не обрабатывается согласно установленным ограничениям -->");

    //    Возврат;

    //КонецЕсли;

    
    КолвоУзлов = Узел.childNodes.length;
    Для СчУзлов = 0 По КолвоУзлов-1 Цикл
        
        ТекУзел = Узел.childNodes.item(СчУзлов);
        Если ТекУзел.nodeType <> 1 Тогда Продолжить; КонецЕсли;
        
        Стр = Формат("","С"+Уровень*8);
        
        СтрАтрибуты = "";
        Для счАтрибутов = 0 По ТекУзел.attributes.length-1 Цикл
            Атрибут     = ТекУзел.attributes.item(счАтрибутов);
            СтрАтрибуты    = СтрАтрибуты + ?(СтрАтрибуты="","",";") + Атрибут.nodename+"="+Атрибут.value;
        КонецЦикла;
        
        ТекстУзла = "";
        Если ТекУзел.childNodes.length = 1 Тогда
            Если  ТекУзел.childNodes.item(0).nodetype = 3 Тогда ТекстУзла = ТекУзел.childNodes.item(0).text; КонецЕсли;
        КонецЕсли;
        
        Стр = Стр + ТекУзел.tagName + ?(СтрАтрибуты="","","("+СтрАтрибуты+")" ) + ": " +ТекстУзла;
        Сообщить(Стр);
        
        ОбработатьУзел(ТекУзел, Уровень+1);
    КонецЦикла;
    
    Состояние("");
КонецПроцедуры// ОбработатьУзел()
   Злопчинский
 
4 - 19.07.18 - 20:31
Это если совсем по тупому, последовательным чтением-разбором.
   DES
 
5 - 19.07.18 - 20:33
не, через Новый COMОбъект("InternetExplorer.Application"); 
надо.

получил IE0.document.getElementByID(ElementByID)
это тип SELECTкак его распарсить?
   DES
 
6 - 19.07.18 - 20:49
нашел
IE0.document.getElementByID("ContentPlaceHolder1_DropDownList4").options(2)

Список тем форума
Рекламное место пустует  Рекламное место пустует
Читай всё полезное и впитывай, а нападки игнорируй. Здесь так принято. aka AMIGO
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует