Вход | Регистрация

1С:Предприятие ::

Метки: 

внешняя печатная - показать в word

Я
   shira84
 
19.07.18 - 13:41
собстно сделал обработку, но не знаю как правильно пустить ее на вывод, обычные табдоки выводятся через         УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм,"Договор","Договор",СформироватьПечатнуюФормуДоговор(МассивОбъектов));
Но я так понимаю это не тот случай
 
  Рекламное место пустует
   shira84
 
1 - 19.07.18 - 13:49
пока сделал обычной процедурой, но все время выходит что в обработчике печати не был сформирован табличный документ, но Word все показывает
   shira84
 
2 - 19.07.18 - 13:59
Функция СведенияОВнешнейОбработке() Экспорт
    
    ПараметрыРегистрации = Новый Структура;
    
    ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма");
    ПараметрыРегистрации.Вставить("Назначение", ПолучитьНазначениеОбработки());
    ПараметрыРегистрации.Вставить("Наименование", НСтр("ru = 'Трудовой договор Word'"));
    ПараметрыРегистрации.Вставить("Версия", "1.0");
    ПараметрыРегистрации.Вставить("БезопасныйРежим", Ложь);
    ПараметрыРегистрации.Вставить("Информация", НСтр("ru = 'Трудовой договор Word'")
    );
    
    ТаблицаКоманд = ПолучитьТаблицуКоманд();
    
    ДобавитьКоманду(ТаблицаКоманд,
                    НСтр("ru = 'Трудовой договор Word'"),
                    "ТрудовойДоговорWord",
                    "ВызовСерверногоМетода",
                    Истина,
                    "ПечатьMXL");
    
    ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
    
    Возврат ПараметрыРегистрации;
    
КонецФункции


Процедура Печать(МассивОбъектов,
                КоллекцияПечатныхФорм,
                ОбъектыПечати,
                ПараметрыВывода) Экспорт
    

    Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "ТрудовойДоговорWord") Тогда
        
        УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм,"Договор","Договор",СформироватьПечатнуюФормуАкт(МассивОбъектов));
            
    КонецЕсли;
    
    
КонецПроцедуры
   Serg_1960
 
3 - 19.07.18 - 14:22
   Serg_1960
 
4 - 19.07.18 - 14:32
"ВызовСерверногоМетода" можно заменить на "ВызовКлиентскогоМетода" - перестанет доставать дурацкими вопросами. Там немножко другой алгоритм работы с печатными формами. Ну, или, таки можно ему сформировать липовую печатную форму с одной единственной строкой типа "Печатная форма сформирована и открыта в отдельном окне Word" - пусть подавится :)


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует