Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Бух базовая 8.3 - для организации не заполнена учетная политика

Бух базовая 8.3 - для организации не заполнена учетная политика
Я
   Масянька
 
18.07.18 - 08:56
Доброе утро!
Я гуглила - ничего толком не нагуглила...
Перенос из УТ 10.2 в Бух 8.3 (базовая, 3.0.62.17).
Поступление (перенесено) - при попытке провести выдает:
для организации на июнь 2018 не заполнена учетная политика.
для организации на июнь 2018 не задана система налогообложения.
Делаю ручками точно такое же поступление (контрагент, склад, номенклатура, сумма, дата) - спокойно проводится.
В чем косяк у перенесенных?
Спасибо.
 
 
   zak555
 
1 - 18.07.18 - 08:57
с помощью чего переносила ?
   Масянька
 
2 - 18.07.18 - 08:58
(1) КД 2.1
   zak555
 
3 - 18.07.18 - 08:58
ИРом сравни два документа и посмотри, какой реквизит не заполнен
   Масянька
 
4 - 18.07.18 - 08:59
(3) "ИРом" - это чего?
   zak555
 
5 - 18.07.18 - 09:00
   unbred
 
6 - 18.07.18 - 09:01
(0) попробуй в созданных организацию перевыбрать..
   unbred
 
7 - 18.07.18 - 09:01
(6) перенесенных*
   Масянька
 
8 - 18.07.18 - 09:04
(6) У меня нет на форме организации (и в "изменить форму" тоже нет).
   unbred
 
9 - 18.07.18 - 09:05
(8) ага,базовая же. туплю.
   Масянька
 
10 - 18.07.18 - 09:08
(5) Качнула портативный. И чего брать?
 
 Рекламное место пустует
   alexshape
 
11 - 18.07.18 - 09:10
(10) Возможно у Вас учетная политика с июля, а документы вы загружаете июнь. Гляньте с какого числа?
   Масянька
 
12 - 18.07.18 - 09:11
(11) Я же написала: руками делаю аналогичный док-т (дата, контрагент, склад, номенклатура, сумма) - проводится.
Учетная политика с января 2018.
   Mankubus
 
13 - 18.07.18 - 09:15
отладчик сломался?
   Масянька
 
14 - 18.07.18 - 09:39
(13) Типа того...
Короче:
- сняла с поддержки.
- модуль Учетная политика.
- функция Существует

Функция Существует(Организация, Период, ВыводитьСообщениеОбОтсутствииУчетнойПолитики = Ложь, ДокументСсылка = Неопределено) Экспорт
    
    СпособОценкиТоваровВРознице = ПолучитьФункциональнуюОпцию("СпособОценкиТоваровВРознице", 
        Новый Структура("Организация, Период", Организация, НачалоМесяца(Период)));
        
    УчетнаяПолитикаСуществует = НЕ (СпособОценкиТоваровВРознице = Ложь);
сообщить("" + Организация + " - " + УчетнаяПолитикаСуществует);    
    Если НЕ УчетнаяПолитикаСуществует
        И ВыводитьСообщениеОбОтсутствииУчетнойПолитики = Истина Тогда
        ТекстСообщения = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
            НСтр("ru='Для организации %1 на %2 не заполнена учетная политика.'"),
            Организация,
            Формат(НачалоМесяца(Период), "ДФ='MMMM yyyy'"));
        ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстСообщения, ДокументСсылка, , "Объект");
    КонецЕсли;

    СистемаНалогообложения = ПолучитьФункциональнуюОпцию("СистемаНалогообложения", 
        Новый Структура("Организация, Период", Организация, НачалоМесяца(Период)));
    
    НалоговыеНастройкиСуществуют = НЕ (СистемаНалогообложения = Ложь);
    
    Если НЕ НалоговыеНастройкиСуществуют
        И ВыводитьСообщениеОбОтсутствииУчетнойПолитики = Истина Тогда
        ТекстСообщения = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
            НСтр("ru='Для организации %1 на %2 не задана система налогообложения.'"),
            Организация,
            Формат(НачалоМесяца(Период), "ДФ='MMMM yyyy'"));
        ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстСообщения, ДокументСсылка, , "Объект");
    КонецЕсли;
    
    Возврат УчетнаяПолитикаСуществует И НалоговыеНастройкиСуществуют;

КонецФункции

сообщить вывело:
- Нет.
Насколько я поняла - организации нет...

Список тем форума
Рекламное место пустует  Рекламное место пустует
AdBlock убивает бесплатный контент. 1Сергей
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует