Вход | Регистрация

1С:Предприятие ::

Метки: 

УТ 11.4 и ШК весового товара.

Я
   Aleksey_a_z
 
17.07.18 - 13:33
При генерации ШК весового товара вываливает 2_0000100000_
полез в конфигуратор и вот функция:



Функция ПолучитьШтрихкодВесовогоТовараПоКоду(Код, ПрефиксУзлаШтрихкода = "_", Загрузка = Ложь) Экспорт

    Если Загрузка Тогда
        КодТовара = Формат(Код, "ЧЦ=5; ЧВН=; ЧГ=");
    Иначе
        КодТовара = Строка(ПрефиксУзлаШтрихкода) + Формат(Код, "ЧЦ=4; ЧВН=; ЧГ=");
    КонецЕсли;
    
    Штрихкод = "2_" + КодТовара + "00000";
    
    КонтрольныйСимволEAN = "_";
    Штрихкод = Штрихкод + КонтрольныйСимволEAN;

    Возврат Штрихкод;

КонецФункции


Намертво прописывается нижний слеш вместо кода весового товара и контрольной суммы? Это так и должно быть?
 
  Рекламное место пустует
   Aleksey_a_z
 
1 - 17.07.18 - 13:34
ну и предшествующая функция:

// Функция осуществляет формирование штрихкода EAN13 для

// весового товара.
//

// Возвращаемое значение:
//  Строка - Штрихкод весового товара.

//
Функция СформироватьШтрихкодВесовогоТовараEAN13() Экспорт

    ПрефиксУзлаШтрихкода = ПрефиксУзлаШтрихкода();

    Код = ПолучитьМаксимальноеЗначениеКодаВесовыхШтрихкодов() + 1;
    
    Если Код = Неопределено Тогда
        ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстСообщенияНетСвободныхКодовВесовыхШтрихкодов());
        Возврат Неопределено;
    КонецЕсли;
    
    Возврат ПолучитьШтрихкодВесовогоТовараПоКоду(Код, ПрефиксУзлаШтрихкода);

КонецФункции
   Garykom
 
2 - 17.07.18 - 13:35
ПрефиксУзлаШтрихкода() - посмотри

И задай его где то
   Aleksey_a_z
 
3 - 17.07.18 - 13:36
(2) префикс узла 0
   Злопчинский
 
4 - 17.07.18 - 13:36
(2) ага, от этого контрольный символ ЕАН, заданный литералом превратится в переменную...?
   Garykom
 
5 - 17.07.18 - 13:37
Хотя какой то изврат
   Garykom
 
6 - 17.07.18 - 13:37
(4) Да понял уже че то тут не так
   Aleksey_a_z
 
7 - 17.07.18 - 13:39
(2) Но причем здесь префикс узла, я жму кнопку "новый шк"

Процедура НовыйШтрихкод(Команда)
    
    ОчиститьСообщения();
    
    Если ЭтоВесовойТовар(Запись.Номенклатура, Запись.Упаковка) Тогда
        Запись.Штрихкод = СформироватьШтрихкодEAN13ВесовогоТовара();
    Иначе
        Запись.Штрихкод = СформироватьШтрихкодEAN13();
    КонецЕсли;
    
КонецПроцедуры



далее попадаю в 


Функция СформироватьШтрихкодВесовогоТовараEAN13() Экспорт

    ПрефиксУзлаШтрихкода = ПрефиксУзлаШтрихкода();

    Код = ПолучитьМаксимальноеЗначениеКодаВесовыхШтрихкодов() + 1;
    
    Если Код = Неопределено Тогда
        ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстСообщенияНетСвободныхКодовВесовыхШтрихкодов());
        Возврат Неопределено;
    КонецЕсли;
    
    Возврат ПолучитьШтрихкодВесовогоТовараПоКоду(Код, ПрефиксУзлаШтрихкода);

КонецФункции


и уже сюда


Функция ПолучитьШтрихкодВесовогоТовараПоКоду(Код, ПрефиксУзлаШтрихкода = "_", Загрузка = Ложь) Экспорт

    Если Загрузка Тогда
        КодТовара = Формат(Код, "ЧЦ=5; ЧВН=; ЧГ=");
    Иначе
        КодТовара = Строка(ПрефиксУзлаШтрихкода) + Формат(Код, "ЧЦ=4; ЧВН=; ЧГ=");
    КонецЕсли;
    
    Штрихкод = "2_" + КодТовара + "00000";
    
    КонтрольныйСимволEAN = "_";
    Штрихкод = Штрихкод + КонтрольныйСимволEAN;

    Возврат Штрихкод;

КонецФункции
   Aleksey_a_z
 
8 - 17.07.18 - 13:41
Взял паузу, надо придумать что сказать завтра клиенту ))
   yzimin
 
9 - 17.07.18 - 13:56
(7) Всё нормально, для весового товара ШК задаётся как шаблон, там смысл чуть другой, чем у штучного товара. Почитай википедию
   Garykom
 
10 - 17.07.18 - 14:01
Точно веса же нет еще, он с весов приходит внутри ШК и конфа по заполненному ШК с весом подбирает шаблон, находит номенклатуру и вычисляет вес.
 
  Рекламное место пустует
   GrandSportS
 
11 - 17.07.18 - 14:11
Советую залезть еще в ФО - Номенклатура - Настройки создания - Настройки префиксов кодов - убедиться, что верно присвоены типы штрихкодов (штучный, весовой) для нужных диапазонов.
   GrandSportS
 
12 - 17.07.18 - 14:13
(0) И судя по "2_0000100000_" у вас присовен тип Штучный, а должен быть Весовой.
   yzimin
 
13 - 17.07.18 - 14:17
(12) это шаблон весового. Для слепых даже два нижних подчеркивания вставлено
   Aleksey_a_z
 
14 - 18.07.18 - 15:54
(12) Внимательно смотрели код?


Список тем форума
Рекламное место пустует   Рекламное место пустует
Я не хочу быть самым богатым человеком на кладбище. Засыпать с чувством, что за день я сделал какую-нибудь потрясающую вещь — вот что меня интересует. Стив Джобс, 1996 г.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует