Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

1c обход по группировкам

1c обход по группировкам
Я
   jamesgold
 
17.07.18 - 10:09
Добрый день, прошу помочь!

Каким образом получить значение размера при обходе? Итоги по размеру мне не нужны, просто вытащить значение нужно при обходе.

Имеется вот такой запрос:
ВЫБРАТЬ
    ВрТабл.Номенклатура КАК Номенклатура,
    ВрТабл.Спецификация КАК Спецификация,
    ВрТабл.Размер КАК Размер,
    СУММА(ВрТабл.КонечныйОстаток) КАК КонечныйОстаток,
    СУММА(ВрТабл.НачальныйОстаток) КАК НачальныйОстаток,
    СУММА(ВрТабл.Приход) КАК Приход,
    СУММА(ВрТабл.Расход) КАК Расход,
    ВрТабл.ПрефиксАртикула КАК ПрефиксАртикула,
    ВрТабл.ЦифрыАртикула КАК ЦифрыАртикула,
    СУММА(ВрТабл.р_Приход) КАК р_Приход,
    СУММА(ВрТабл.р_Расход) КАК р_Расход,
    ВрТабл.Склад КАК Склад
ИЗ
    ВрТабл КАК ВрТабл

СГРУППИРОВАТЬ ПО
    ВрТабл.ЦифрыАртикула,
    ВрТабл.Спецификация,
    ВрТабл.Номенклатура,
    ВрТабл.Размер,
    ВрТабл.ПрефиксАртикула,
    ВрТабл.Склад

УПОРЯДОЧИТЬ ПО
    Расход УБЫВ
ИТОГИ
    СУММА(КонечныйОстаток),
    СУММА(НачальныйОстаток),
    СУММА(Приход),
    СУММА(Расход),
    СУММА(р_Приход),
    СУММА(р_Расход)
ПО
    ОБЩИЕ,
    Номенклатура,
    Спецификация,
    Склад



ВыборкаПоАртикулу = РезультатЗапроса.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"Номенклатура");

Пока ВыборкаПоАртикулу.Следующий() Цикл
    
    ОбластьСтрокаАртикул.Параметры.Заполнить(ВыборкаПоАртикулу);
    
    ВыборкаПоСклад = ВыборкаПоАртикулу.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"Склад");
    Пока ВыборкаПоСклад.Следующий() Цикл
        ОбластьСтрокаСпецификация.Параметры.Заполнить(ВыборкаПоСклад);
        
        ВыборкаПоСпецификация = ВыборкаПоСклад.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"Спецификация");
        Пока ВыборкаПоСпецификация.Следующий() Цикл
            
            ОбластьСтрокаСпецификация.Параметры.Заполнить(ВыборкаПоСпецификация);
            
            //Не могу получить значение размера

            //Размер = ВыборкаПоСпецификация.Размер;

            
        КонецЦикла;    
        
    КонецЦикла;
    
КонецЦикла;
 
 
   1Сергей
 
1 - 17.07.18 - 10:17
снаружи нужна ещё одна выборка по общим итогам
   jamesgold
 
2 - 17.07.18 - 10:18
(1) есть, не указа тут просто
   jamesgold
 
3 - 17.07.18 - 10:18
В группировочном поле "размер" не указываю, не нужны итоги по нему
   1Сергей
 
4 - 17.07.18 - 10:20
нужны выборки по всем итогам:
   ОБЩИЕ,
    Номенклатура,
    Спецификация,
    Склад

и ещё одна по детализации
   1Сергей
 
5 - 17.07.18 - 10:21
и в том же порядке как в запросе
   jamesgold
 
6 - 17.07.18 - 10:21
еще одна - размер?
   jamesgold
 
7 - 17.07.18 - 10:22
Нужно обязательно делать итоги по ней чтобы можно было получить значение при обходе?
   1Сергей
 
8 - 17.07.18 - 10:22
(7) нет
ВыборкаДетализация = ВыборкаПоСпецификация.Выбрать();
   1Сергей
 
9 - 17.07.18 - 10:23
Посмотри как в других местах сделано, в конфе
   jamesgold
 
10 - 17.07.18 - 10:24
ВыборкаДетализация в ней будет размер?
 
 Рекламное место пустует
   jamesgold
 
11 - 17.07.18 - 10:30
(9) Спасибо! Размеры получил. Нужен был дополнительный обход после после последней группировки!

Список тем форума
Рекламное место пустует  Рекламное место пустует
Программист всегда исправляет последнюю ошибку.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует