Вход | Регистрация

1С:Предприятие ::

Метки: 

Ошибка: Конструктор не найден

Я
   Vladislava-smile
 
16.07.18 - 04:13
Ошибка возникает при выполнении регламента на сервере. Если выполнять функцию через клиента (обработка) все работает.

Процедура СФормироватьУведомленияОбЭтапахПоставки() Экспорт
    
    Запрос = Новый Запрос();
    
    Запрос.Текст = "ВЫБРАТЬ РАЗРЕШЕННЫЕ
                   |    ЗаказПоставщикуЭтапыПоставкиТовара.Ссылка,
                   |    ЗаказПоставщикуЭтапыПоставкиТовара.Этап,
                   |    ЗаказПоставщикуЭтапыПоставкиТовара.Дата
                   |ИЗ
                   |    Документ.ЗаказПоставщику.ЭтапыПоставкиТовара КАК ЗаказПоставщикуЭтапыПоставкиТовара
                   |ГДЕ
                   |    ЗаказПоставщикуЭтапыПоставкиТовара.Ссылка.Проведен
                   |    И НЕ ЗаказПоставщикуЭтапыПоставкиТовара.Исполнено
                   |    И НАЧАЛОПЕРИОДА(ЗаказПоставщикуЭтапыПоставкиТовара.Дата, ДЕНЬ) = &ТекущаяДата";
                   
    Запрос.УстановитьПараметр("ТекущаяДата", НачалоДня(ТекущаяДата()));        
    
    Выборка = Запрос.Выполнить().Выбрать();
    
    П_Администратор = Справочники.Пользователи.НайтиПоНаименованию("Администратор");
    
    Пока Выборка.Следующий() Цикл
        
        ЗаказПоставщику = Выборка.Ссылка;
        
        Если ЗначениеЗаполнено(ЗаказПоставщику.Ответственный) тогда
                          
            СписокПолучателей = Новый СписокЗначений;
            ДобавитьПользователяВСписокПолучателей(СписокПолучателей, ЗаказПоставщику.Ответственный);
            
            Если ЗаказПоставщику.Ответственный <> ЗаказПоставщику.Ответственный.Руководитель тогда 
                ДобавитьПользователяВСписокПолучателей(СписокПолучателей, ЗаказПоставщику.Ответственный.Руководитель);
            КонецЕсли;    
            
            ОписаниеУведомления = Строка(КонецДня(Выборка.Дата)) + " истекает срок исполнения этапа поставки: " + Выборка.Этап;  
            
            СоздатьУведомление(ЗаказПоставщику, ОписаниеУведомления, СписокПолучателей, П_Администратор);    
        КонецЕсли;
        
    КонецЦикла;    
    
КонецПроцедуры

В свойствах галки: Сервер, Клиент (обычное), вызов сервера.

В чем может быть проблема подскажите пжлст?
 
 
   Cool_Profi
 
1 - 16.07.18 - 04:38
Пытаюсь протелепать, но не удаётся....
В какой конкретно строке ошибка?
   Галахад
 
2 - 16.07.18 - 04:44
Проблема скорее всего с другой процедуре. Вызов какого-нибудь клиентского метода.
   Vladislava-smile
 
3 - 16.07.18 - 06:07
(2), спасибо, оказались правы. Перенесал в отдельный модуль - все заработало


Список тем форума
Рекламное место пустует  
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует