Вход | Регистрация


1С:Предприятие ::

Метки: 

Конвертация 2.1 - условие по таб. части

Я
   Масянька
 
13.07.18 - 15:45
День добрый!
КД для УТ 10.2 в Бух 3.
Имеем в УТ поступление и в бухии поступление. Но в УТ нет вида операции.
Как извернуться: если ТЧ услуги -> вид операции = услуги, если ТЧ товары -> вид операции = товары?
Спасибо.
 
 
   ssh2006
 
1 - 13.07.18 - 15:47
(0) Если  ТЧ услуги.Количество() > 0 вид операции = услуги
   user-ok
 
2 - 13.07.18 - 15:49
А если заполнены обе ТЧ?
   Масянька
 
3 - 13.07.18 - 15:56
(1) Самый умный? :)
Я уже так пробовала:
ПТУ - ПВД - перед выгрузкой - 
Если Объект.Услуги.Количество() > 0 Тогда
    ВидОперации = Перечисление.ВидыОперацийПоступлениеТоваровУслуг.Услуги;
КонецЕсли;
перемененная не определена.
(2) Фиолетово - раз. Два - божатся, что так не делают.
   Масянька
 
4 - 13.07.18 - 15:57
+ (3) Перечисление может в параметры воткнуть?
   user-ok
 
5 - 13.07.18 - 15:58
(3) а кто такой "Объект"? в обработчике ПВД?
может таки "источник" ?
   Масянька
 
6 - 13.07.18 - 15:58
+(4) А нету...
   Масянька
 
7 - 13.07.18 - 15:59
(5) Это почему вдруг?
   Масянька
 
8 - 13.07.18 - 16:00
Переменная не определена (Перечисление).
   hhhh
 
9 - 13.07.18 - 16:01
(4) зачем в пвд? делайте в пко.
   user-ok
 
10 - 13.07.18 - 16:01
(9) сам только допер
в ПКС
 
 
   ssh2006
 
11 - 13.07.18 - 16:04
(3)
В ПКС ВидОперации  
Если Источник.Услуги.Количество() > 0 Тогда
    Значение = Перечисление.ВидыОперацийПоступлениеТоваровУслуг.Услуги;
КонецЕсли;
   Михаил Козлов
 
12 - 13.07.18 - 16:06
(11) Может ПеречислениЯ ?
   user-ok
 
13 - 13.07.18 - 16:08
в 11 правильный ответ. все остальное от лукавого ))
   Масянька
 
14 - 13.07.18 - 16:10
https://pastenow.ru/643fcd26649dc44d5a961288097a6bf6 - выдает при выгрузке "Поле объекта не обнаружено "ВидОперации)".
   Масянька
 
15 - 13.07.18 - 16:11
+ (14) Если "Перечисление" (там же) - Переменная не определена (Перечисление)
   ssh2006
 
16 - 13.07.18 - 16:15
(15) ЗНАЧЕНИЕ = Перечисления.ВидыОперацийПоступлениеТоваровУслуг.Услуги;
   ssh2006
 
17 - 13.07.18 - 16:16
Надо так и написать Значение =
Нажми кнопку Информация по обработчикам, там хорошая встроенная справка
   Масянька
 
18 - 13.07.18 - 16:16
(16) Я уже поправила.
Ругается именно на ПЕРЕЧИСЛЕНИЕ.
В источнике нету (НЕТУ СОВСЕМ) такого перечисления.
   ssh2006
 
19 - 13.07.18 - 16:18
(18) аа, тогда так:

Значение = "Услуги";
   Масянька
 
20 - 13.07.18 - 16:18
В УТ нет в док-те ВидОперации и нет Перечисления.ВидыОперацийПоступлениеТОваровУслуг.
   Масянька
 
21 - 13.07.18 - 16:20
(19) Поле объекта не обнаружено (ВидОперации).
   Масянька
 
22 - 13.07.18 - 16:34
   ssh2006
 
23 - 13.07.18 - 16:35
(19) напиши 
Значение = "Услуги";

Вместо 

Значение = Перечисление.ВидыОперацийПоступлениеТоваровУслуг.Услуги;
   Масянька
 
24 - 13.07.18 - 16:36
(23) Написала уже давно.
Вы не поверите - Иначе нужно обработать...
Блин... Тоже мне Ванги :)))
   Масянька
 
25 - 13.07.18 - 16:37
Блин... Мужики, мужики...
   Масянька
 
26 - 13.07.18 - 16:38
Все равно - спасибо!
   ssh2006
 
27 - 13.07.18 - 16:38
(26)  так получилось то все?
   Масянька
 
28 - 13.07.18 - 16:42
(27) Есесьно - я же умница!
   d4rkmesa
 
29 - 13.07.18 - 20:45
(0) Что-то вроде такого писал, ПКС ВидОперации->ВидОперации(стандартное ПКО ВидыОперацийРеализацияТоваров), в обработчике ПередВыгрузкой:

ЕстьТовары = (Источник.Товары.Количество() > 0);
ЕстьУслуги = (Источник.Услуги.Количество() > 0);

Если ЕстьТовары И НЕ ЕстьУслуги Тогда
    
    Выражение = "Перечисления.ВидыОперацийРеализацияТоваров.Товары";
    
ИначеЕсли НЕ ЕстьТовары И ЕстьУслуги Тогда
    
    Выражение = "Перечисления.ВидыОперацийРеализацияТоваров.Услуги";
    
КонецЕсли;
   Масянька
 
30 - 16.07.18 - 15:04
Тут продолжу...
В УТ нет вида номенклатуры (спр. номенклатура), а в БП это справочник.
ПКС:
Если Источник.Услуга = Истина Тогда
    Значение = "Услуги";
Иначе
    Значение = "Товары";
КонецЕсли;
Фигня - номенклатуру загружает, а вида нет...
   Масянька
 
31 - 16.07.18 - 17:59
Люди! Никто ничего не скажет? По (30), а?
   Масянька
 
32 - 16.07.18 - 18:01
Ну, ладно... Вот новую ветку заведу...
   Масянька
 
33 - 17.07.18 - 08:27
Люди! Ну будьте человеками!
Киньте мыслью какой-нибудь!
 
  Рекламное место пустует
   alkov
 
34 - 17.07.18 - 08:29
(30) ПКО назначено, в котором по наименованию будет искаться вид номенклатуры?
   Масянька
 
35 - 17.07.18 - 08:29
И предопределенных нет в справочнике...
Не, ну, кто так пишет...
   Масянька
 
36 - 17.07.18 - 08:30
(34) Где? В док-тах или справочнике?
   alkov
 
37 - 17.07.18 - 08:31
(36) я думал, речь про перенос номенклатуры в номенклатуру
   Масянька
 
38 - 17.07.18 - 08:32
(37) И это тоже.
Общий смысл: из УТ выгружать поступления и реализации за период и по организации. Ну, со всеми вытекающими.
То есть - номенклатура тоже должна выгружаться.
   Масянька
 
39 - 17.07.18 - 08:35
Сделала так - https://pastenow.ru/87d73879e15560287ade41c51f1f45ef.
И как теперь при загрузке обработать?
А может есть красивый вариант?
   alkov
 
40 - 17.07.18 - 08:36
Для вида номенклатуры я бы сделал ПКО Номенклатура -- Вид номенклатуры, в котором по реквизиту Наименование был бы поиск, и в ПКС наименования Перед выгрузкой был бы код из (30).

По этому правилу выгружал б реквизит "Вид номенклатуры" в ПКО Номенклатура -- Номенклатура
   alkov
 
41 - 17.07.18 - 08:37
(39) такое сгодилось бы для перечисления, а для справочника отдельное ПКО нужно, имхо, как в (40)
   user-ok
 
42 - 17.07.18 - 08:38
ПКО для справочника "Виды номенклатуры"
источник пустой, приемник - Виды номенклатуры
одно ПКС для поля Наименование
в нем "Перед выгрузкой"
Значение = Источник;
   Масянька
 
43 - 17.07.18 - 08:44
   user-ok
 
44 - 17.07.18 - 08:57
категорически не так
1. в моем примере входящие данные вообще не используются. можешь использовать их, но тогда при выгрузке Вида номенклатуры в соответствующем ПКС ПКО "Номенклатура" заполняй не значение, а исходящие данные
2. код именно в "Перед выгрузкой". если будешь делать через входящие данные - тогда вообще не нужен
   user-ok
 
45 - 17.07.18 - 09:01
   Масянька
 
46 - 17.07.18 - 09:13
(45) Виды номенклатуры - https://pastenow.ru/55c50a4a09bd8a14c022035be74e5372
Номенклатура - https://pastenow.ru/8e92306c15f35d7568b0e9a8bc9cadd3
Проверяю...
   Масянька
 
47 - 17.07.18 - 09:18
(45) Спасибо огромное!!!!
   user-ok
 
48 - 17.07.18 - 09:20
всегда пожалуйста. не ради рекламы - послушай на досуге Гилева. для таких задач достаточно первой части
   Масянька
 
49 - 18.07.18 - 12:24
При выгрузке - выгружено 312.
При загрузке - загружено 306.
Вариант узнать - что не грузится?
 
  Рекламное место пустует
   Масянька
 
50 - 18.07.18 - 15:22
Буду продолжать...
Поступление (из УТ в Бух) - все норм, за исключением одной фигни...
На форме поступления есть поле "ЦеныИВалюта". Редактируется это поле путем вызова формы "Цены в док-те" (ФормаЦеныИВалюта).
Как до неё достучаться из КД? Смысл в том, что при загрузке док-ов пихается "НДС сверху", а надобно "НДС не выделять".
   MonteCarlo
 
51 - 18.07.18 - 15:30
(18) Надо не Значение = ... , а Выражение = "Перечисление.ВидыОПераций.Услуги";
   Масянька
 
52 - 18.07.18 - 15:33
(51) Ты спи дольше - это уже сделала...
   Масянька
 
53 - 18.07.18 - 15:34
Люди! Ну, скажите чего-нибудь на (50). А?
   Mankubus
 
54 - 18.07.18 - 15:34
(50) посмотри в отладчике какой реквизит заполняется после закрытия этой формы с ценой и валютой
   Масянька
 
55 - 18.07.18 - 15:42
(54) Есть такой кусок - мне не понятный:
    Если ОткрыватьИзМеню Тогда
        
        СписокКоманд = Новый СписокЗначений;
        Если Не Форма.ПлательщикНДС Тогда
            СписокКоманд.Добавить(ПредопределенноеЗначение("Перечисление.ВариантыРасчетаНДС.НДСНеВыделять"));
        КонецЕсли;
        СписокКоманд.Добавить(ПредопределенноеЗначение("Перечисление.ВариантыРасчетаНДС.НДССверху"));
        СписокКоманд.Добавить(ПредопределенноеЗначение("Перечисление.ВариантыРасчетаНДС.НДСВСумме"));
        Если НЕ Форма.ТолькоПросмотр Тогда
            Форма.ПоказатьВыборИзМеню(ОповещениеОЗакрытии, СписокКоманд, Форма.Элементы.ЦеныИВалюта);
        КонецЕсли;
    Иначе
        ОткрытьФорму("ОбщаяФорма.ФормаЦеныИВалюта", СтруктураПараметров,,,,,ОповещениеОЗакрытии);
    КонецЕсли;
   Kondarat
 
56 - 18.07.18 - 15:48
(55) А что в ОповещениеОЗакрытии?
   Масянька
 
57 - 18.07.18 - 15:49
(56)     ОповещениеОЗакрытии = Новый ОписаниеОповещения("ОбработатьИзмененияПоКнопкеЦеныИВалютыЗавершение", ЭтотОбъект, ДополнительныеПараметры);
   Kondarat
 
58 - 18.07.18 - 15:50
(57) Что в процедуре ОбработатьИзмененияПоКнопкеЦеныИВалютыЗавершение?
   Масянька
 
59 - 18.07.18 - 15:50
Я вам всю процедуру положу:
Процедура ОбработатьИзмененияПоКнопкеЦеныИВалюты(Форма)

    Объект = Форма.Объект;
    
    ЭтоКомиссия = ПоступлениеТоваровУслугФормыКлиентСервер.ПолучитьРеквизитФормы(Форма, "ЭтоКомиссия");

    // Формирование структуры параметров для заполнения формы "Цены и Валюта".

    СтруктураПараметров = Новый Структура;
    СтруктураПараметров.Вставить("ВалютаДокумента"     , Объект.ВалютаДокумента);
    СтруктураПараметров.Вставить("Курс"                , Объект.КурсВзаиморасчетов);
    СтруктураПараметров.Вставить("Кратность"           , Объект.КратностьВзаиморасчетов);
    СтруктураПараметров.Вставить("Контрагент"          , Объект.Контрагент);
    СтруктураПараметров.Вставить("Договор"             , Объект.ДоговорКонтрагента);
    СтруктураПараметров.Вставить("Организация"         , Объект.Организация);
    СтруктураПараметров.Вставить("ДатаДокумента"       , Объект.Дата);
    
    Если Объект.ВидОперации <> ПредопределенноеЗначение("Перечисление.ВидыОперацийПоступлениеТоваровУслуг.УслугиЛизинга")
        И Объект.ВидОперации <> ПредопределенноеЗначение("Перечисление.ВидыОперацийПоступлениеТоваровУслуг.ОбъектыСтроительства")
        И Объект.ВидОперации <> ПредопределенноеЗначение("Перечисление.ВидыОперацийПоступлениеТоваровУслуг.ОсновныеСредства") Тогда
        СтруктураПараметров.Вставить("ТипЦен", Объект.ТипЦен);
    КонецЕсли;
    
    СтруктураПараметров.Вставить("ТолькоПросмотр"      , Форма.ТолькоПросмотр);
    
    Если Не Форма.ПлательщикНДС Тогда
        СтруктураПараметров.Вставить("НДСНеВыделять"       , Объект.НДСНеВыделять);
    КонецЕсли;
    
    Если Объект.ВидОперации = ПредопределенноеЗначение("Перечисление.ВидыОперацийПоступлениеТоваровУслуг.ВПереработку")
        Тогда
        СтруктураПараметров.Вставить("ЭтоПоступление", Истина);
    Иначе
        Если НЕ ЭтоКомиссия Тогда
            СтруктураПараметров.Вставить("НДСВключенВСтоимость", Объект.НДСВключенВСтоимость);
        КонецЕсли;
        СтруктураПараметров.Вставить("СуммаВключаетНДС", Объект.СуммаВключаетНДС);
    КонецЕсли;

    ДополнительныеПараметры = Новый Структура;
    ДополнительныеПараметры.Вставить("Форма", Форма);
    
    Если (НЕ Форма.РаздельныйУчетНДСНаСчете19 И НЕ ЭтоКомиссия И НЕ Объект.НДСНеВыделять)
        ИЛИ Форма.ИспользоватьТипыЦенНоменклатуры
        ИЛИ (Форма.ЕстьВалютныйУчет И Объект.ВалютаДокумента <> Форма.ВалютаРегламентированногоУчета)
        ИЛИ Форма.РасчетыВУЕ Тогда 
        
        ОткрыватьИзМеню = Ложь;
    Иначе
        ОткрыватьИзМеню = Истина;
        Если Форма.ПлательщикНДС Тогда
            СтруктураПараметров.Вставить("НДСНеВыделять", Ложь);
        КонецЕсли;
        ДополнительныеПараметры.Вставить("СтруктураПараметровКоманды", СтруктураПараметров);
    КонецЕсли;
    
    ОповещениеОЗакрытии = Новый ОписаниеОповещения("ОбработатьИзмененияПоКнопкеЦеныИВалютыЗавершение", ЭтотОбъект, ДополнительныеПараметры);
    
    Если ОткрыватьИзМеню Тогда
        
        СписокКоманд = Новый СписокЗначений;
        Если Не Форма.ПлательщикНДС Тогда
            СписокКоманд.Добавить(ПредопределенноеЗначение("Перечисление.ВариантыРасчетаНДС.НДСНеВыделять"));
        КонецЕсли;
        СписокКоманд.Добавить(ПредопределенноеЗначение("Перечисление.ВариантыРасчетаНДС.НДССверху"));
        СписокКоманд.Добавить(ПредопределенноеЗначение("Перечисление.ВариантыРасчетаНДС.НДСВСумме"));
        Если НЕ Форма.ТолькоПросмотр Тогда
            Форма.ПоказатьВыборИзМеню(ОповещениеОЗакрытии, СписокКоманд, Форма.Элементы.ЦеныИВалюта);
        КонецЕсли;
    Иначе
        ОткрытьФорму("ОбщаяФорма.ФормаЦеныИВалюта", СтруктураПараметров,,,,,ОповещениеОЗакрытии);
    КонецЕсли;
    
КонецПроцедуры
   Kondarat
 
60 - 18.07.18 - 15:53
(59) Дык это не та процедура.
   Масянька
 
61 - 18.07.18 - 15:53
(58) Процедура ОбработатьИзмененияПоКнопкеЦеныИВалютыЗавершение(РезультатЗакрытия, ДополнительныеПараметры) Экспорт
    
    Форма = ДополнительныеПараметры.Форма;
    Объект = Форма.Объект;

    Если ДополнительныеПараметры.Свойство("СтруктураПараметровКоманды") Тогда
        
        СтруктураЦеныИВалюта = ДополнительныеПараметры.СтруктураПараметровКоманды;
        
        СуммаВключаетНДСДоИзменения = СтруктураЦеныИВалюта.СуммаВключаетНДС;
        
        Если РезультатЗакрытия = Неопределено Тогда 
            Возврат;
        ИначеЕсли РезультатЗакрытия.Значение = ПредопределенноеЗначение("Перечисление.ВариантыРасчетаНДС.НДСНеВыделять") Тогда
            СтруктураЦеныИВалюта.НДСНеВыделять        = Истина;
            СтруктураЦеныИВалюта.СуммаВключаетНДС     = Истина;
        ИначеЕсли РезультатЗакрытия.Значение = ПредопределенноеЗначение("Перечисление.ВариантыРасчетаНДС.НДСВСумме") Тогда
            СтруктураЦеныИВалюта.НДСНеВыделять         = Ложь;
            СтруктураЦеныИВалюта.СуммаВключаетНДС     = Истина;
        Иначе
            СтруктураЦеныИВалюта.НДСНеВыделять         = Ложь;
            СтруктураЦеныИВалюта.СуммаВключаетНДС     = Ложь;
        КонецЕсли;
        
        СтруктураЦеныИВалюта.Вставить("ПерезаполнитьЦены",    Ложь);
        СтруктураЦеныИВалюта.Вставить("ПересчитатьЦены",      Ложь);
        СтруктураЦеныИВалюта.Вставить("ПересчитатьНДС",       СуммаВключаетНДСДоИзменения <> СтруктураЦеныИВалюта.СуммаВключаетНДС);
        СтруктураЦеныИВалюта.Вставить("БылиВнесеныИзменения", СуммаВключаетНДСДоИзменения <> СтруктураЦеныИВалюта.СуммаВключаетНДС
            ИЛИ Объект.НДСНеВыделять <> СтруктураЦеныИВалюта.НДСНеВыделять);

    Иначе
        СтруктураЦеныИВалюта = РезультатЗакрытия;
    КонецЕсли;
    
    Если ТипЗнч(СтруктураЦеныИВалюта) = Тип("Структура") И СтруктураЦеныИВалюта.БылиВнесеныИзменения Тогда
        
        ВалютаДоИзменения    = Объект.ВалютаДокумента;
        КурсДоИзменения      = Объект.КурсВзаиморасчетов;
        КратностьДоИзменения = Объект.КратностьВзаиморасчетов;
        
        Если СтруктураЦеныИВалюта.Свойство("ТипЦен") Тогда
            Объект.ТипЦен              = СтруктураЦеныИВалюта.ТипЦен;
        КонецЕсли;
        Объект.ВалютаДокумента         = СтруктураЦеныИВалюта.ВалютаДокумента;
        Объект.КурсВзаиморасчетов      = СтруктураЦеныИВалюта.Курс;
        Объект.КратностьВзаиморасчетов = СтруктураЦеныИВалюта.Кратность;
        Объект.СуммаВключаетНДС        = СтруктураЦеныИВалюта.СуммаВключаетНДС;
        Объект.НДСНеВыделять           = СтруктураЦеныИВалюта.НДСНеВыделять;
        Если СтруктураЦеныИВалюта.Свойство("НДСВключенВСтоимость") Тогда
            Объект.НДСВключенВСтоимость    = СтруктураЦеныИВалюта.НДСВключенВСтоимость;
        КонецЕсли;
        
        Форма.Модифицированность = Истина;
        
        Форма.ПриИзмененииЦеныИВалюты(
            ВалютаДоИзменения, 
            КурсДоИзменения,
            КратностьДоИзменения,
            СтруктураЦеныИВалюта.ПерезаполнитьЦены,
            СтруктураЦеныИВалюта.ПересчитатьЦены,
            СтруктураЦеныИВалюта.ПересчитатьНДС);
            
        Форма.ОбновитьОтображениеДанных();    
    
    КонецЕсли;
    
КонецПроцедуры
   Масянька
 
62 - 18.07.18 - 15:53
(60) Блин... Я искала :(
   Kondarat
 
63 - 18.07.18 - 15:56
Вот тут

Объект.СуммаВключаетНДС        = СтруктураЦеныИВалюта.СуммаВключаетНДС;
        Объект.НДСНеВыделять           = СтруктураЦеныИВалюта.НДСНеВыделять;
        Если СтруктураЦеныИВалюта.Свойство("НДСВключенВСтоимость") Тогда
            Объект.НДСВключенВСтоимость    = СтруктураЦеныИВалюта.НДСВключенВСтоимость;
        КонецЕсли;
Значения присваиваются соответствующим реквизитам.
Значит и надо смотреть выгрузку таких реквизитов как СуммаВключаетНДС, НДСНеВыделять и НДСВключенВСтоимость.
   Масянька
 
64 - 18.07.18 - 16:01
(63) При выгрузке:

Начало выгрузки:   18.07.2018 16:00:04
НДСВключенВСтоимость - ложь
СуммаВключаетНДС - ложь
НДСНеВыделять - ложь
НДСВключенВСтоимость - ложь
СуммаВключаетНДС - ложь
НДСНеВыделять - ложь
НДСВключенВСтоимость - ложь
СуммаВключаетНДС - ложь
НДСНеВыделять - ложь
НДСВключенВСтоимость - ложь
СуммаВключаетНДС - ложь
НДСНеВыделять - ложь
НДСВключенВСтоимость - ложь
СуммаВключаетНДС - ложь
НДСНеВыделять - ложь
НДСВключенВСтоимость - ложь
СуммаВключаетНДС - ложь
НДСНеВыделять - ложь
НДСВключенВСтоимость - ложь
СуммаВключаетНДС - ложь
НДСНеВыделять - ложь
НДСВключенВСтоимость - ложь
СуммаВключаетНДС - ложь
НДСНеВыделять - ложь
НДСВключенВСтоимость - ложь
СуммаВключаетНДС - ложь
НДСНеВыделять - ложь

Окончание выгрузки: 18.07.2018 16:00:05

Выгружено объектов: 314
   Масянька
 
65 - 18.07.18 - 16:01
(64) Ровно 9 док-ов.
   Масянька
 
66 - 18.07.18 - 16:08
А вот то, что загрузилось в бухию - https://pastenow.ru/52b5ffd4ed8cf1cc5af806a2d70ac255.
НДС сверху...
   Kondarat
 
67 - 18.07.18 - 16:09
В ПКС Документа есть эти реквизиты?
   Масянька
 
68 - 18.07.18 - 16:16
(67) https://pastenow.ru/90a41f30f3ac4760f82ab41b5e606290
Остальные ниже, выше.
   Kondarat
 
69 - 18.07.18 - 16:18
Судя по всему НДСВключенВСтоимость у тебя перед выгрузкой переопределыется...
   user-ok
 
70 - 18.07.18 - 16:18
(68) Судя по значку -там что-то в обработчиках написано. покажь
   Масянька
 
71 - 18.07.18 - 16:22
(69) (70) https://pastenow.ru/3313fcd5f8c7d97114a4d7fd1432d7b5
Эх... Пропал во мне Пикассо... :(
   Kondarat
 
72 - 18.07.18 - 16:26
>>НДС сверху...
А где он должен быть если в источнике СуммаВключаетНДС=Ложь
   Масянька
 
73 - 18.07.18 - 16:31
(72) А я в (50) написала, что нет его в реквизитах док-а, а на форме хрень какая-то... Которая как-то хреново закручена... И хочется сделать не хреново...
   user-ok
 
74 - 18.07.18 - 16:33
(73) его не может не быть в реквизитах дока
   Kondarat
 
75 - 18.07.18 - 16:34
(73) В реквизитах документа он есть. Просто редактируется в УТ не напрямую, а через открытие дополнительной формы. Возьми какой-нибудь документ, установи флаг УчитыватьНДС и СуммаВключаетНДС и выгрузи. Думаю результат тебя порадует.
   Масянька
 
76 - 18.07.18 - 16:36
   Масянька
 
77 - 18.07.18 - 16:38
(75) Это не в УТ, а в Бухии. Или о чем речь?
И у меня выгрузка из УТ в Бухию (универсальная, правила и пр.).
   Kondarat
 
78 - 18.07.18 - 16:38
В Бухии между КурсВзаиморасчетов и СуммаДокумента
   Kondarat
 
79 - 18.07.18 - 16:39
(77) В УТ открой формы ЦеныИВалюта и там протыкай галки, потом в бухию...
   Масянька
 
80 - 18.07.18 - 16:40
(78) НДСВключенВСтоимость?
   Масянька
 
81 - 18.07.18 - 16:41
(79) А зачем?
Нету НДС... Нету... Совсем... ИП это.
   Kondarat
 
82 - 18.07.18 - 16:42
(81)Тогда, что тебя так парит эта надпись?
   Масянька
 
83 - 18.07.18 - 16:56
(82) Хочу красиво и правильно.
Если нету НДС - почему надпись есть?
   Масянька
 
84 - 18.07.18 - 17:46
Слушайте, я тут подолбилась немножко...
А, вообще, вариант настроить НДС для подстановки в док-ты? Ну, как раньше было (в семерке, в 8.2).
   user-ok
 
85 - 19.07.18 - 11:02
(84) это как?
   Масянька
 
86 - 19.07.18 - 11:07
   user-ok
 
87 - 19.07.18 - 11:32
это всего лишь ставка НДС, которая подставится в новые документы. А ты переносишь готовые с уже заполненными ставками, значениями, паролями, явками.... )))
   Масянька
 
88 - 19.07.18 - 11:34
К КД не относится, но не буду делать новую тему.
Бух 3.3.62.17.
Док-т поступление товаров и услуг.
Форма документа товары.
В ТЧ есть колонка "Счет НДС".
Видимость этой колонки прописана тут:
Процедура УстановитьВидимостьСчетовУчета()
    
    ЭлементыСчетов = Новый Массив(); 
    ЭлементыСчетов.Добавить("ТоварыСчетУчета");
    ЭлементыСчетов.Добавить("ТоварыСчетУчетаНДС");
    ЭлементыСчетов.Добавить("ТоварыСпособУчетаНДС");
    
    // Поле формы ПорядокУчетаРасчетов содержит счета и другие реквизиты.

    // Поэтому видимостью этого поля управляем в УчетВзаиморасчетовФормы.УстановитьПорядокУчетаРасчетов()

    
    СчетаУчетаВДокументах.УстановитьВидимостьСчетовУчета(Элементы, ЭлементыСчетов);
    
КонецПроцедуры
И тут
Процедура УстановитьВидимостьСчетовУчета(Элементы, ЭлементыСчетов) Экспорт
    
    ПользовательУправляетСчетамиУчета = СчетаУчетаВДокументахВызовСервераПовтИсп.ПользовательУправляетСчетамиУчета();
    
    Для Каждого ЭлементСчет Из ЭлементыСчетов Цикл
        Если Элементы.Найти(ЭлементСчет) <> Неопределено Тогда
            Элементы[ЭлементСчет].Видимость = ПользовательУправляетСчетамиУчета;
сообщить("1 - " + ЭлементСчет + " - " + ПользовательУправляетСчетамиУчета);            
        КонецЕсли;
    КонецЦикла;
        
КонецПроцедуры
Сообщить выводит
1 - ТоварыСчетУчета - Да
1 - ТоварыСчетУчетаНДС - Да
1 - ТоварыСпособУчетаНДС - Да
а счет НДС в ТЧ нет.
Скажите мне - где устанавливается видимость?



Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует