Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Вопрос по правам доступа

Вопрос по правам доступа
Я
   gamar20
 
12.07.18 - 14:42
Здравствуйте. Имеется "Управление торговлей", редакция 10.3 (10.3.13.2)
, с дописанными модулями. 
с 1С торговлей работают 40 человек, и вот, поставили задачу, выяснить кто имеет право на чтение/редактирование раздела: Документы > Денежные средства > Касса.
Как и где посмотреть список пользователей, у кого есть полномочия такие?

P.S. Заранее прошу подробно описать куда зайти и что тыкать, так как я не администратор 1С. Он у нас на аутсорсинге и то в отпуске, а это надо выяснить как можно быстрее.
 
 
   DrShad
 
1 - 12.07.18 - 14:52
администратор 1С это как?
   gamar20
 
2 - 12.07.18 - 14:54
(1) начинается.. ну программист 1С
P.S. админский доступ к конфигуратору у меня есть
   LeoKeyn
 
3 - 12.07.18 - 14:55
(0) Два щелчка на объект (в данном случае я так понимаю это документ кассы) в конфигураторе. Вкладка права. Смотришь у каких прав есть доступ на этот объект, а потом проверяешь кому из пользователей присвоены эти права ^_^
   DrShad
 
4 - 12.07.18 - 14:58
на ИСе есть несколько обработок, которые могут сильно помочь несведущему
   LeoKeyn
 
5 - 12.07.18 - 14:58
(3)* Извиняюсь "у каких прав" "у каких ролей*" а потом смотришь кому эти роли присвоены из пользователей ^_^
   Гипервизор
 
6 - 12.07.18 - 15:10
(0) Расшифруйте чтение/редактирование:
просмотр, чтение, изменение, редактирование? Или все вместе?
   Cyberhawk
 
7 - 12.07.18 - 15:15
"я не администратор 1С. Он у нас на аутсорсинге и то в отпуске" // Сколько платите ему?
   Гипервизор
 
8 - 12.07.18 - 15:19
Ну вот.. ТС ушел, а интрига осталась. Как дальше жить..
   gamar20
 
9 - 12.07.18 - 15:38
(6) интересует чтение и изменение/редактирование
   gamar20
 
10 - 12.07.18 - 15:41
(3)
А где там "денежные средства" ?
http://images.vfl.ru/ii/1531399269/92b6b70a/22455332.jpg
В документах его нет.
 
 Рекламное место пустует
   Гипервизор
 
11 - 12.07.18 - 15:43
(9)
Юзеры = ПользователиИнформационнойБазы.ПолучитьПользователей();

КассовыеДокументы = Новый Массив;
КассовыеДокументы.Добавить(Метаданные.Документы.ПриходныйКассовыйОрдер);
КассовыеДокументы.Добавить(Метаданные.Документы.РасходныйКассовыйОрдер);
КассовыеДокументы.Добавить(Метаданные.Документы.ВнутреннееПеремещениеНаличныхДенежныхСредств);
КассовыеДокументы.Добавить(Метаданные.Документы.ОбъявлениеНаВзносНаличными);
КассовыеДокументы.Добавить(Метаданные.Документы.ДенежныйЧек);

ПраваДоступа = Новый Массив;
ПраваДоступа.Добавить("Чтение");
ПраваДоступа.Добавить("Просмотр");
ПраваДоступа.Добавить("Изменение");
ПраваДоступа.Добавить("Редактирование");

Для каждого Юзер Из Юзеры  Цикл
    Для каждого КассовыйДокумент Из КассовыеДокументы Цикл
        Для каждого ПравоДоступа Из ПраваДоступа Цикл
            Если ПравоДоступа(ПравоДоступа, КассовыйДокумент, Юзер) Тогда
                Сообщить(Строка(Юзер) + ": " + Строка(КассовыйДокумент) + " (" + ПравоДоступа + ")");
            КонецЕсли;
        КонецЦикла;
    КонецЦикла;
КонецЦикла;    

500 рублей в кассу Мисты, следующий! ))
   gamar20
 
12 - 12.07.18 - 15:45
(11) к сожалению я не знаю как применять этот скрипт, да и боюсь угробить базу или права все сбить.
Мне надо только посмотреть и все.
   Гипервизор
 
13 - 12.07.18 - 15:54
(12) Можно подумать я вам предлагаю "комбинированный бормотограф с пылесосом", а не "посмотреть".
А если не верите, что это не "патч Брамина в 1С", тогда - пичалька) Остается только рыдать)
"Серебряной пули" в виде одной кнопочки под вашу индивидуальную хотелку в 1С нет. Тупик. Даже если вам скинут готовую обработку - вдруг она тоже угробит базу??
   gamar20
 
14 - 12.07.18 - 15:58
(13) а то что вы скинули, это что такое ? И что с ним делать?
   Гипервизор
 
15 - 12.07.18 - 16:02
(14) А вы вообще кто в данной организации? Человек с доступом к конфигуратору, получивший такую странную задачу, но ни в зуб ногой в 1с? Очень странно..
Это код, который можно запустить в консоли кода или оформить в виде обработки, которую и запустить в режиме Предприятия. И вам просто будет выведен список вида "юзер - документ - право".
   gamar20
 
16 - 12.07.18 - 16:08
(15)
> Это код, который можно запустить в консоли кода или оформить в виде обработки
Я создал резервный БД, на нем могу выполнить.
сможете делать, пожалуйста обработчика, чтоб запустить его в 1С ? я не знаю где там консоль.
   gamar20
 
17 - 13.07.18 - 09:12
НУ что ребята, никто не сможет из исходника делать обработчика, чтоб выполнил в торговле?
ну или сказать где там консоль и как выполнить код?
   ildary
 
18 - 13.07.18 - 09:30
(17) Медленно положите конфигуратор на землю и не трогайте его больше. Задача подождет вашего разработчика из отпуска.
   DrWatson
 
19 - 13.07.18 - 10:39
(17) Создать обработку не сложно. Там всё интерактивно.
1. Меню Файл - создать внешнюю обработку
2. Строчка Формы - создать новую. В помощнике жать "Далее" пока не откроет форму.
3. В экране настройки формы найти закладку "Команды" - "Команды формы". Добавить новую. В свойствах справа найти Действие, нажать лупу, выбрать "создать клиент и сервер". В серверной процедуре написать указанный код.
Внизу окна закладки - переключиться обратно на форму. Созданную команду перетащить на форму. обработку сохранить.
4. Открыть обработку в режиме Предприятия, нажать кнопку, смотреть что напишет в окне сообщений внизу.
   Гипервизор
 
20 - 13.07.18 - 10:47
(19) В сабже УТ 10.3, зачем грузить человека клиент-серверной идеологией и УФ? )
   DrWatson
 
21 - 13.07.18 - 11:06
(20) Сорри. Много лет не видел обычные формы, забыл уже что такие бывают.
   gamar20
 
22 - 13.07.18 - 11:14
Все лишь бы умничать и критиковать. а по делу написать, сказать как делать - видите ли, кишка тонка.
Такая простая задача, даже код уже дали, но вот как его запустить - никто не знает.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует