Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

УПП 1.3 Выплаты физлицу за услуги

УПП 1.3 Выплаты физлицу за услуги
Я
   dchumak
 
12.07.18 - 04:32
Добрый день.

В компании используется выплата сотрудникам за аренду автомобиля. Создано новое начисление "Аренда ТС", с кодом 2400. Облагается НДФЛ, но, не облагается страховыми взносами.

Эти начисления рассчитываются отдельными документами расчета зарплаты и выплачиваются отдельным РКО с видом операции "Выплата зп".

В свете изменений 54 ФЗ с 1 июля мы обязаны при выплатах физлицам за услуги, к которым относится и выплата за аренду ТС, пробивать чек расхода по ККТ.

Но, в УПП пробитие чека расхода возможно только для РКО с операцией "Возврат поставщику" и "Прочий расход". Если делать РКО на выплату как прочий расход, то не закрываются данные зп по упр. учету (взаиморасчеты с сотрудниками, ндфл и т.д.), остаются долги за предприятием в расчетных ведомостях и листах.

Как правильно это сделать? Допилить УПП, чтобы пробивать чек из РКО с типом выплаты зп, или вообще переводить эти выплаты на прочие расходы и регистрировать ндфл вручную?

УПП 1.3 последняя версия.
 
 
   assasu
 
1 - 12.07.18 - 05:25
(0) мы поставили штрих и научили бухгалтеров бить чек прямо из драйвера
   dchumak
 
2 - 12.07.18 - 05:46
(1) мне кажется, не совсем верное решение, т.к. часть чеков пробивается из 1С (оплата реализаций, чеки ккм), а часть вручную
   assasu
 
3 - 12.07.18 - 05:48
(2) мы начали с нуля. никаких чеков у нас не было до этого момента
   dchumak
 
4 - 12.07.18 - 05:53
Посмотрел в коде, если в форме РКО в процедуре УстановитьВидимость() подкорректировать значение переменной МожноПробитьЧек = (ВидОперации = Перечисления.ВидыОперацийРКО.ВозвратДенежныхСредствПокупателю)
        ИЛИ (ВидОперации = Перечисления.ВидыОперацийРКО.РасходДенежныхСредствПрочее) 
        ИЛИ (ВидОперации = Перечисления.ВидыОперацийРКО.ВыплатаЗаработнойПлатыПоВедомостям);
то в коде дальше ничего (теоретически не должно поломаться). 
Процедура пробития чека не привязывается к операции РКО, а считает РКО по умолчанию расходом 

МенеджерОборудованияВызовСервера.ПодготовитьДанныеДляФискализацииЧека(Ссылка, ПараметрыЧека, ВерсияФормата, 
                ПолучитьСерверТО().ПолучитьМодель(ФУ), Выдать, Основание);

Выдать = Реквизит рко, текст.
Основание = Реквизит рко, текст.

Если ОбщиеПараметры.МетаданныеОбъекта.Реквизиты.Найти("ВидОперации") <> Неопределено Тогда
        ВидОперации = Ссылка.ВидОперации;
    Иначе
        ВидОперации = "";
    КонецЕсли;
    
    Если ВидОперации = Перечисления.ВидыОперацийПКО.ВозвратДенежныхСредствПоставщиком Тогда
        ИмяТипаРасчета = "ВозвратРасходаДенежныхСредств";
    ИначеЕсли ТипЗнч(Ссылка) = Тип("ДокументСсылка.ВозвратТоваровОтПокупателя") ИЛИ 
        ВидОперации = Перечисления.ВидыОперацийРКО.ВозвратДенежныхСредствПокупателю ИЛИ 
        ВидОперации = Перечисления.ВидыОперацийОплатаОтПокупателяПлатежнойКартой.ВозвратДенежныхСредствПокупателю Тогда
        ИмяТипаРасчета = "ВозвратДенежныхСредств";
    ИначеЕсли ТипЗнч(Ссылка) = Тип("ДокументСсылка.РасходныйКассовыйОрдер") Тогда
        // РКО - все остальные виды операций

        ИмяТипаРасчета = "РасходДенежныхСредств";
    Иначе
        // РТУ и ПКО, ОПК - все остальные виды операций

        ИмяТипаРасчета = "ПриходДенежныхСредств";
    КонецЕсли;

Это будет не товарный документ

ЭтоТоварныйДокумент = ТипЗнч(Ссылка) = Тип("ДокументСсылка.РеализацияТоваровУслуг") ИЛИ 
        ТипЗнч(Ссылка) = Тип("ДокументСсылка.ВозвратТоваровОтПокупателя") ИЛИ
        ТипЗнч(Ссылка) = Тип("ДокументСсылка.АктОбОказанииПроизводственныхУслуг");
        
    Если ЭтоТоварныйДокумент Тогда
        
        Если Ссылка.ВалютаДокумента = глЗначениеПеременной("ВалютаРегламентированногоУчета") Тогда
            КурсОплаты = 1;
        Иначе
            КурсОплаты = Ссылка.КурсВзаиморасчетов / Ссылка.КратностьВзаиморасчетов;
        КонецЕсли;
        
        ЗаполнитьОплатыДляТоварногоДокумента(Ссылка, ОбщиеПараметры, КурсОплаты);
        
        ЗаполнитьТоварныеПозицииДляТоварногоДокумента(Ссылка, ОбщиеПараметры, КурсОплаты);
        
    Иначе
        
        ЗаполнитьОплатыДляПлатежногоДокумента(Ссылка, ОбщиеПараметры);
        
        РасчетыСПокупателем = (ВидОперации = ПредопределенноеЗначение("Перечисление.ВидыОперацийПКО.ОплатаПокупателя"))
            ИЛИ (ВидОперации = ПредопределенноеЗначение("Перечисление.ВидыОперацийРКО.ВозвратДенежныхСредствПокупателю"))
            ИЛИ (ТипЗнч(Ссылка) = Тип("ДокументСсылка.ОплатаОтПокупателяПлатежнойКартой"));
        ЭтоВозврат = (ВидОперации = ПредопределенноеЗначение("Перечисление.ВидыОперацийОплатаОтПокупателяПлатежнойКартой.ВозвратДенежныхСредствПокупателю"))
            ИЛИ (ТипЗнч(Ссылка) = Тип("ДокументСсылка.РасходныйКассовыйОрдер"));
        
        ЗаполнитьТоварныеПозицииДляПлатежногоДокумента(Ссылка, ОбщиеПараметры, 
            РасчетыСПокупателем, ЭтоВозврат, КомуОтКого, Основание);
        
    КонецЕсли;

С оплатой наличными, процедура ЗаполнитьОплатыДляПлатежногоДокумента(Ссылка, ОбщиеПараметры);  - т.к. РКО

Далее заполнятся данные расшифровки платежа, куда подставятся заполненные данные Выдать, Основание со вкладки "Печать"

Процедура ЗаполнитьТоварныеПозицииДляПлатежногоДокумента(Ссылка, ОбщиеПараметры, РасчетыСПокупателем, ЭтоВозврат, КомуОтКого, Основание)
    
    ПривилегированныйРежимДо = ПривилегированныйРежим();
    УстановитьПривилегированныйРежим(Истина);
    
    Если ЭтоВозврат Тогда
        Заголовок = "Выдать: ";
    Иначе
        Заголовок = "Принято от: ";
    КонецЕсли;
    НаименованиеПредметаРасчета = Заголовок + КомуОтКого + " Основание: " + Основание;
    Если Не РасчетыСПокупателем Тогда
        Для Каждого СтрокаПлатежа Из Ссылка.РасшифровкаПлатежа Цикл
            ЗаполнитьФиктивнуюСтрокуЧека(ОбщиеПараметры, СтрокаПлатежа, НаименованиеПредметаРасчета);
        КонецЦикла;
        Возврат;
    КонецЕсли;
   dchumak
 
5 - 12.07.18 - 05:56
(3) ну выплату физлицу за услуги (1 строчку) можно пробить из драйвера. А если реализация на 50 или более товарных позиций?

Думаю стоит попробовать доработать пробитие чека на выплату зп, и попробовать пробить один чек.

Расчетчику дополнительная работа - раньше все было в одной выплате зп и одном РКО, теперь нужно на каждого сотрудника, получающего такую выплату формировать отдельный расчет, и отдельный РКО...
   assasu
 
6 - 12.07.18 - 06:16
(6) в сети есть обработки которые позволяют бить что угодно на каких угодно кассах. ну а подпилить это под себя уже никаких трудностей не вызывает
   spectre1978
 
7 - 12.07.18 - 06:38
(5) сделать это частью ЗП не вариант? Премия, например.
   dchumak
 
8 - 12.07.18 - 09:21
(7)
1) если сделать это доходом (код 2000), то такой доход облагается страховыми взносами, так же, как и договоры ГПХ. Мы же сделали с кодом 2400, НДФЛ облагается, а страховыми взносами нет.
2) выплата такого дохода официально дает возможность ставить его в расходы (у нас УСН д-р).
   Флориан
 
9 - 12.07.18 - 10:04
Не совсем в тему - может кому будет полезно:

— Среди обязательных реквизитов кассового чека есть признак расчета «расход», который вызвал много вопросов. К примеру, следует ли пробивать чек с признаком «расход» при выплате физлицу арендной платы по договору аренды? Нужно ли применять ККТ при выплате физлицам вознаграждения (наличными и безналичными) по договорам ГПХ за оказанные ими услуги/выполненные работы?
— Признак расчета «расход» в кассовом чеке означает выдачу средств покупателю (клиенту). Поэтому во всех ситуациях, когда компании (ИП) выплачивают деньги (наличными или с помощью электронных средств платежа) физлицу, включая выплаты по договорам ГПХ или аренды, они должны применить ККТ и сформировать кассовый чек с признаком расчета «расход», за исключением случаев, когда организации (ИП) освобождены от применения ККТ или когда срок перехода на новый порядок применения ККТ отсрочен до 01.07.2019. «Расходный» чек понадобится и при выплате другому юрлицу (ИП) наличных денег.

http://glavkniga.ru/news/6760

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует